summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-06 07:44:32 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-06 07:44:32 +0000
commit6295f08684080b8dd778446e1403b7a96782ceed (patch)
tree68ff7d7d25884c75058beeab9615b414b5ca77a1 /sys-auth/ykpers
parentVersion bump, bug#524564 (diff)
downloadgentoo-2-6295f08684080b8dd778446e1403b7a96782ceed.tar.gz
gentoo-2-6295f08684080b8dd778446e1403b7a96782ceed.tar.bz2
gentoo-2-6295f08684080b8dd778446e1403b7a96782ceed.zip
sys-auth/ykpers: Version Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-auth/ykpers')
-rw-r--r--sys-auth/ykpers/ChangeLog8
-rw-r--r--sys-auth/ykpers/metadata.xml5
-rw-r--r--sys-auth/ykpers/ykpers-1.16.0.ebuild39
3 files changed, 49 insertions, 3 deletions
diff --git a/sys-auth/ykpers/ChangeLog b/sys-auth/ykpers/ChangeLog
index 41d2d5521e84..ef517ded2b59 100644
--- a/sys-auth/ykpers/ChangeLog
+++ b/sys-auth/ykpers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/ykpers
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.12 2014/08/19 02:33:08 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.13 2014/10/06 07:44:32 jlec Exp $
+
+*ykpers-1.16.0 (06 Oct 2014)
+
+ 06 Oct 2014; Justin Lecher <jlec@gentoo.org> +ykpers-1.16.0.ebuild,
+ metadata.xml:
+ Version Bump
*ykpers-1.15.2 (19 Aug 2014)
diff --git a/sys-auth/ykpers/metadata.xml b/sys-auth/ykpers/metadata.xml
index 5b1dadacc9b9..3a896d143b24 100644
--- a/sys-auth/ykpers/metadata.xml
+++ b/sys-auth/ykpers/metadata.xml
@@ -13,10 +13,11 @@
<description>Proxy maintainer, CC him on bugs</description>
</maintainer>
<upstream>
- <remote-id type="google-code">yubikey-personalization</remote-id>
+ <remote-id type="github">Yubico/yubikey-personalization</remote-id>
+ <bugs-to>https://github.com/Yubico/yubikey-personalization/issues</bugs-to>
</upstream>
<use>
- <flag name='consolekit'>
+ <flag name="consolekit">
Use <pkg>sys-auth/consolekit</pkg> and <pkg>virtual/udev</pkg>
to allow access to the YubiKey HID device to the console user.
</flag>
diff --git a/sys-auth/ykpers/ykpers-1.16.0.ebuild b/sys-auth/ykpers/ykpers-1.16.0.ebuild
new file mode 100644
index 000000000000..b714274c30e2
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.16.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.16.0.ebuild,v 1.1 2014/10/06 07:44:32 jlec Exp $
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ dodoc doc/*
+ prune_libtool_files
+
+ use consolekit && \
+ udev_dorules 70-yubikey.rules
+}