summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-05 11:09:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-05 11:09:42 +0000
commita71180f594dbe1820145dc865378c2ab33c78c0e (patch)
treea25c771e2e2e955daa87559304793ad25e1cb81b /sys-auth/polkit
parentMask USE="systemd" for sys-auth/polkit for keywording and testing. (diff)
downloadgentoo-2-a71180f594dbe1820145dc865378c2ab33c78c0e.tar.gz
gentoo-2-a71180f594dbe1820145dc865378c2ab33c78c0e.tar.bz2
gentoo-2-a71180f594dbe1820145dc865378c2ab33c78c0e.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/polkit')
-rw-r--r--sys-auth/polkit/ChangeLog10
-rw-r--r--sys-auth/polkit/metadata.xml3
-rw-r--r--sys-auth/polkit/polkit-0.104.ebuild97
3 files changed, 107 insertions, 3 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 7cf14035ee74..a6e597231b22 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/polkit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.61 2011/12/08 15:42:02 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.62 2012/01/05 11:09:42 ssuominen Exp $
+
+*polkit-0.104 (05 Jan 2012)
+
+ 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
+ metadata.xml:
+ Version bump.
08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
old
diff --git a/sys-auth/polkit/metadata.xml b/sys-auth/polkit/metadata.xml
index f2f1f7f9b41e..ef37ca45998b 100644
--- a/sys-auth/polkit/metadata.xml
+++ b/sys-auth/polkit/metadata.xml
@@ -7,6 +7,7 @@
<name>Nirbheek Chauhan</name>
</maintainer>
<use>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ <flag name='introspection'>Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ <flag name='systemd'>Use <pkg>sys-apps/systemd</pkg> instead of <pkg>sys-auth/consolekit</pkg> for session tracking</flag>
</use>
</pkgmetadata>
diff --git a/sys-auth/polkit/polkit-0.104.ebuild b/sys-auth/polkit/polkit-0.104.ebuild
new file mode 100644
index 000000000000..e7cb158a62f3
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.104.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.104.ebuild,v 1.1 2012/01/05 11:09:42 ssuominen Exp $
+
+EAPI=4
+inherit pam
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="http://hal.freedesktop.org/docs/polkit/"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples gtk +introspection kde nls pam systemd"
+
+RDEPEND=">=dev-libs/glib-2.30
+ dev-libs/expat
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ pam? ( virtual/pam )
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/intltool
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+PDEPEND="!systemd? ( >=sys-auth/consolekit-0.4.5[policykit] )
+ pam? ( sys-auth/pambase[consolekit] )
+ gtk? ( || ( >=gnome-extra/polkit-gnome-${PV} lxde-base/lxpolkit ) )
+ kde? ( sys-auth/polkit-kde-agent )"
+
+DOCS=( docs/TODO HACKING NEWS README )
+
+src_configure() {
+ local myauth="--with-authfw=shadow"
+ use pam && myauth="--with-authfw=pam --with-pam-module-dir=$(getpam_mod_dir)"
+
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --disable-static \
+ $(use_enable debug verbose-mode) \
+ --enable-man-pages \
+ $(use_enable doc gtk-doc) \
+ $(use_enable systemd) \
+ $(use_enable introspection) \
+ --disable-examples \
+ $(use_enable nls) \
+ --with-os-type=gentoo \
+ ${myauth}
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # We disable example compilation above, and handle it here
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/examples/{*.c,*.policy*}
+ fi
+
+ # Need to keep a few directories around...
+ diropts -m0700 -o root -g root
+ keepdir /var/lib/polkit-1
+ #keepdir /var/run/polkit-1 #387903
+}
+
+pkg_postinst() {
+ # Make sure that the user has consolekit sessions working so that the
+ # 'allow_active' directive in polkit action policies works
+ if has_version 'gnome-base/gdm' && ! has_version 'gnome-base/gdm[consolekit]'; then
+ # If user has GDM installed, but USE=-consolekit, warn them
+ ewarn "You have GDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using GDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if has_version 'kde-base/kdm' && ! has_version 'kde-base/kdm[consolekit]'; then
+ # If user has KDM installed, but USE=-consolekit, warn them
+ ewarn "You have KDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using KDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if ! has_version 'gnome-base/gdm[consolekit]' && \
+ ! has_version 'kde-base/kdm[consolekit]'; then
+ # Inform user about the alternative method
+ ewarn "If you don't use GDM or KDM for logging in,"
+ ewarn "you must start your desktop environment (DE) as follows:"
+ ewarn " ck-launch-session \$STARTGUI"
+ ewarn "Where \$STARTGUI is a DE-starting command such as 'gnome-session'."
+ ewarn "You should add this to your ~/.xinitrc if you use startx."
+ fi
+}