summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-08-26 16:32:46 +0000
committerUlrich Müller <ulm@gentoo.org>2013-08-26 16:32:46 +0000
commitfdf99bfe2daffd2119794dbcae438a1b263adba2 (patch)
treee1ad0a70d388c45e6264ba2a0d0f7860cf60db8c /sys-auth/pam_skey
parentChange dependencies to work with KDE 4.11, fixes bug 482322 (diff)
downloadgentoo-2-fdf99bfe2daffd2119794dbcae438a1b263adba2.tar.gz
gentoo-2-fdf99bfe2daffd2119794dbcae438a1b263adba2.tar.bz2
gentoo-2-fdf99bfe2daffd2119794dbcae438a1b263adba2.zip
Fix handling of status returned from skey_haskey. File access errors for the skeykeys file will now cause the module to return with status "authinfo_unavail" instead of "ignore".
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'sys-auth/pam_skey')
-rw-r--r--sys-auth/pam_skey/ChangeLog11
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r4.ebuild56
2 files changed, 65 insertions, 2 deletions
diff --git a/sys-auth/pam_skey/ChangeLog b/sys-auth/pam_skey/ChangeLog
index 7f5e5e434dbd..8f6cf3ba0df4 100644
--- a/sys-auth/pam_skey/ChangeLog
+++ b/sys-auth/pam_skey/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam_skey
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.22 2012/03/24 17:34:17 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.23 2013/08/26 16:32:46 ulm Exp $
+
+*pam_skey-1.1.5-r4 (26 Aug 2013)
+
+ 26 Aug 2013; Ulrich Müller <ulm@gentoo.org> +pam_skey-1.1.5-r4.ebuild:
+ Fix handling of status returned from skey_haskey. File access errors for
+ the skeykeys file will now cause the module to return with status
+ "authinfo_unavail" instead of "ignore".
24 Mar 2012; Ulrich Müller <ulm@gentoo.org> -pam_skey-1.1.5-r2.ebuild:
Remove old.
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r4.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r4.ebuild
new file mode 100644
index 000000000000..69e5ceceedd1
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/pam_skey-1.1.5-r4.ebuild,v 1.1 2013/08/26 16:32:46 ulm Exp $
+
+EAPI=5
+
+inherit eutils pam autotools multilib readme.gentoo
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://dkorunic.net/tarballs/${P}.tar.gz
+ mirror://gentoo/${P}-patches-5.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+DOCS="README INSTALL"
+DOC_CONTENTS="To use the pam_skey module, you need to configure PAM
+ by adding a line like:
+ \n\nauth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so\n
+ \nto an appropriate place in the /etc/pam.d/system-auth file.
+ Consult the README and INSTALL files in /usr/share/doc/${PF}
+ for detailed instructions.
+ \n\nPlease note that calling this module from unprivileged
+ applications, e.g. screensavers, is not supported.
+ \n\nError checking has become stricter in pam_skey-1.1.5-r4;
+ errors returned from the underlying skey library when accessing
+ the S/Key data base will no longer be ignored.
+ Make sure that your PAM configuration is correct."
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+ epatch_user
+
+ cd autoconf
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die "mv failed"
+}
+
+src_configure() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC"
+}
+
+pkg_postinst() {
+ case ${REPLACING_VERSIONS} in
+ 1.1.[45]|1.1.5-r[123]) FORCE_PRINT_ELOG=1 ;;
+ esac
+ readme.gentoo_print_elog
+}