summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-09-17 19:51:31 +0000
committerUlrich Müller <ulm@gentoo.org>2008-09-17 19:51:31 +0000
commit08d8aeab57dcbb3ea11f0782f637ea317a82fcf2 (patch)
treea873a6d80b220c4fa60590ec0f62e68b4eb98332 /sys-auth/otpcalc
parentversion bump (diff)
downloadgentoo-2-08d8aeab57dcbb3ea11f0782f637ea317a82fcf2.tar.gz
gentoo-2-08d8aeab57dcbb3ea11f0782f637ea317a82fcf2.tar.bz2
gentoo-2-08d8aeab57dcbb3ea11f0782f637ea317a82fcf2.zip
Fix SHA1 byte-order issue for conformance with RFC 2289.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'sys-auth/otpcalc')
-rw-r--r--sys-auth/otpcalc/ChangeLog9
-rw-r--r--sys-auth/otpcalc/files/otpcalc-0.97-sha1-byteorder.patch22
-rw-r--r--sys-auth/otpcalc/otpcalc-0.97-r4.ebuild (renamed from sys-auth/otpcalc/otpcalc-0.97-r3.ebuild)7
3 files changed, 36 insertions, 2 deletions
diff --git a/sys-auth/otpcalc/ChangeLog b/sys-auth/otpcalc/ChangeLog
index 8f0fe6930145..7e58c12fb574 100644
--- a/sys-auth/otpcalc/ChangeLog
+++ b/sys-auth/otpcalc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/otpcalc
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/otpcalc/ChangeLog,v 1.3 2008/08/20 23:09:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/otpcalc/ChangeLog,v 1.4 2008/09/17 19:51:31 ulm Exp $
+
+*otpcalc-0.97-r4 (17 Sep 2008)
+
+ 17 Sep 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/otpcalc-0.97-sha1-byteorder.patch, -otpcalc-0.97-r3.ebuild,
+ +otpcalc-0.97-r4.ebuild:
+ Fix SHA1 byte-order issue for conformance with RFC 2289.
*otpcalc-0.97-r3 (20 Aug 2008)
diff --git a/sys-auth/otpcalc/files/otpcalc-0.97-sha1-byteorder.patch b/sys-auth/otpcalc/files/otpcalc-0.97-sha1-byteorder.patch
new file mode 100644
index 000000000000..eb9fe8cf823a
--- /dev/null
+++ b/sys-auth/otpcalc/files/otpcalc-0.97-sha1-byteorder.patch
@@ -0,0 +1,22 @@
+--- otpCalc-0.97-orig/crypto.c 2001-06-26 10:22:52.000000000 +0200
++++ otpCalc-0.97/crypto.c 2008-09-17 20:55:10.000000000 +0200
+@@ -199,6 +199,8 @@
+ for (i = 0; i < 4; i++)
+ digest[i] ^= digest[i+16];
+
+- memcpy(message, digest, 8);
++ /* Fix byte order */
++ for (i = 0; i < 8; i++)
++ message[i] = digest[(i&4)+3-(i&3)];
+
+ }
+--- otpCalc-0.97-orig/BUGS 2001-05-07 08:23:38.000000000 +0200
++++ otpCalc-0.97/BUGS 2008-09-17 21:02:36.000000000 +0200
+@@ -16,3 +16,7 @@
+
+ Thanks,
+ Anthony
++
++Note: Above-mentioned SHA1 issue is fixed in the Gentoo version.
++The output now agrees with RFC 2289 and with S/Key.
++ - Ulrich Mueller <ulm@gentoo.org>
diff --git a/sys-auth/otpcalc/otpcalc-0.97-r3.ebuild b/sys-auth/otpcalc/otpcalc-0.97-r4.ebuild
index e44c52bfd34b..f5cb202f7ccd 100644
--- a/sys-auth/otpcalc/otpcalc-0.97-r3.ebuild
+++ b/sys-auth/otpcalc/otpcalc-0.97-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/otpcalc/otpcalc-0.97-r3.ebuild,v 1.1 2008/08/20 22:51:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/otpcalc/otpcalc-0.97-r4.ebuild,v 1.1 2008/09/17 19:51:31 ulm Exp $
inherit eutils
@@ -27,11 +27,16 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-man-table-format.diff"
epatch "${FILESDIR}/${P}-badindex.diff"
epatch "${FILESDIR}/${PN}-crypto-proto.diff"
+
+ # make it work with GTK+ 2
epatch "${FILESDIR}/${P}-gtk2-gentoo.patch"
# change default s/key hash to MD5 (same as sys-auth/skey)
epatch "${FILESDIR}/${P}-skey-md5.patch"
+ # fix SHA1 byte-order issue for conformance with RFC 2289
+ epatch "${FILESDIR}/${P}-sha1-byteorder.patch"
+
# print correct version in manpage
sed -i -e "s/VERSION/${PV}/g" otpCalc.man