summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-03 08:27:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-03 08:27:37 +0000
commitc1a6204168e952fb8a7fc25f66b84ba2a7986edf (patch)
treea507914ddeaa6aaac310004cd7558524a6c318b7 /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-c1a6204168e952fb8a7fc25f66b84ba2a7986edf.tar.gz
gentoo-2-c1a6204168e952fb8a7fc25f66b84ba2a7986edf.tar.bz2
gentoo-2-c1a6204168e952fb8a7fc25f66b84ba2a7986edf.zip
Version bump.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mlocate/ChangeLog7
-rw-r--r--sys-apps/mlocate/mlocate-0.25.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-apps/mlocate/ChangeLog b/sys-apps/mlocate/ChangeLog
index d381a0c55849..7872d26e077e 100644
--- a/sys-apps/mlocate/ChangeLog
+++ b/sys-apps/mlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/mlocate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.96 2012/02/05 13:32:52 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.97 2012/03/03 08:27:37 ssuominen Exp $
+
+*mlocate-0.25 (03 Mar 2012)
+
+ 03 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> +mlocate-0.25.ebuild:
+ Version bump.
05 Feb 2012; Christian Faulhammer <fauli@gentoo.org>
-mlocate-0.23.1-r1.ebuild:
diff --git a/sys-apps/mlocate/mlocate-0.25.ebuild b/sys-apps/mlocate/mlocate-0.25.ebuild
new file mode 100644
index 000000000000..badd0d02ac82
--- /dev/null
+++ b/sys-apps/mlocate/mlocate-0.25.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.25.ebuild,v 1.1 2012/03/03 08:27:37 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Merging locate is an utility to index and quickly search for files"
+HOMEPAGE="https://fedorahosted.org/mlocate/"
+SRC_URI="https://fedorahosted.org/releases/m/l/mlocate/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls selinux"
+
+RDEPEND="!sys-apps/slocate
+ !sys-apps/rlocate
+ selinux? ( sec-policy/selinux-slocate )"
+DEPEND="app-arch/xz-utils
+ nls? ( sys-devel/gettext )
+ selinux? ( sec-policy/selinux-slocate )"
+
+pkg_setup() {
+ enewgroup locate
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ emake groupname=locate
+}
+
+src_install() {
+ emake groupname=locate DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README NEWS
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/mlocate-cron.conf
+ fperms 0644 /etc/{updatedb,mlocate-cron}.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}"/mlocate.cron-r2 mlocate
+ fperms 0755 /etc/cron.daily/mlocate
+
+ fowners 0:locate /usr/bin/locate
+ fperms go-r,g+s /usr/bin/locate
+
+ keepdir /var/lib/mlocate
+ chown -R 0:locate "${ED}"/var/lib/mlocate
+ fperms 0750 /var/lib/mlocate
+}
+
+pkg_postinst() {
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the /etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+}