summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-06-08 15:04:21 +0000
committerSven Vermeulen <swift@gentoo.org>2014-06-08 15:04:21 +0000
commitbcd0511eb684fbacb3a3ec18a3bc27da4c2ca459 (patch)
tree791bf30e8d6b76ed61edc85506fe3f4c7caeffd0 /sys-apps
parentBump to 0.3.0 (bug #512752) thanks to Dmitry Pisklov (diff)
downloadgentoo-2-bcd0511eb684fbacb3a3ec18a3bc27da4c2ca459.tar.gz
gentoo-2-bcd0511eb684fbacb3a3ec18a3bc27da4c2ca459.tar.bz2
gentoo-2-bcd0511eb684fbacb3a3ec18a3bc27da4c2ca459.zip
Bump to 2.0.0 (bug #512752) thanks to Dmitry Pisklov
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/roccat-tools/ChangeLog7
-rw-r--r--sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/roccat-tools/ChangeLog b/sys-apps/roccat-tools/ChangeLog
index b0db79205076..7330ba41b5bf 100644
--- a/sys-apps/roccat-tools/ChangeLog
+++ b/sys-apps/roccat-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/roccat-tools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.8 2014/05/30 10:24:30 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.9 2014/06/08 15:04:21 swift Exp $
+
+*roccat-tools-2.0.0 (08 Jun 2014)
+
+ 08 Jun 2014; Sven Vermeulen <swift@gentoo.org> +roccat-tools-2.0.0.ebuild:
+ Bump to 2.0.0 (bug #512752) thanks to Dmitry Pisklov
*roccat-tools-1.6.0 (30 May 2014)
diff --git a/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild b/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild
new file mode 100644
index 000000000000..2ae12318c8ac
--- /dev/null
+++ b/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild,v 1.1 2014/06/08 15:04:21 swift Exp $
+
+EAPI=5
+
+inherit readme.gentoo cmake-utils gnome2-utils udev user
+
+DESCRIPTION="Utility for advanced configuration of Roccat devices"
+
+HOMEPAGE="http://roccat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_INPUT_DEVICES="
+ input_devices_roccat_arvo
+ input_devices_roccat_isku
+ input_devices_roccat_iskufx
+ input_devices_roccat_kone
+ input_devices_roccat_koneplus
+ input_devices_roccat_konepure
+ input_devices_roccat_konepuremilitary
+ input_devices_roccat_konepureoptical
+ input_devices_roccat_konextd
+ input_devices_roccat_konextdoptical
+ input_devices_roccat_kovaplus
+ input_devices_roccat_lua
+ input_devices_roccat_pyra
+ input_devices_roccat_savu
+ input_devices_roccat_ryos
+"
+IUSE="${IUSE_INPUT_DEVICES}"
+
+RDEPEND="
+ >=dev-libs/libgaminggear-0.3
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ media-libs/libcanberra
+ virtual/libusb:1
+ dev-libs/dbus-glib
+ virtual/udev[gudev]
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup roccat
+}
+
+src_configure() {
+ local UDEVDIR="$(udev_get_udevdir)"/rules.d
+ local MODELS=${INPUT_DEVICES//roccat_/}
+ mycmakeargs=( -DDEVICES=${MODELS// /;} \
+ -DUDEVDIR="${UDEVDIR/"//"//}" )
+ cmake-utils_src_configure
+}
+src_install() {
+ cmake-utils_src_install
+ local stat_dir=/var/lib/roccat
+ keepdir $stat_dir
+ fowners root:roccat $stat_dir
+ fperms 2770 $stat_dir
+ readme.gentoo_src_install
+}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}