summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 13:04:14 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 13:04:14 +0000
commitb22c71dd74461d77564ae0bf6279810e93e94d62 (patch)
tree8cd482288d6be63595bde6c9285ac5bf70760b9f /sys-apps
parentImport the live ebuild. (diff)
downloadgentoo-2-b22c71dd74461d77564ae0bf6279810e93e94d62.tar.gz
gentoo-2-b22c71dd74461d77564ae0bf6279810e93e94d62.tar.bz2
gentoo-2-b22c71dd74461d77564ae0bf6279810e93e94d62.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/uam/ChangeLog7
-rw-r--r--sys-apps/uam/uam-9999.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-apps/uam/ChangeLog b/sys-apps/uam/ChangeLog
index bd39bd6188eb..e5b59291e353 100644
--- a/sys-apps/uam/ChangeLog
+++ b/sys-apps/uam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/uam
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/ChangeLog,v 1.28 2012/11/29 02:23:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/ChangeLog,v 1.29 2012/12/15 13:04:14 mgorny Exp $
+
+*uam-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +uam-9999.ebuild:
+ Import the live ebuild.
29 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> uam-0.3.ebuild:
Use virtual/udev instead of sys-fs/udev wrt #444398
diff --git a/sys-apps/uam/uam-9999.ebuild b/sys-apps/uam/uam-9999.ebuild
new file mode 100644
index 000000000000..57909cfa062a
--- /dev/null
+++ b/sys-apps/uam/uam-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/uam-9999.ebuild,v 1.1 2012/12/15 13:04:14 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils user
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://bitbucket.org/mgorny/uam/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
+ elog "to enable in-kernel media polling, e.g.:"
+ elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
+ elog "where 5000 would mean a poll will occur every 5 seconds."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool."
+
+ if [[ -e "${EROOT}"/dev/.udev ]]; then
+ ebegin "Calling udev to reload its rules"
+ udevadm control --reload-rules
+ eend $?
+ fi
+}