summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-25 06:56:23 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-25 06:56:23 +0000
commitaf8a9e9fa07b9bf6b42f6096af661bf4152f264c (patch)
treeeef2a08aef2ae69218abdabeb240d33fff0ce1f8 /sys-apps
parentmeep (diff)
downloadgentoo-2-af8a9e9fa07b9bf6b42f6096af661bf4152f264c.tar.gz
gentoo-2-af8a9e9fa07b9bf6b42f6096af661bf4152f264c.tar.bz2
gentoo-2-af8a9e9fa07b9bf6b42f6096af661bf4152f264c.zip
global update: "virtual/kernel" has been depreciated and "virtual/linux-sources"
should be used instead. "virtual/linux-sources" means "a kernel source tree in /usr/src/linux"
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/acpid/acpid-1.0.0.ebuild4
-rw-r--r--sys-apps/iproute/iproute-20010824.ebuild4
-rw-r--r--sys-apps/lsof/lsof-4.60-r1.ebuild54
3 files changed, 58 insertions, 4 deletions
diff --git a/sys-apps/acpid/acpid-1.0.0.ebuild b/sys-apps/acpid/acpid-1.0.0.ebuild
index a353e53cb1fb..c1fdd5baaa87 100644
--- a/sys-apps/acpid/acpid-1.0.0.ebuild
+++ b/sys-apps/acpid/acpid-1.0.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.0.ebuild,v 1.3 2001/12/31 23:47:55 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.0.ebuild,v 1.4 2002/04/25 06:56:23 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Daemon for Advanced Configuration and Power Interface."
@@ -11,7 +11,7 @@ HOMEPAGE="http://acpid.sourceforge.net/"
# We need the patched kernel with latest ACPI code, or else it will
# be broken. Hopefully it will be merge into release kernel soon.
DEPEND="virtual/glibc
- >=sys-kernel/linux-sources-2.4.10-r4"
+ >=virtual/linux-sources-2.4.10-r4"
src_compile() {
diff --git a/sys-apps/iproute/iproute-20010824.ebuild b/sys-apps/iproute/iproute-20010824.ebuild
index bfa921b6b95a..fd1f66a48c07 100644
--- a/sys-apps/iproute/iproute-20010824.ebuild
+++ b/sys-apps/iproute/iproute-20010824.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824.ebuild,v 1.1 2002/04/20 05:25:47 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824.ebuild,v 1.2 2002/04/25 06:56:23 drobbins Exp $
S=${WORKDIR}/iproute2
DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/iproute2-2.4.7-now-ss010824.tar.gz"
-DEPEND="virtual/glibc virtual/kernel"
+DEPEND="virtual/glibc virtual/linux-sources"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/lsof/lsof-4.60-r1.ebuild b/sys-apps/lsof/lsof-4.60-r1.ebuild
new file mode 100644
index 000000000000..5f4a899c484b
--- /dev/null
+++ b/sys-apps/lsof/lsof-4.60-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.60-r1.ebuild,v 1.3 2002/04/25 06:56:23 drobbins Exp $
+
+MY_P=${P/-/_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Lists open files for running Unix processes"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}_W.tar.gz
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}_W.tar.gz"
+HOMEPAGE="http://"
+
+DEPEND="virtual/glibc virtual/linux-sources"
+
+#This pkg appears to be highly kernel-dependent.
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ tar xf ${MY_P}.tar || die
+ cd ${S}
+}
+
+src_compile() {
+ #interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
+ #is there a way to avoid the "echo to a file + file read"?
+ #Just piping in the results didn't seem to work.
+ echo -e "y\ny\ny\nn\ny\ny\n" > ${T}/junk
+ ./Configure linux < ${T}/junk
+
+ #simple Makefile hack to insert CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" Makefile.orig > Makefile
+
+ make all || die
+}
+
+src_install () {
+ #/usr/sbin is a good location -- drobbins
+ dosbin lsof
+ # .a libs not needed during boot so they go in /usr/lib -- drobbins
+ dolib lib/liblsof.a
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+ doman lsof.8
+ local x
+ for x in 00*
+ do
+ newdoc ${x} ${x/00/}
+ done
+ cd ${D}/usr/share/doc/${PF}
+ mv .README.FIRST.gz README.FIRST.gz
+}
+