summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 13:41:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 13:41:21 +0000
commitaabd28b1390d65e5b64ad9ad5b807eb426861f8c (patch)
treeb03750244d216417789e7a0bc2efc750d0d75680 /sys-apps
parentmask multilib attr (diff)
downloadgentoo-2-aabd28b1390d65e5b64ad9ad5b807eb426861f8c.tar.gz
gentoo-2-aabd28b1390d65e5b64ad9ad5b807eb426861f8c.tar.bz2
gentoo-2-aabd28b1390d65e5b64ad9ad5b807eb426861f8c.zip
Convert to multilib, bug #479310
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/attr/ChangeLog7
-rw-r--r--sys-apps/attr/attr-2.4.47-r1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index 5236466fec48..c3d241c2da4f 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/attr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.155 2013/08/10 12:50:12 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.156 2013/08/10 13:41:21 aballier Exp $
+
+*attr-2.4.47-r1 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org> +attr-2.4.47-r1.ebuild:
+ Convert to multilib, bug #479310
10 Aug 2013; Agostino Sarubbo <ago@gentoo.org> attr-2.4.46-r2.ebuild:
Stable for ppc, wrt bug #470570
diff --git a/sys-apps/attr/attr-2.4.47-r1.ebuild b/sys-apps/attr/attr-2.4.47-r1.ebuild
new file mode 100644
index 000000000000..6c1ff2f33ac3
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.47-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.47-r1.ebuild,v 1.1 2013/08/10 13:41:21 aballier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib-minimal
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://savannah.nongnu.org/projects/attr"
+SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die
+ strip-linguas -u po
+ multilib_copy_sources # https://savannah.nongnu.org/bugs/index.php?39736
+}
+
+multilib_src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --enable-shared $(use_enable static-libs static) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir) \
+ --bindir="${EPREFIX}"/bin
+}
+
+multilib_src_compile() {
+ emake $(multilib_is_native_abi || echo TOOL_SUBDIRS=)
+}
+
+multilib_src_install() {
+ emake \
+ $(multilib_is_native_abi || echo TOOL_SUBDIRS=) \
+ DIST_ROOT="${D}" \
+ install install-lib install-dev
+
+ # we install attr into /bin, so we need the shared lib with it
+ multilib_is_native_abi && gen_usr_ldscript -a attr
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+ # the man-pages packages provides the man2 files
+ rm -r "${ED}"/usr/share/man/man2 || die
+}