summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-17 00:47:45 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-12-17 00:47:45 +0000
commit85eb4fbfb79d9f0f384e86e48c92178f6eb390b4 (patch)
treecc3b41a149ede3080c7058e4c4e0a98e06002a03 /sys-apps
parentBump to EAPI=5 to make Paludis happy, bug #447524. (diff)
downloadgentoo-2-85eb4fbfb79d9f0f384e86e48c92178f6eb390b4.tar.gz
gentoo-2-85eb4fbfb79d9f0f384e86e48c92178f6eb390b4.tar.bz2
gentoo-2-85eb4fbfb79d9f0f384e86e48c92178f6eb390b4.zip
Version bump: adds improved tests, fixes flag setting, bug #446518
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/elfix/ChangeLog4
-rw-r--r--sys-apps/elfix/elfix-0.7.0.ebuild37
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 6a5bfbed12e1..11191699af0b 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,4 +1,8 @@
+*elfix-0.7.0 (17 Dec 2012)
+
+ 17 Dec 2012; Anthony G. Basile <blueness@gentoo.org> +elfix-0.7.0.ebuild:
+ Version bump: adds improved tests, fixes flag setting, bug #446518
06 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> elfix-0.6.0.ebuild:
x86 stable wrt bug #445334
diff --git a/sys-apps/elfix/elfix-0.7.0.ebuild b/sys-apps/elfix/elfix-0.7.0.ebuild
new file mode 100644
index 000000000000..7c835b02138b
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.7.0.ebuild,v 1.1 2012/12/17 00:47:44 blueness Exp $
+
+EAPI="4"
+
+DESCRIPTION="Tools to work with ELF binaries and libraries on Hardened Gentoo."
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test +ptpax xtpax"
+
+# These only work on a properly configure pax kernel
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/elfutils
+ =dev-python/pypax-${PV}[ptpax=,xtpax=]
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf \
+ $(use_enable test tests) \
+ $(use_enable ptpax ptpax) \
+ $(use_enable xtpax xtpax)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}