summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-19 22:39:27 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-19 22:39:27 +0000
commit647cd2a8ba64031a8a63c7f801e7f7936bf88ac4 (patch)
tree0b607c09f50950cd8c3408e237402d7ca594ee4e /sys-apps
parentold (diff)
downloadgentoo-2-647cd2a8ba64031a8a63c7f801e7f7936bf88ac4.tar.gz
gentoo-2-647cd2a8ba64031a8a63c7f801e7f7936bf88ac4.tar.bz2
gentoo-2-647cd2a8ba64031a8a63c7f801e7f7936bf88ac4.zip
Version bump #341701.
(Portage version: 2.2_rc96/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smartmontools/ChangeLog8
-rw-r--r--sys-apps/smartmontools/smartmontools-5.40.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index ab4499988b18..26cf7b70c71b 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.86 2010/03/06 23:00:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.87 2010/10/19 22:39:27 vapier Exp $
+
+*smartmontools-5.40 (19 Oct 2010)
+
+ 19 Oct 2010; Mike Frysinger <vapier@gentoo.org>
+ +smartmontools-5.40.ebuild:
+ Version bump #341701.
*smartmontools-5.39.1 (06 Mar 2010)
diff --git a/sys-apps/smartmontools/smartmontools-5.40.ebuild b/sys-apps/smartmontools/smartmontools-5.40.ebuild
new file mode 100644
index 000000000000..e490e9a42d52
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.40.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.40.ebuild,v 1.1 2010/10/19 22:39:27 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static minimal"
+
+RDEPEND="!minimal? ( virtual/mailx )"
+DEPEND=""
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+ econf \
+ --with-docdir="/usr/share/doc/${PF}" \
+ --with-initscriptdir="/toss-it-away" \
+ || die
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl || die
+ doman smartctl.8
+ else
+ emake install DESTDIR="${D}" || die
+ rm -rf "${D}"/toss-it-away
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}