summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-10-22 19:46:57 +0000
committerTim Harder <radhermit@gentoo.org>2013-10-22 19:46:57 +0000
commit5b20cd3e7d24bc4a8caab96d2480183504439512 (patch)
tree9ebe5736ab26b420673763e502f7fadaf18ef0e5 /sys-apps
parentFix failing to pass default install arguments when user passes an additional ... (diff)
downloadgentoo-2-5b20cd3e7d24bc4a8caab96d2480183504439512.tar.gz
gentoo-2-5b20cd3e7d24bc4a8caab96d2480183504439512.tar.bz2
gentoo-2-5b20cd3e7d24bc4a8caab96d2480183504439512.zip
Migrate to distutils-r1 (bug #483062, patch by mgorny).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pkgcore/ChangeLog5
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild77
2 files changed, 55 insertions, 27 deletions
diff --git a/sys-apps/pkgcore/ChangeLog b/sys-apps/pkgcore/ChangeLog
index 3e018b77a76a..352915eca137 100644
--- a/sys-apps/pkgcore/ChangeLog
+++ b/sys-apps/pkgcore/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pkgcore
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/ChangeLog,v 1.170 2013/09/12 22:37:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/ChangeLog,v 1.171 2013/10/22 19:46:57 radhermit Exp $
+
+ 22 Oct 2013; Tim Harder <radhermit@gentoo.org> pkgcore-9999.ebuild:
+ Migrate to distutils-r1 (bug #483062, patch by mgorny).
12 Sep 2013; Michał Górny <mgorny@gentoo.org> pkgcore-0.8.6.ebuild,
pkgcore-9999.ebuild:
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index a236ba2a6572..a8ce8a94c10c 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -1,53 +1,78 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/pkgcore-9999.ebuild,v 1.12 2013/09/12 22:37:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/pkgcore-9999.ebuild,v 1.13 2013/10/22 19:46:57 radhermit Exp $
-EAPI="3"
-DISTUTILS_SRC_TEST="setup.py"
+EAPI=4
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+inherit distutils-r1
-EGIT_REPO_URI="https://code.google.com/p/pkgcore/"
-inherit distutils git-2
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://code.google.com/p/pkgcore/"
+ EGIT_NONSHALLOW=1
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="http://pkgcore.googlecode.com/files/${P}.tar.bz2"
+fi
DESCRIPTION="pkgcore package manager"
HOMEPAGE="http://pkgcore.googlecode.com/"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="+doc"
-RDEPEND=">=dev-lang/python-2.5
- =dev-python/snakeoil-9999
- || ( >=dev-lang/python-2.5 dev-python/pycrypto )"
+RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/sphinx
- dev-python/pyparsing"
-
-DOCS="AUTHORS NEWS"
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
pkg_setup() {
# disable snakeoil 2to3 caching...
unset PY2TO3_CACHEDIR
- python_pkg_setup
+
+ mydistutilsargs=(
+ build
+ --disable-html-docs
+ --disable-man-pages
+ )
+}
+
+python_compile_all() {
+ esetup.py build_man $(use doc && echo 'build_docs')
+
+ # symlinks generated manpages into source root
+ # dead symlinks are tolerated
+ ln -s "${BUILD_DIR}/sphinx/man" man || die
+ ln -s "${BUILD_DIR}/sphinx/html" html || die
}
-src_compile() {
- local x
- distutils_src_compile $(use_enable doc html-docs)
- # Find the first set of generated manpages, and symlink
- # those into the source root.
- for x in ${PYTHON_ABIS}; do
- ln -s "${S}/build-${x}/sphinx/man" "${S}/man"
- break
- done
+python_test() {
+ esetup.py test
}
src_install() {
- distutils_src_install $(use_enable doc html-docs)
+ mydistutilsargs+=(
+ install
+ --disable-html-docs
+ --disable-man-pages
+ )
+
+ distutils-r1_src_install
+}
+
+python_install_all() {
+ local cmds=(
+ install_man
+ )
+ use doc && cmds+=(
+ install_docs --path="${ED%/}"/usr/share/doc/${PF}/html
+ )
+
+ distutils-r1_python_install "${cmds[@]}"
+ distutils-r1_python_install_all
}
pkg_postinst() {
- distutils_pkg_postinst
pplugincache
}