summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2002-07-12 10:31:23 +0000
committerDoug Goldstein <cardoe@gentoo.org>2002-07-12 10:31:23 +0000
commit59da5b03a3586e41f6804c090a6857f7a5a127aa (patch)
tree95a396d2410854e58e1006837f15ef8ca6377216 /sys-apps
parentupdated to -r6 (diff)
downloadgentoo-2-59da5b03a3586e41f6804c090a6857f7a5a127aa.tar.gz
gentoo-2-59da5b03a3586e41f6804c090a6857f7a5a127aa.tar.bz2
gentoo-2-59da5b03a3586e41f6804c090a6857f7a5a127aa.zip
Added pcmcia-cs-3.1.35_beta2
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog10
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.35_beta22
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.1.35_beta2.ebuild137
3 files changed, 148 insertions, 1 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index 652fc8c301d8..9452889f3446 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.16 2002/07/12 09:23:16 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.17 2002/07/12 10:31:23 cardoe Exp $
+
+*pcmcia-cs-3.1.35_beta2 (12 July 2002)
+
+ 12 July 2002; Doug Goldstein <cardoe@gentoo.org> pcmcia-cs-3.1.35_beta2.ebuild
+
+ Since .34 and lower have some very very annoying and dibilitating (sp) bugs in them I'm creating this..
+ It carries over my fixes from .34-r6 still as they haven't been made upstream yet
+ There is no beta1 ebuild, only beta2 as the file this ebuild uses is the 2nd beta file released
*pcmcia-cs-3.1.34 (12 July 2002)
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.35_beta2 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.35_beta2
new file mode 100644
index 000000000000..e09c7ad92897
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.35_beta2
@@ -0,0 +1,2 @@
+MD5 7826a84d3d4e75b23bba3d15024e987f pcmcia-cs.02-Jul-02.tar.gz 1247090
+MD5 c2e545a8358edcd0ecec1be1685fac71 orinoco-0.12b.tar.gz 62958
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.35_beta2.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.35_beta2.ebuild
new file mode 100644
index 000000000000..0ce5de91b513
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.35_beta2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.1.35_beta2.ebuild,v 1.1 2002/07/12 10:31:23 cardoe Exp $
+
+S=${WORKDIR}/pcmcia-cs-3.1.35
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="http://pcmcia-cs.sourceforge.net/ftp/NEW/pcmcia-cs.02-Jul-02.tar.gz
+ http://ozlabs.org/people/dgibson/dldwd/orinoco-0.12b.tar.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack pcmcia-cs.02-Jul-02.tar.gz
+# patch -p0 < ${FILESDIR}/gentoo-${P}.patch
+
+ unpack orinoco-0.12b.tar.gz
+ cd ${S}
+ mv ../orinoco-0.12b/hermes*.{c,h} \
+ ../orinoco-0.12b/orinoco*.{c,h} \
+ ../orinoco-0.12b/ieee802_11.h wireless/
+ cp Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ #man pages will now install into /usr/share/man
+
+ cd ${S}
+ ### As per the SourceForge web site reqs and bug #3400
+ # We'll replace all ide_cs with ide-cs
+ cp etc/config etc/config.orig
+ sed -e 's:ide_cs:ide-cs:g' etc/config.orig > etc/config
+ rm -f etc/config.orig
+
+
+}
+
+src_compile() {
+ local myconf
+ if [ -n "`use trusted`" ] ; then
+ myconf="--trust"
+ else
+ myconf="--notrust"
+ fi
+
+ if [ -n "`use apm`" ] ; then
+ myconf="$myconf --apm"
+ else
+ myconf="$myconf --noapm"
+ fi
+
+ if [ -n "`use pnp`" ] ; then
+ myconf="$myconf --pnp"
+ else
+ myconf="$myconf --nopnp"
+ fi
+
+ if [ -n "`use nocardbus`" ] ; then
+ myconf="$myconf --nocardbus"
+ else
+ myconf="$myconf --cardbus"
+ fi
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
+ # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+ cd ${D}
+ rm -rf etc/rc*.d
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf usr/X11R6
+ # todo: if they are nstalled, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc6 pcmcia
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ # install docs
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ ${ARCH} = "ppc" ] ; then
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+src_postinst() {
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
+ einfo "(Otherwise, you might experience CardServices version mismatch errors)"
+}