summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-12-02 21:35:05 +0000
committerMarinus Schraal <foser@gentoo.org>2004-12-02 21:35:05 +0000
commit2fad0daa934972984d47452790c2d4ed365f0984 (patch)
tree71853a303d88ef5d70546ef78331a29ea088a723 /sys-apps
parentdep fixes (Manifest recommit) (diff)
downloadgentoo-2-2fad0daa934972984d47452790c2d4ed365f0984.tar.gz
gentoo-2-2fad0daa934972984d47452790c2d4ed365f0984.tar.bz2
gentoo-2-2fad0daa934972984d47452790c2d4ed365f0984.zip
new release
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/Manifest2
-rw-r--r--sys-apps/hal/files/digest-hal-0.4.21
-rw-r--r--sys-apps/hal/hal-0.4.2.ebuild101
4 files changed, 110 insertions, 1 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index c6ea8de4c7be..5271807fa98e 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.12 2004/11/30 00:22:35 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.13 2004/12/02 21:35:05 foser Exp $
+
+*hal-0.4.2 (02 Dec 2004)
+
+ 02 Dec 2004; foser <foser@gentoo.org> hal-0.4.2.ebuild :
+ New release, add proper debug & pcmcia USE flags
*hal-0.4.1-r1 (30 Nov 2004)
diff --git a/sys-apps/hal/Manifest b/sys-apps/hal/Manifest
index dd9b43327659..024504af924e 100644
--- a/sys-apps/hal/Manifest
+++ b/sys-apps/hal/Manifest
@@ -2,6 +2,7 @@ MD5 4265ce12f38a8dc8ef24fe9e56c449d9 hal-0.4.1.ebuild 2396
MD5 90547a95bd5c26e49711a482c1eaef26 hal-0.4.1-r1.ebuild 2507
MD5 3e506a597274c818f662edbe0c7d2b59 hal-0.2.98-r1.ebuild 2062
MD5 3623707794adfd9e8fd4381df20dc27f ChangeLog 1951
+MD5 e500c00719dae5c15258ab06701cec6a hal-0.4.2.ebuild 2391
MD5 731695e9263a5a2e1eeba290b36078d5 metadata.xml 219
MD5 192112dfb678a9795a93d3cdcc50bb95 files/hald 543
MD5 715f2a2e9a6980bae0823241ea50787f files/hal-0.4.0-allow-floppy-drives.patch 738
@@ -9,6 +10,7 @@ MD5 72d398ab014b2630043ef2a4d9990e2f files/digest-hal-0.2.98-r1 63
MD5 f1cf07edc63d04f0ef33911de97ea2f2 files/digest-hal-0.4.1-r1 62
MD5 399570c945e0f4bffbeb645e057e027b files/hal-0.4.1-dm_devices_tab.patch 1028
MD5 f1cf07edc63d04f0ef33911de97ea2f2 files/digest-hal-0.4.1 62
+MD5 a9afa7e41b21ea5f012765a8ced6c10d files/digest-hal-0.4.2 62
MD5 fa38b59d0ab9bdf0ff3363cd756d902a files/hal-0.4.0-old_storage_policy.patch 1217
MD5 90ea63d4a4b9885b7a6eab147dcb428b files/hal-0.4.0-clean-on-startup.patch 2653
MD5 a0ce1c268e0b7d0967ec7b8e0d0d26d2 files/hal-0.4.1-old_storage_policy.patch 1216
diff --git a/sys-apps/hal/files/digest-hal-0.4.2 b/sys-apps/hal/files/digest-hal-0.4.2
new file mode 100644
index 000000000000..6b8be036974e
--- /dev/null
+++ b/sys-apps/hal/files/digest-hal-0.4.2
@@ -0,0 +1 @@
+MD5 dd3469f1b501879719fa47795a0f48fb hal-0.4.2.tar.gz 1310359
diff --git a/sys-apps/hal/hal-0.4.2.ebuild b/sys-apps/hal/hal-0.4.2.ebuild
new file mode 100644
index 000000000000..2744057a7e25
--- /dev/null
+++ b/sys-apps/hal/hal-0.4.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.2.ebuild,v 1.1 2004/12/02 21:35:05 foser Exp $
+
+inherit eutils python
+
+DESCRIPTION="Hardware Abstraction Layer"
+HOMEPAGE="http://www.freedesktop.org/Software/hal"
+SRC_URI="http://freedesktop.org/~david/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.0 )"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~ppc64"
+IUSE="debug pcmcia"
+
+RDEPEND=">=dev-libs/glib-2.2.2
+ >=sys-apps/dbus-0.22-r1
+ dev-libs/expat
+ sys-fs/udev
+ sys-apps/hotplug
+ sys-libs/libcap
+ >=sys-apps/util-linux-2.12i
+ sys-kernel/linux26-headers"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# dep on a specific util-linux version for
+# managed mount patches #70873
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # remove pamconsole option
+ epatch ${FILESDIR}/${PN}-0.4.1-old_storage_policy.patch
+ # fix floppy drives be shown
+ epatch ${FILESDIR}/${PN}-0.4.0-allow-floppy-drives.patch
+
+}
+
+src_compile() {
+
+ # FIXME : docs
+ econf \
+ `use_enable debug verbose-mode` \
+ `use_enable pcmcia pcmcia-support` \
+ --enable-fstab-sync \
+ --enable-hotplug-map \
+ --disable-doxygen-docs \
+ --disable-docbook-docs \
+ --with-pid-file=/var/run/hald/hald.pid \
+ || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ # We install this in a seperate package to avoid gnome-python dep
+ rm ${D}/usr/bin/hal-device-manager
+
+ # initscript
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/hald
+
+ # place our pid file
+ keepdir /var/run/hald
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+}
+
+pkg_preinst() {
+
+ enewgroup haldaemon || die "Problem adding haldaemon group"
+ enewuser haldaemon -1 /bin/false /dev/null haldaemon || die "Problem adding haldaemon user"
+
+}
+
+pkg_postinst() {
+
+ # make sure the permissions on the pid dir are alright & after preinst
+ chown haldaemon:haldaemon /var/run/hald
+
+ ewarn "Enabled in this ebuild by default is the usage of fstab-sync"
+ ewarn "that will create mount rules for non-existing devices in"
+ ewarn "fstab if needed, mount points will be created in /media."
+ ewarn "This functionality alters /etc/fstab runtime on the filesystem"
+ ewarn "and should be considered a security risk."
+ echo
+ einfo "The HAL daemon needs to be running for certain applications to"
+ einfo "work. Suggested is to add the init script to your start-up"
+ einfo "scripts, this should be done like this :"
+ einfo "\`rc-update add hald default\`"
+
+}