summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-12 22:21:06 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-12 22:21:06 +0000
commit28bd73fbf0f88dee7871f40dd40967b63371310e (patch)
tree0512fc5fba3170aff8672d96dfa28da1f2bf81a1 /sys-apps
parentStable on amd64/x86 (bug #258841) (diff)
downloadgentoo-2-28bd73fbf0f88dee7871f40dd40967b63371310e.tar.gz
gentoo-2-28bd73fbf0f88dee7871f40dd40967b63371310e.tar.bz2
gentoo-2-28bd73fbf0f88dee7871f40dd40967b63371310e.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/shadow/shadow-4.0.18.1-r1.ebuild210
-rw-r--r--sys-apps/shadow/shadow-4.1.0-r1.ebuild163
-rw-r--r--sys-apps/shadow/shadow-4.1.0.ebuild160
-rw-r--r--sys-apps/shadow/shadow-4.1.1.ebuild161
-rw-r--r--sys-apps/shadow/shadow-4.1.2-r1.ebuild158
-rw-r--r--sys-apps/shadow/shadow-4.1.2.1.ebuild161
6 files changed, 0 insertions, 1013 deletions
diff --git a/sys-apps/shadow/shadow-4.0.18.1-r1.ebuild b/sys-apps/shadow/shadow-4.0.18.1-r1.ebuild
deleted file mode 100644
index 6d68366bfcc6..000000000000
--- a/sys-apps/shadow/shadow-4.0.18.1-r1.ebuild
+++ /dev/null
@@ -1,210 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.18.1-r1.ebuild,v 1.14 2008/05/11 13:11:56 ulm Exp $
-
-inherit eutils libtool toolchain-funcs autotools pam multilib
-
-DESCRIPTION="Utilities to deal with user accounts"
-HOMEPAGE="http://shadow.pld.org.pl/"
-SRC_URI="ftp://ftp.pld.org.pl/software/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls pam selinux skey nousuid cracklib"
-
-RDEPEND="cracklib? ( >=sys-libs/cracklib-2.7-r3 )
- pam? ( virtual/pam )
- !sys-apps/pam-login
- !app-admin/nologin
- skey? ( sys-auth/skey )
- selinux? ( >=sys-libs/libselinux-1.28 )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # uclibc support, corrects NIS usage
- epatch "${FILESDIR}"/${PN}-4.0.13-nonis.patch
-
- # If su should not simulate a login shell, use '/bin/sh' as shell to enable
- # running of commands as user with /bin/false as shell, closing bug #15015.
- # *** This one could be a security hole; disable for now ***
- #epatch "${FILESDIR}"/${P}-nologin-run-sh.patch
-
- # tweak the default login.defs
- epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
- sed -i "s:@LIBDIR@:$(get_libdir):" etc/login.defs || die
-
- # Make user/group names more flexible #3485 / #22920
- epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
- epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
-
- # Fix compiling with gcc-2.95.x
- epatch "${FILESDIR}"/${PN}-4.0.12-gcc2.patch
-
- # lock down setuid perms #47208
- epatch "${FILESDIR}"/${PN}-4.0.11.1-perms.patch
-
- epatch "${FILESDIR}"/${PN}-4.0.15-uclibc-missing-l64a.patch
-
- epatch "${FILESDIR}"/${PN}-4.0.16-fix-useradd-usergroups.patch #128715
-
- epatch "${FILESDIR}"/${PN}-4.0.18.1-useradd-usermod.patch
-
- # Needed by the UCLIBC patches
- eautoconf || die
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
- econf \
- --disable-desrpc \
- --with-libcrypt \
- --enable-shared=no \
- --enable-static=yes \
- $(use_with cracklib libcrack) \
- $(use_with pam libpam) \
- $(use_with skey) \
- $(use_with selinux) \
- $(use_enable nls) \
- || die "bad configure"
- emake || die "compile problem"
-}
-
-src_install() {
- local perms=4711
- use nousuid && perms=711
- make DESTDIR="${D}" suiduperms=${perms} install || die "install problem"
- dosym useradd /usr/sbin/adduser
-
- # Remove libshadow and libmisc; see bug 37725 and the following
- # comment from shadow's README.linux:
- # Currently, libshadow.a is for internal use only, so if you see
- # -lshadow in a Makefile of some other package, it is safe to
- # remove it.
- rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins "${FILESDIR}"/securetty
- if ! use pam ; then
- insopts -m0600
- doins etc/login.access etc/limits
- else
- newpamd "${FILESDIR}/login.pamd.1" login
- use selinux || sed -i -e '/@selinux@/d' "${D}"/etc/pam.d/login
- use selinux && sed -i -e 's:@selinux@::g' "${D}"/etc/pam.d/login
- fi
- # Output arch-specific cruft
- case $(tc-arch) in
- ppc*) echo "hvc0" >> "${D}"/etc/securetty
- echo "hvsi0" >> "${D}"/etc/securetty
- echo "ttyPSC0" >> "${D}"/etc/securetty;;
- hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
- arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
- sh) echo "ttySC0" >> "${D}"/etc/securetty
- echo "ttySC1" >> "${D}"/etc/securetty;;
- esac
-
- # needed for 'adduser -D'
- insinto /etc/default
- insopts -m0600
- doins "${FILESDIR}"/default/useradd
-
- # move passwd to / to help recover broke systems #64441
- mv "${D}"/usr/bin/passwd "${D}"/bin/
- dosym /bin/passwd /usr/bin/passwd
-
- if use pam ; then
- local INSTALL_SYSTEM_PAMD="yes"
-
- # Do not install below pam.d files if we have pam-0.78 or later
- has_version '>=sys-libs/pam-0.78' && \
- INSTALL_SYSTEM_PAMD="no"
-
- for x in "${FILESDIR}"/pam.d-include/*; do
- case "${x##*/}" in
- "login")
- # We do no longer install this one, as its from
- # pam-login now.
- ;;
- "system-auth"|"system-auth-1.1"|"other")
- # These we only install if we do not have pam-0.78
- # or later.
- [ "${INSTALL_SYSTEM_PAMD}" = "yes" ] && [ -f ${x} ] && \
- dopamd ${x}
- ;;
- "su")
- # Disable support for pam_env and pam_wheel on openpam
- has_version sys-libs/pam && dopamd ${x}
- ;;
- "su-openpam")
- has_version sys-libs/openpam && newpamd ${x} su
- ;;
- *)
- [ -f ${x} ] && dopamd ${x}
- ;;
- esac
- done
- for x in chage chsh chfn chpasswd newusers \
- user{add,del,mod} group{add,del,mod} ; do
- newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
- done
-
- # remove manpages that pam will install for us
- # and/or don't apply when using pam
-
- find "${D}"/usr/share/man \
- '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
- -exec rm {} \;
- fi
-
- cd "${S}"
- insinto /etc
- insopts -m0644
- newins etc/login.defs login.defs
-
- # comment out options that pam hates
- if use pam ; then
- awk -f "${FILESDIR}"/login_defs.awk \
- lib/getdef.c etc/login.defs \
- > "${D}"/etc/login.defs
- fi
-
- # Remove manpages that are handled by other packages
- find "${D}"/usr/share/man \
- '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
- -exec rm {} \;
-
- cd "${S}"
- dodoc ChangeLog NEWS TODO
- newdoc README README.download
- cd doc
- dodoc HOWTO README* WISHLIST *.txt
-}
-
-pkg_preinst() {
- rm -f "${ROOT}"/etc/pam.d/system-auth.new \
- "${ROOT}/etc/login.defs.new"
-}
-
-pkg_postinst() {
- # Enable shadow groups (we need ROOT=/ here, as grpconv only
- # operate on / ...).
- if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
- if grpck -r &>/dev/null; then
- grpconv
- else
- ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
- ewarn "run 'grpconv' afterwards!"
- fi
- fi
-}
diff --git a/sys-apps/shadow/shadow-4.1.0-r1.ebuild b/sys-apps/shadow/shadow-4.1.0-r1.ebuild
deleted file mode 100644
index 624c8cdfba8c..000000000000
--- a/sys-apps/shadow/shadow-4.1.0-r1.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.1.0-r1.ebuild,v 1.9 2008/05/17 14:20:52 nixnut Exp $
-
-inherit eutils libtool toolchain-funcs autotools pam multilib
-
-DESCRIPTION="Utilities to deal with user accounts"
-HOMEPAGE="http://shadow.pld.org.pl/ http://packages.qa.debian.org/s/shadow.html"
-SRC_URI="mirror://debian/pool/main/s/shadow/shadow_${PV}.orig.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="nls pam selinux skey cracklib"
-
-# Does not work with OpenPAM (yet?)
-RDEPEND="cracklib? ( >=sys-libs/cracklib-2.7-r3 )
- pam? ( >=sys-libs/pam-0.99 )
- !sys-apps/pam-login
- !app-admin/nologin
- skey? ( sys-auth/skey )
- selinux? ( >=sys-libs/libselinux-1.28 )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${RDEPEND}
- pam? ( >=sys-auth/pambase-20080219.1 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # If su should not simulate a login shell, use '/bin/sh' as shell to enable
- # running of commands as user with /bin/false as shell, closing bug #15015.
- # *** This one could be a security hole; disable for now ***
- #epatch "${FILESDIR}"/${P}-nologin-run-sh.patch
-
- # tweak the default login.defs
- epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
- sed -i "s:@LIBDIR@:$(get_libdir):" etc/login.defs || die
-
- # Make user/group names more flexible #3485 / #22920
- epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
- epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
- epatch "${FILESDIR}"/${PN}-4.1.0-fix-useradd-usergroups.patch #128715
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
- econf \
- --disable-desrpc \
- --with-libcrypt \
- --enable-shared=no \
- --enable-static=yes \
- $(use_with cracklib libcrack) \
- $(use_with pam libpam) \
- $(use_with skey) \
- $(use_with selinux) \
- $(use_enable nls) \
- || die "bad configure"
- emake || die "compile problem"
-}
-
-src_install() {
- emake DESTDIR="${D}" suidperms=4711 install || die "install problem"
- dosym useradd /usr/sbin/adduser
-
- # Remove libshadow and libmisc; see bug 37725 and the following
- # comment from shadow's README.linux:
- # Currently, libshadow.a is for internal use only, so if you see
- # -lshadow in a Makefile of some other package, it is safe to
- # remove it.
- rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins "${FILESDIR}"/securetty
- if ! use pam ; then
- insopts -m0600
- doins etc/login.access etc/limits
- fi
- # Output arch-specific cruft
- case $(tc-arch) in
- ppc*) echo "hvc0" >> "${D}"/etc/securetty
- echo "hvsi0" >> "${D}"/etc/securetty
- echo "ttyPSC0" >> "${D}"/etc/securetty;;
- hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
- arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
- sh) echo "ttySC0" >> "${D}"/etc/securetty
- echo "ttySC1" >> "${D}"/etc/securetty;;
- esac
-
- # needed for 'adduser -D'
- insinto /etc/default
- insopts -m0600
- doins "${FILESDIR}"/default/useradd
-
- # move passwd to / to help recover broke systems #64441
- mv "${D}"/usr/bin/passwd "${D}"/bin/
- dosym /bin/passwd /usr/bin/passwd
-
- cd "${S}"
- insinto /etc
- insopts -m0644
- newins etc/login.defs login.defs
-
- if use pam ; then
- dopamd "${FILESDIR}/pam.d-include/"{su,passwd,shadow}
-
- newpamd "${FILESDIR}/login.pamd.2" login
-
- for x in chage chsh chfn chpasswd newusers \
- user{add,del,mod} group{add,del,mod} ; do
- newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
- done
-
- # comment out login.defs options that pam hates
- gawk -f "${FILESDIR}"/login_defs.awk \
- lib/getdef.c etc/login.defs \
- > "${D}"/etc/login.defs
-
- # remove manpages that pam will install for us
- # and/or don't apply when using pam
- find "${D}"/usr/share/man \
- '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
- -exec rm {} \;
- fi
-
- # Remove manpages that are handled by other packages
- find "${D}"/usr/share/man \
- '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
- -exec rm {} \;
-
- cd "${S}"
- dodoc ChangeLog NEWS TODO
- newdoc README README.download
- cd doc
- dodoc HOWTO README* WISHLIST *.txt
-}
-
-pkg_preinst() {
- rm -f "${ROOT}"/etc/pam.d/system-auth.new \
- "${ROOT}/etc/login.defs.new"
-
- use pam && pam_epam_expand "${D}"/etc/pam.d/login
-}
-
-pkg_postinst() {
- # Enable shadow groups (we need ROOT=/ here, as grpconv only
- # operate on / ...).
- if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
- if grpck -r &>/dev/null; then
- grpconv
- else
- ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
- ewarn "run 'grpconv' afterwards!"
- fi
- fi
-}
diff --git a/sys-apps/shadow/shadow-4.1.0.ebuild b/sys-apps/shadow/shadow-4.1.0.ebuild
deleted file mode 100644
index 9b6c652a5e34..000000000000
--- a/sys-apps/shadow/shadow-4.1.0.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.1.0.ebuild,v 1.2 2008/05/11 13:11:56 ulm Exp $
-
-inherit eutils libtool toolchain-funcs autotools pam multilib
-
-DESCRIPTION="Utilities to deal with user accounts"
-HOMEPAGE="http://shadow.pld.org.pl/ http://packages.qa.debian.org/s/shadow.html"
-SRC_URI="mirror://debian/pool/main/s/shadow/shadow_${PV}.orig.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls pam selinux skey cracklib"
-
-RDEPEND="cracklib? ( >=sys-libs/cracklib-2.7-r3 )
- pam? ( >=sys-libs/pam-0.99 )
- !sys-apps/pam-login
- !app-admin/nologin
- skey? ( sys-auth/skey )
- selinux? ( >=sys-libs/libselinux-1.28 )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # If su should not simulate a login shell, use '/bin/sh' as shell to enable
- # running of commands as user with /bin/false as shell, closing bug #15015.
- # *** This one could be a security hole; disable for now ***
- #epatch "${FILESDIR}"/${P}-nologin-run-sh.patch
-
- # tweak the default login.defs
- epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
- sed -i "s:@LIBDIR@:$(get_libdir):" etc/login.defs || die
-
- # Make user/group names more flexible #3485 / #22920
- epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
- epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
- epatch "${FILESDIR}"/${PN}-4.1.0-fix-useradd-usergroups.patch #128715
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
- econf \
- --disable-desrpc \
- --with-libcrypt \
- --enable-shared=no \
- --enable-static=yes \
- $(use_with cracklib libcrack) \
- $(use_with pam libpam) \
- $(use_with skey) \
- $(use_with selinux) \
- $(use_enable nls) \
- || die "bad configure"
- emake || die "compile problem"
-}
-
-src_install() {
- emake DESTDIR="${D}" suidperms=4711 install || die "install problem"
- dosym useradd /usr/sbin/adduser
-
- # Remove libshadow and libmisc; see bug 37725 and the following
- # comment from shadow's README.linux:
- # Currently, libshadow.a is for internal use only, so if you see
- # -lshadow in a Makefile of some other package, it is safe to
- # remove it.
- rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins "${FILESDIR}"/securetty
- if ! use pam ; then
- insopts -m0600
- doins etc/login.access etc/limits
- fi
- # Output arch-specific cruft
- case $(tc-arch) in
- ppc*) echo "hvc0" >> "${D}"/etc/securetty
- echo "hvsi0" >> "${D}"/etc/securetty
- echo "ttyPSC0" >> "${D}"/etc/securetty;;
- hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
- arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
- sh) echo "ttySC0" >> "${D}"/etc/securetty
- echo "ttySC1" >> "${D}"/etc/securetty;;
- esac
-
- # needed for 'adduser -D'
- insinto /etc/default
- insopts -m0600
- doins "${FILESDIR}"/default/useradd
-
- # move passwd to / to help recover broke systems #64441
- mv "${D}"/usr/bin/passwd "${D}"/bin/
- dosym /bin/passwd /usr/bin/passwd
-
- cd "${S}"
- insinto /etc
- insopts -m0644
- newins etc/login.defs login.defs
-
- if use pam ; then
- dopamd "${FILESDIR}/pam.d-include/"{su,passwd,shadow}
-
- newpamd "${FILESDIR}/login.pamd.2" login
-
- for x in chage chsh chfn chpasswd newusers \
- user{add,del,mod} group{add,del,mod} ; do
- newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
- done
-
- # comment out login.defs options that pam hates
- gawk -f "${FILESDIR}"/login_defs.awk \
- lib/getdef.c etc/login.defs \
- > "${D}"/etc/login.defs
-
- # remove manpages that pam will install for us
- # and/or don't apply when using pam
- find "${D}"/usr/share/man \
- '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
- -exec rm {} \;
- fi
-
- # Remove manpages that are handled by other packages
- find "${D}"/usr/share/man \
- '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
- -exec rm {} \;
-
- cd "${S}"
- dodoc ChangeLog NEWS TODO
- newdoc README README.download
- cd doc
- dodoc HOWTO README* WISHLIST *.txt
-}
-
-pkg_preinst() {
- rm -f "${ROOT}"/etc/pam.d/system-auth.new \
- "${ROOT}/etc/login.defs.new"
-
- use pam && pam_epam_expand "${D}"/etc/pam.d/login
-}
-
-pkg_postinst() {
- # Enable shadow groups (we need ROOT=/ here, as grpconv only
- # operate on / ...).
- if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
- if grpck -r &>/dev/null; then
- grpconv
- else
- ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
- ewarn "run 'grpconv' afterwards!"
- fi
- fi
-}
diff --git a/sys-apps/shadow/shadow-4.1.1.ebuild b/sys-apps/shadow/shadow-4.1.1.ebuild
deleted file mode 100644
index 544c902bf14c..000000000000
--- a/sys-apps/shadow/shadow-4.1.1.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.1.1.ebuild,v 1.5 2008/05/11 13:11:56 ulm Exp $
-
-inherit eutils libtool toolchain-funcs autotools pam multilib
-
-DESCRIPTION="Utilities to deal with user accounts"
-HOMEPAGE="http://shadow.pld.org.pl/ http://packages.qa.debian.org/s/shadow.html"
-SRC_URI="mirror://debian/pool/main/s/shadow/shadow_${PV}.orig.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="audit cracklib nls pam selinux skey"
-
-# Does not work with OpenPAM (yet?)
-RDEPEND="audit? ( sys-process/audit )
- cracklib? ( >=sys-libs/cracklib-2.7-r3 )
- pam? ( >=sys-libs/pam-0.99 )
- !sys-apps/pam-login
- !app-admin/nologin
- skey? ( sys-auth/skey )
- selinux? ( >=sys-libs/libselinux-1.28 )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${RDEPEND}
- pam? ( >=sys-auth/pambase-20080219.1 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-audit.patch #216291
-
- # tweak the default login.defs
- epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
- sed -i "s:@LIBDIR@:$(get_libdir):" etc/login.defs || die
-
- # Make user/group names more flexible #3485 / #22920
- epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
- epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
- econf \
- --disable-desrpc \
- --with-libcrypt \
- --enable-shared=no \
- --enable-static=yes \
- $(use_with audit) \
- $(use_with cracklib libcrack) \
- $(use_with pam libpam) \
- $(use_with skey) \
- $(use_with selinux) \
- $(use_enable nls) \
- || die "bad configure"
- emake || die "compile problem"
-}
-
-src_install() {
- emake DESTDIR="${D}" suidperms=4711 install || die "install problem"
- dosym useradd /usr/sbin/adduser
-
- # Remove libshadow and libmisc; see bug 37725 and the following
- # comment from shadow's README.linux:
- # Currently, libshadow.a is for internal use only, so if you see
- # -lshadow in a Makefile of some other package, it is safe to
- # remove it.
- rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins "${FILESDIR}"/securetty
- if ! use pam ; then
- insopts -m0600
- doins etc/login.access etc/limits
- fi
- # Output arch-specific cruft
- case $(tc-arch) in
- ppc*) echo "hvc0" >> "${D}"/etc/securetty
- echo "hvsi0" >> "${D}"/etc/securetty
- echo "ttyPSC0" >> "${D}"/etc/securetty;;
- hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
- arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
- sh) echo "ttySC0" >> "${D}"/etc/securetty
- echo "ttySC1" >> "${D}"/etc/securetty;;
- esac
-
- # needed for 'adduser -D'
- insinto /etc/default
- insopts -m0600
- doins "${FILESDIR}"/default/useradd
-
- # move passwd to / to help recover broke systems #64441
- mv "${D}"/usr/bin/passwd "${D}"/bin/
- dosym /bin/passwd /usr/bin/passwd
-
- cd "${S}"
- insinto /etc
- insopts -m0644
- newins etc/login.defs login.defs
-
- if use pam ; then
- dopamd "${FILESDIR}/pam.d-include/"{su,passwd,shadow}
-
- newpamd "${FILESDIR}/login.pamd.2" login
-
- for x in chage chsh chfn chpasswd newusers \
- user{add,del,mod} group{add,del,mod} ; do
- newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
- done
-
- # comment out login.defs options that pam hates
- gawk -f "${FILESDIR}"/login_defs.awk \
- lib/getdef.c etc/login.defs \
- > "${D}"/etc/login.defs
-
- # remove manpages that pam will install for us
- # and/or don't apply when using pam
- find "${D}"/usr/share/man \
- '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
- -exec rm {} \;
- fi
-
- # Remove manpages that are handled by other packages
- find "${D}"/usr/share/man \
- '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
- -exec rm {} \;
-
- cd "${S}"
- dodoc ChangeLog NEWS TODO
- newdoc README README.download
- cd doc
- dodoc HOWTO README* WISHLIST *.txt
-}
-
-pkg_preinst() {
- rm -f "${ROOT}"/etc/pam.d/system-auth.new \
- "${ROOT}/etc/login.defs.new"
-
- use pam && pam_epam_expand "${D}"/etc/pam.d/login
-}
-
-pkg_postinst() {
- # Enable shadow groups (we need ROOT=/ here, as grpconv only
- # operate on / ...).
- if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
- if grpck -r &>/dev/null; then
- grpconv
- else
- ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
- ewarn "run 'grpconv' afterwards!"
- fi
- fi
-}
diff --git a/sys-apps/shadow/shadow-4.1.2-r1.ebuild b/sys-apps/shadow/shadow-4.1.2-r1.ebuild
deleted file mode 100644
index 3a429ea91e6c..000000000000
--- a/sys-apps/shadow/shadow-4.1.2-r1.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.1.2-r1.ebuild,v 1.1 2008/05/27 00:19:58 flameeyes Exp $
-
-inherit eutils libtool toolchain-funcs autotools pam multilib
-
-DESCRIPTION="Utilities to deal with user accounts"
-HOMEPAGE="http://shadow.pld.org.pl/ http://packages.qa.debian.org/s/shadow.html"
-SRC_URI="ftp://pkg-shadow.alioth.debian.org/pub/pkg-shadow/shadow-${PV}.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="audit cracklib nls pam selinux skey"
-
-# Does not work with OpenPAM (yet?)
-RDEPEND="audit? ( sys-process/audit )
- cracklib? ( >=sys-libs/cracklib-2.7-r3 )
- pam? ( >=sys-libs/pam-0.99 )
- !sys-apps/pam-login
- !app-admin/nologin
- skey? ( sys-auth/skey )
- selinux? ( >=sys-libs/libselinux-1.28 )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${RDEPEND}
- pam? ( >=sys-auth/pambase-20080219.1 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # tweak the default login.defs
- epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
- sed -i "s:@LIBDIR@:$(get_libdir):" etc/login.defs || die
-
- # Make user/group names more flexible #3485 / #22920
- epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
- epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
- econf \
- --disable-desrpc \
- --with-libcrypt \
- --enable-shared=no \
- --enable-static=yes \
- $(use_with audit) \
- $(use_with cracklib libcrack) \
- $(use_with pam libpam) \
- $(use_with skey) \
- $(use_with selinux) \
- $(use_enable nls) \
- || die "bad configure"
- emake || die "compile problem"
-}
-
-src_install() {
- emake DESTDIR="${D}" suidperms=4711 install || die "install problem"
- dosym useradd /usr/sbin/adduser
-
- # Remove libshadow and libmisc; see bug 37725 and the following
- # comment from shadow's README.linux:
- # Currently, libshadow.a is for internal use only, so if you see
- # -lshadow in a Makefile of some other package, it is safe to
- # remove it.
- rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins "${FILESDIR}"/securetty
- if ! use pam ; then
- insopts -m0600
- doins etc/login.access etc/limits
- fi
- # Output arch-specific cruft
- case $(tc-arch) in
- ppc*) echo "hvc0" >> "${D}"/etc/securetty
- echo "hvsi0" >> "${D}"/etc/securetty
- echo "ttyPSC0" >> "${D}"/etc/securetty;;
- hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
- arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
- sh) echo "ttySC0" >> "${D}"/etc/securetty
- echo "ttySC1" >> "${D}"/etc/securetty;;
- esac
-
- # needed for 'adduser -D'
- insinto /etc/default
- insopts -m0600
- doins "${FILESDIR}"/default/useradd
-
- # move passwd to / to help recover broke systems #64441
- mv "${D}"/usr/bin/passwd "${D}"/bin/
- dosym /bin/passwd /usr/bin/passwd
-
- cd "${S}"
- insinto /etc
- insopts -m0644
- newins etc/login.defs login.defs
-
- if use pam ; then
- dopamd "${FILESDIR}/pam.d-include/"{su,passwd,shadow}
-
- newpamd "${FILESDIR}/login.pamd.2" login
-
- for x in chage chsh chfn chpasswd newusers \
- user{add,del,mod} group{add,del,mod} ; do
- newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
- done
-
- # comment out login.defs options that pam hates
- sed -i -f "${FILESDIR}"/login_defs_pam.sed \
- "${D}"/etc/login.defs
-
- # remove manpages that pam will install for us
- # and/or don't apply when using pam
- find "${D}"/usr/share/man \
- '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
- -exec rm {} \;
- fi
-
- # Remove manpages that are handled by other packages
- find "${D}"/usr/share/man \
- '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
- -exec rm {} \;
-
- cd "${S}"
- dodoc ChangeLog NEWS TODO
- newdoc README README.download
- cd doc
- dodoc HOWTO README* WISHLIST *.txt
-}
-
-pkg_preinst() {
- rm -f "${ROOT}"/etc/pam.d/system-auth.new \
- "${ROOT}/etc/login.defs.new"
-
- use pam && pam_epam_expand "${D}"/etc/pam.d/login
-}
-
-pkg_postinst() {
- # Enable shadow groups (we need ROOT=/ here, as grpconv only
- # operate on / ...).
- if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
- if grpck -r &>/dev/null; then
- grpconv
- else
- ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
- ewarn "run 'grpconv' afterwards!"
- fi
- fi
-}
diff --git a/sys-apps/shadow/shadow-4.1.2.1.ebuild b/sys-apps/shadow/shadow-4.1.2.1.ebuild
deleted file mode 100644
index f73d9addbd0e..000000000000
--- a/sys-apps/shadow/shadow-4.1.2.1.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.1.2.1.ebuild,v 1.4 2008/12/01 04:08:07 vapier Exp $
-
-inherit eutils libtool toolchain-funcs autotools pam multilib
-
-DESCRIPTION="Utilities to deal with user accounts"
-HOMEPAGE="http://shadow.pld.org.pl/ http://packages.qa.debian.org/s/shadow.html"
-SRC_URI="ftp://pkg-shadow.alioth.debian.org/pub/pkg-shadow/shadow-${PV}.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="audit cracklib nls pam selinux skey"
-
-RDEPEND="audit? ( sys-process/audit )
- cracklib? ( >=sys-libs/cracklib-2.7-r3 )
- pam? ( virtual/pam )
- !sys-apps/pam-login
- !app-admin/nologin
- skey? ( sys-auth/skey )
- selinux? ( >=sys-libs/libselinux-1.28 )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${RDEPEND}
- pam? ( >=sys-auth/pambase-20080219.1 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # tweak the default login.defs
- epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
- sed -i "s:@LIBDIR@:$(get_libdir):" etc/login.defs || die
-
- # Make user/group names more flexible #3485 / #22920
- epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
- epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
-
- # Support OpenPAM #232586
- epatch "${FILESDIR}"/${P}+openpam.patch
-
- eautoconf
- eautoheader
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
- econf \
- --enable-shared=no \
- --enable-static=yes \
- $(use_with audit) \
- $(use_with cracklib libcrack) \
- $(use_with pam libpam) \
- $(use_with skey) \
- $(use_with selinux) \
- $(use_enable nls) \
- || die "bad configure"
- emake || die "compile problem"
-}
-
-src_install() {
- emake DESTDIR="${D}" suidperms=4711 install || die "install problem"
- dosym useradd /usr/sbin/adduser
-
- # Remove libshadow and libmisc; see bug 37725 and the following
- # comment from shadow's README.linux:
- # Currently, libshadow.a is for internal use only, so if you see
- # -lshadow in a Makefile of some other package, it is safe to
- # remove it.
- rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins "${FILESDIR}"/securetty
- if ! use pam ; then
- insopts -m0600
- doins etc/login.access etc/limits
- fi
- # Output arch-specific cruft
- case $(tc-arch) in
- ppc*) echo "hvc0" >> "${D}"/etc/securetty
- echo "hvsi0" >> "${D}"/etc/securetty
- echo "ttyPSC0" >> "${D}"/etc/securetty;;
- hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
- arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
- sh) echo "ttySC0" >> "${D}"/etc/securetty
- echo "ttySC1" >> "${D}"/etc/securetty;;
- esac
-
- # needed for 'adduser -D'
- insinto /etc/default
- insopts -m0600
- doins "${FILESDIR}"/default/useradd
-
- # move passwd to / to help recover broke systems #64441
- mv "${D}"/usr/bin/passwd "${D}"/bin/
- dosym /bin/passwd /usr/bin/passwd
-
- cd "${S}"
- insinto /etc
- insopts -m0644
- newins etc/login.defs login.defs
-
- if use pam ; then
- dopamd "${FILESDIR}/pam.d-include/"{su,passwd,shadow}
-
- newpamd "${FILESDIR}/login.pamd.2" login
-
- for x in chage chsh chfn chpasswd newusers \
- user{add,del,mod} group{add,del,mod} ; do
- newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
- done
-
- # comment out login.defs options that pam hates
- sed -i -f "${FILESDIR}"/login_defs_pam.sed \
- "${D}"/etc/login.defs
-
- # remove manpages that pam will install for us
- # and/or don't apply when using pam
- find "${D}"/usr/share/man \
- '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
- -exec rm {} \;
- fi
-
- # Remove manpages that are handled by other packages
- find "${D}"/usr/share/man \
- '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
- -exec rm {} \;
-
- cd "${S}"
- dodoc ChangeLog NEWS TODO
- newdoc README README.download
- cd doc
- dodoc HOWTO README* WISHLIST *.txt
-}
-
-pkg_preinst() {
- rm -f "${ROOT}"/etc/pam.d/system-auth.new \
- "${ROOT}/etc/login.defs.new"
-
- use pam && pam_epam_expand "${D}"/etc/pam.d/login
-}
-
-pkg_postinst() {
- # Enable shadow groups (we need ROOT=/ here, as grpconv only
- # operate on / ...).
- if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
- if grpck -r &>/dev/null; then
- grpconv
- else
- ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
- ewarn "run 'grpconv' afterwards!"
- fi
- fi
-}