summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-11 17:45:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-11 17:45:16 +0000
commit2168dd34d42e15bfcd4b309e59142bb1297d23cc (patch)
treec82bef2141f9731ca376b2c55d039ce4fd118daa /sys-apps
parentAdd contributed patches for kernel 3.10.0, see bug 470896 (diff)
downloadgentoo-2-2168dd34d42e15bfcd4b309e59142bb1297d23cc.tar.gz
gentoo-2-2168dd34d42e15bfcd4b309e59142bb1297d23cc.tar.bz2
gentoo-2-2168dd34d42e15bfcd4b309e59142bb1297d23cc.zip
Run udevadm control --reload to reload the /etc/udev/hwdb.bin after regenerating it.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20130717-r1.ebuild8
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild8
3 files changed, 18 insertions, 5 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index cd44e4f2aa77..8ab2054595bf 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.113 2013/07/23 05:00:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.114 2013/08/11 17:45:16 ssuominen Exp $
+
+ 11 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> hwids-20130717-r1.ebuild,
+ hwids-99999999.ebuild:
+ Run udevadm control --reload to reload the /etc/udev/hwdb.bin after
+ regenerating it.
*hwids-20130717-r1 (23 Jul 2013)
diff --git a/sys-apps/hwids/hwids-20130717-r1.ebuild b/sys-apps/hwids/hwids-20130717-r1.ebuild
index 6e478889f0d4..94b97dd0d30b 100644
--- a/sys-apps/hwids/hwids-20130717-r1.ebuild
+++ b/sys-apps/hwids/hwids-20130717-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130717-r1.ebuild,v 1.1 2013/07/23 05:00:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130717-r1.ebuild,v 1.2 2013/08/11 17:45:16 ssuominen Exp $
EAPI=5
inherit udev eutils
@@ -43,5 +43,9 @@ src_install() {
}
pkg_postinst() {
- use udev && udevadm hwdb --update --root="${ROOT%/}"
+ if use udev; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ udevadm control --reload
+ fi
}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 55f59cd033d6..c188df62d70a 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.21 2013/07/23 05:00:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.22 2013/08/11 17:45:16 ssuominen Exp $
EAPI=5
inherit udev eutils git-2
@@ -41,5 +41,9 @@ src_install() {
}
pkg_postinst() {
- use udev && udevadm hwdb --update --root="${ROOT%/}"
+ if use udev; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ udevadm control --reload
+ fi
}