summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-01-30 04:35:10 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-01-30 04:35:10 +0000
commit100ee8107d8ef7c37f6c67a9de6f736041b6b279 (patch)
treeba59bd5e41722c1cebcb55900b8be5a99cefcb29 /sys-apps
parentfix bug #39808, touching .keep files obsolete. (Manifest recommit) (diff)
downloadgentoo-2-100ee8107d8ef7c37f6c67a9de6f736041b6b279.tar.gz
gentoo-2-100ee8107d8ef7c37f6c67a9de6f736041b6b279.tar.bz2
gentoo-2-100ee8107d8ef7c37f6c67a9de6f736041b6b279.zip
Update version, fixing bug #39397.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/module-init-tools/ChangeLog8
-rw-r--r--sys-apps/module-init-tools/files/digest-module-init-tools-3.0_pre82
-rw-r--r--sys-apps/module-init-tools/module-init-tools-3.0_pre8.ebuild163
3 files changed, 172 insertions, 1 deletions
diff --git a/sys-apps/module-init-tools/ChangeLog b/sys-apps/module-init-tools/ChangeLog
index 2f59ae69e5a9..7021669ca01a 100644
--- a/sys-apps/module-init-tools/ChangeLog
+++ b/sys-apps/module-init-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/module-init-tools
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.50 2004/01/26 22:43:54 dorileo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.51 2004/01/30 04:35:10 azarah Exp $
+
+*module-init-tools-3.0_pre8 (30 Jan 2004)
+
+ 30 Jan 2004; Martin Schlemmer <azarah@gentoo.org>
+ module-init-tools-3.0_pre8.ebuild:
+ Update version, fixing bug #39397.
*module-init-tools-3.0_pre7 (26 Jan 2004)
diff --git a/sys-apps/module-init-tools/files/digest-module-init-tools-3.0_pre8 b/sys-apps/module-init-tools/files/digest-module-init-tools-3.0_pre8
new file mode 100644
index 000000000000..b1da006d82d2
--- /dev/null
+++ b/sys-apps/module-init-tools/files/digest-module-init-tools-3.0_pre8
@@ -0,0 +1,2 @@
+MD5 bb8d33e000d0ed9f623a1e8ab467ab32 module-init-tools-3.0-pre8.tar.bz2 120705
+MD5 704c8d2834bcaa6f31d4ad79d154157a modutils-2.4.26.tar.bz2 235135
diff --git a/sys-apps/module-init-tools/module-init-tools-3.0_pre8.ebuild b/sys-apps/module-init-tools/module-init-tools-3.0_pre8.ebuild
new file mode 100644
index 000000000000..38f115758ff0
--- /dev/null
+++ b/sys-apps/module-init-tools/module-init-tools-3.0_pre8.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-3.0_pre8.ebuild,v 1.1 2004/01/30 04:35:10 azarah Exp $
+
+# This ebuild includes backwards compatability for stable 2.4 kernels
+IUSE=""
+
+inherit flag-o-matic eutils gnuconfig
+
+MYP="${P/_pre/-pre}"
+S="${WORKDIR}/${MYP}"
+MODUTILS_PV="2.4.26"
+DESCRIPTION="Kernel module tools for the development kernel >=2.5.48"
+SRC_URI="mirror://kernel/linux/kernel/people/rusty/modules/${MYP}.tar.bz2
+ mirror://kernel/linux/kernel/people/rusty/modules/old/${MYP}.tar.bz2
+ mirror://kernel/linux/utils/kernel/modutils/v2.4/modutils-${MODUTILS_PV}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/rusty/modules"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~arm ~ia64 ~ppc64 ~hppa"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-libs/zlib"
+
+PROVIDE="virtual/modutils"
+
+src_unpack() {
+ unpack ${A}
+
+ # With the b0rked modutils, "modprobe hid" does work. But if something
+ # (like hotplug) tries to auto-load hid (because another module needs it,
+ # via the kernel module auto-loader) and keybdev.o or mousedev.o don't
+ # exist, then the "above" clause fails and the hid module never gets
+ # loaded, and then things like USB will fail. Thus we remove it all
+ # together.
+ #
+ # <drobbins@gentoo.org> (26 Mar 2003)
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+ epatch ${FILESDIR}/modutils-2.4.22-no-above-below.patch
+
+ # Support legacy .o modules
+ cd ${S}; epatch ${FILESDIR}/${PN}-0.9.15-legacy-modext-support.patch
+
+ cd ${S}
+ rm -f missing
+ automake --add-missing
+}
+
+src_compile() {
+
+ # If running mips64, we need updated configure data
+ use mips && gnuconfig_update
+
+ local myconf=
+
+ filter-flags -fPIC
+
+ einfo "Building modutils..."
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+
+ econf \
+ --disable-strip \
+ --prefix=/ \
+ --disable-insmod-static \
+ --disable-zlib \
+ ${myconf}
+
+ emake || die "emake modutils failed"
+ einfo "Building module-init-tools..."
+ cd ${S}
+
+ econf \
+ --prefix=/ \
+ --enable-zlib \
+ ${myconf}
+
+ emake || die "emake module-init-tools failed"
+}
+
+src_install () {
+
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+ einstall prefix="${D}"
+
+ docinto modutils-${MODUTILS_PV}
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+
+ cd ${S}
+ # This copies the old version of modutils to *.old so it still works
+ # with kernels <= 2.4; new versions will execve() the .old version if
+ # a 2.4 kernel is running...
+ # This code was borrowed from the module-init-tools Makefile
+ local runme=
+ local f=
+ for f in lsmod modprobe rmmod depmod insmod modinfo
+ do
+ if [ -L ${D}/sbin/${f} ]
+ then
+ einfo "Moving symlink $f to ${f}.old"
+ #runme = the target of the symlink with a .old tagged on.
+ runme="`ls -l ${D}/sbin/${f} | sed 's/.* -> //'`.old"
+ [ ! -e ${D}/sbin/${runme} ] || einfo "${D}/sbin/${runme} not found"
+ dosym $runme /sbin/${f} || die
+ elif [ -e ${D}/sbin/${f} ]
+ then
+ einfo "Moving executable $f to ${f}.old"
+ fi
+ mv -f ${D}/sbin/${f} ${D}/sbin/${f}.old
+ done
+ # Move the man pages as well. We only do this for the man pages of the
+ # tools that module-init-tools will replace.
+ for f in ${D}/usr/share/man/man8/{lsmod,modprobe,rmmod,depmod,insmod}.8
+ do
+ mv -f ${f} ${f%\.*}.old.${f##*\.}
+ done
+
+ einstall prefix=${D}
+
+ # Install compat symlink
+ dosym ../bin/lsmod /sbin/lsmod
+ dosym ../sbin/insmod.old /bin/lsmod.old
+ # Install the modules.conf2modprobe.conf tool, so we can update
+ # modprobe.conf.
+ into /
+ dosbin ${S}/generate-modprobe.conf
+ # Create the new modprobe.conf
+ dodir /etc
+ rm -f ${D}/etc/modprobe.conf
+ if [ ! -f ${ROOT}/etc/modprobe.devfs ]
+ then
+ # Support file for the devfs hack .. needed else modprobe borks.
+ # Baselayout-1.8.6.3 or there abouts will have a modules-update that
+ # will correctly generate /etc/modprobe.devfs ....
+ echo "### This file is automatically generated by modules-update" \
+ > ${D}/etc/modprobe.devfs
+ else
+ # This is dynamic, so we do not want this in the package ...
+ rm -f ${D}/etc/modprobe.devfs
+ fi
+
+ doman *.[1-8]
+ docinto /
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ einfo "Updating config files..."
+ if [ -x /sbin/modules-update ]
+ then
+ /sbin/modules-update
+ elif [ -x /sbin/update-modules ]
+ then
+ /sbin/update-modules
+ elif [ -x /usr/sbin/update-modules ]
+ then
+ /usr/sbin/update-modules
+ fi
+ fi
+}
+