summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-04-09 12:16:34 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-04-09 12:16:34 +0000
commit068d8d05608267aea2acac458f8ff0c0150decbb (patch)
tree1300c5d52ed9d5b2054d844730dee1a3a26abc30 /sys-apps
parentAdd ~amd64-linux keyword (diff)
downloadgentoo-2-068d8d05608267aea2acac458f8ff0c0150decbb.tar.gz
gentoo-2-068d8d05608267aea2acac458f8ff0c0150decbb.tar.bz2
gentoo-2-068d8d05608267aea2acac458f8ff0c0150decbb.zip
Version bump, upstream address changed. Drop old.
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/edac-utils/ChangeLog11
-rw-r--r--sys-apps/edac-utils/edac-utils-0.12.ebuild37
-rw-r--r--sys-apps/edac-utils/edac-utils-0.18.ebuild (renamed from sys-apps/edac-utils/edac-utils-0.16.ebuild)21
3 files changed, 21 insertions, 48 deletions
diff --git a/sys-apps/edac-utils/ChangeLog b/sys-apps/edac-utils/ChangeLog
index 6b5ee4336b58..2b3973c15f08 100644
--- a/sys-apps/edac-utils/ChangeLog
+++ b/sys-apps/edac-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/edac-utils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/ChangeLog,v 1.3 2009/12/15 14:43:36 pva Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/ChangeLog,v 1.4 2013/04/09 12:16:34 dev-zero Exp $
+
+*edac-utils-0.18 (09 Apr 2013)
+
+ 09 Apr 2013; Tiziano Müller <dev-zero@gentoo.org> +edac-utils-0.18.ebuild,
+ -edac-utils-0.12.ebuild, -edac-utils-0.16.ebuild:
+ Version bump, upstream address changed. Drop old.
15 Dec 2009; Peter Volkov <pva@gentoo.org> metadata.xml:
metadata.xml: added required herd tag.
@@ -16,4 +22,3 @@
09 Apr 2008; Tiziano Müller <dev-zero@gentoo.org> +metadata.xml,
+edac-utils-0.12.ebuild:
Initial commit.
-
diff --git a/sys-apps/edac-utils/edac-utils-0.12.ebuild b/sys-apps/edac-utils/edac-utils-0.12.ebuild
deleted file mode 100644
index ab854b11e330..000000000000
--- a/sys-apps/edac-utils/edac-utils-0.12.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/edac-utils-0.12.ebuild,v 1.1 2008/04/09 20:53:08 dev-zero Exp $
-
-DESCRIPTION="Userspace helper for Linux kernel EDAC drivers"
-HOMEPAGE="http://sourceforge.net/projects/edac-utils/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug"
-
-DEPEND="sys-fs/sysfsutils"
-RDEPEND="${DEPEND}
- sys-apps/dmidecode"
-
-src_compile() {
- econf $(use_enable debug)
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog DISCLAIMER META NEWS README TODO
-
- # We don't need this init.d file
- # Modules should be loaded by adding them to /etc/conf.d/modules
- # The rest is done via the udev-rule
- rm "${D}/etc/init.d/edac"
-}
-
-pkg_postinst() {
- elog "There must be an entry for your mainboard in /etc/edac/labels.db"
- elog "in case you want nice labels in /sys/module/*_edac/"
- elog "Run the following command to check whether such an entry is already available:"
- elog " edac-ctl --print-labels"
-}
diff --git a/sys-apps/edac-utils/edac-utils-0.16.ebuild b/sys-apps/edac-utils/edac-utils-0.18.ebuild
index e7749cc6bd17..1def9455e288 100644
--- a/sys-apps/edac-utils/edac-utils-0.16.ebuild
+++ b/sys-apps/edac-utils/edac-utils-0.18.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/edac-utils-0.16.ebuild,v 1.1 2009/08/03 17:34:47 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/edac-utils-0.18.ebuild,v 1.1 2013/04/09 12:16:33 dev-zero Exp $
-EAPI="2"
+EAPI=5
+
+inherit eutils
DESCRIPTION="Userspace helper for Linux kernel EDAC drivers"
-HOMEPAGE="http://sourceforge.net/projects/edac-utils/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="https://github.com/grondo/edac-utils"
+SRC_URI="https://github.com/grondo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
@@ -17,17 +19,20 @@ RDEPEND="${DEPEND}
sys-apps/dmidecode"
src_configure() {
- econf $(use_enable debug)
+ econf \
+ --disable-static \
+ $(use_enable debug)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog DISCLAIMER META NEWS README TODO
+ default
# We don't need this init.d file
# Modules should be loaded by adding them to /etc/conf.d/modules
# The rest is done via the udev-rule
rm -rf "${D}/etc/init.d"
+
+ prune_libtool_files
}
pkg_postinst() {