summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-08-06 17:44:45 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-08-06 17:44:45 +0000
commit633b63454e8209c0b415e544d60746ff812e4b80 (patch)
treeba25b7c586486c08a52b0219118733f4ef964d5d /sys-apps/xinetd
parentVersion bumped. (diff)
downloadgentoo-2-633b63454e8209c0b415e544d60746ff812e4b80.tar.gz
gentoo-2-633b63454e8209c0b415e544d60746ff812e4b80.tar.bz2
gentoo-2-633b63454e8209c0b415e544d60746ff812e4b80.zip
Version bumped.
Diffstat (limited to 'sys-apps/xinetd')
-rw-r--r--sys-apps/xinetd/ChangeLog7
-rw-r--r--sys-apps/xinetd/Manifest4
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.121
-rw-r--r--sys-apps/xinetd/xinetd-2.3.12.ebuild62
4 files changed, 71 insertions, 3 deletions
diff --git a/sys-apps/xinetd/ChangeLog b/sys-apps/xinetd/ChangeLog
index b927044325d6..d6bcfc1664bf 100644
--- a/sys-apps/xinetd/ChangeLog
+++ b/sys-apps/xinetd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/xinetd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.22 2003/05/19 16:48:39 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.23 2003/08/06 17:44:34 mholzer Exp $
+
+*xinetd-2.3.12 (06 Aug 2003)
+
+ 06 Aug 2003; Martin Holzer <mholzer@gentoo.org> xinetd-2.3.12.ebuild:
+ Version bumped.
19 May 2003; Martin Holzer <mholzer@gentoo.org> xinetd-2.3.10.ebuild,
xinetd-2.3.10.ebuild, xinetd-2.3.11.ebuild, xinetd-2.3.7.ebuild,
diff --git a/sys-apps/xinetd/Manifest b/sys-apps/xinetd/Manifest
index 35e5bb60f587..c9ddb7084495 100644
--- a/sys-apps/xinetd/Manifest
+++ b/sys-apps/xinetd/Manifest
@@ -1,6 +1,6 @@
-MD5 890d6579167984ad9eb64a42273ff7e5 ChangeLog 3906
+MD5 6d955177a4012cc4a1c74e30881768de ChangeLog 4027
MD5 ffa5acabc1b35a6e07545832f003001b xinetd-2.3.11.ebuild 2039
-MD5 80f3a49d0d76a0a40ce8fd62dbbcea19 xinetd-2.3.12.ebuild 2046
+MD5 e1da852d7224065edbe4451bceb227c5 xinetd-2.3.12.ebuild 2047
MD5 469ecc467df958570cae2caad4391dd1 files/digest-xinetd-2.3.11 65
MD5 41406ad0e85906703ed6e0def5b42bed files/svc-xinetd 827
MD5 897e24c3c7cc5a08093dfcb3a71fc0ee files/xconv.pl 3030
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.12 b/sys-apps/xinetd/files/digest-xinetd-2.3.12
new file mode 100644
index 000000000000..9807d0107a3d
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.12
@@ -0,0 +1 @@
+MD5 16154191731b6449d934eecacef647dd xinetd-2.3.12.tar.gz 292202
diff --git a/sys-apps/xinetd/xinetd-2.3.12.ebuild b/sys-apps/xinetd/xinetd-2.3.12.ebuild
new file mode 100644
index 000000000000..aa2a4d1b7d1a
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.12.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.12.ebuild,v 1.1 2003/08/06 17:44:34 mholzer Exp $
+
+DESCRIPTION="Xinetd is a powerful replacement for inetd, with advanced features"
+HOMEPAGE="http://www.xinetd.org"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~mips ~alpha ~hppa"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${DEPEND} dev-lang/perl"
+
+PROVIDE="virtual/inetd"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+
+ # the --with-inet6 is now obsolete. Services will default to IPv4 unless configured otherwise.
+
+ econf --with-loadavg ${myconf}
+
+ # Fix CFLAGS
+ sed "/^CFLAGS/s/+=/=/" < Makefile > makefile
+ mv --force makefile Makefile
+
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ into /usr ; dosbin xinetd/xinetd xinetd/itox
+ exeinto /usr/sbin ; doexe xinetd/xconv.pl
+
+ newman xinetd/xinetd.conf.man xinetd.conf.5
+ newman xinetd/xinetd.log.man xinetd.log.8
+ newman xinetd/xinetd.man xinetd.8
+ doman xinetd/itox.8
+
+ newdoc xinetd/sample.conf xinetd.conf.dist.sample
+ newdoc ${FILESDIR}/xinetd.conf xinetd.conf.default || die
+ dodoc AUDIT INSTALL README TODO CHANGELOG COPYRIGHT
+
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/etc.xinetd.d/* || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/xinetd.rc6 xinetd || die
+ insinto /etc/conf.d ; newins ${FILESDIR}/xinetd.confd xinetd || die
+ insinto /etc ; doins ${FILESDIR}/xinetd.conf || die
+}
+
+pkg_postinst(){
+ einfo "This ebuild introduces the /etc/xinetd.d includedir with a default"
+ einfo "/etc/xinetd.conf file. Check your config files if you're upgrading from an older"
+ einfo "ebuild version. You should browse /etc/xinetd.conf and the files in /etc/xinetd.d."
+ ewarn
+ ewarn "PLEASE NOTE: Everything is off by default with access restricted to localhost."
+ ewarn
+ einfo "Check /etc/conf.d/xinetd for the startup options."
+ echo ""
+}