summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-02-23 09:43:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-02-23 09:43:15 +0000
commit833e1c108accac4874ca708316666dadc793ac3c (patch)
tree7875d206acfed4450a13f1f54b2e63c170674ff4 /sys-apps/usb_modeswitch
parentStop using prepalldocs. (diff)
downloadgentoo-2-833e1c108accac4874ca708316666dadc793ac3c.tar.gz
gentoo-2-833e1c108accac4874ca708316666dadc793ac3c.tar.bz2
gentoo-2-833e1c108accac4874ca708316666dadc793ac3c.zip
Fix building with --as-needed and respect CPPFLAGS. Thanks to Kevin Pyle in bug #248397 for the patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/usb_modeswitch')
-rw-r--r--sys-apps/usb_modeswitch/ChangeLog9
-rw-r--r--sys-apps/usb_modeswitch/usb_modeswitch-0.9.4.ebuild6
2 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/usb_modeswitch/ChangeLog b/sys-apps/usb_modeswitch/ChangeLog
index 932f85414276..a41ceddd41db 100644
--- a/sys-apps/usb_modeswitch/ChangeLog
+++ b/sys-apps/usb_modeswitch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/usb_modeswitch
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.1 2008/08/25 22:28:23 wschlich Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.2 2009/02/23 09:43:14 flameeyes Exp $
+
+ 23 Feb 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ usb_modeswitch-0.9.4.ebuild:
+ Fix building with --as-needed and respect CPPFLAGS. Thanks to Kevin Pyle
+ in bug #248397 for the patch.
*usb_modeswitch-0.9.4 (25 Aug 2008)
diff --git a/sys-apps/usb_modeswitch/usb_modeswitch-0.9.4.ebuild b/sys-apps/usb_modeswitch/usb_modeswitch-0.9.4.ebuild
index 1ae6addfeb19..d28c45fcd68a 100644
--- a/sys-apps/usb_modeswitch/usb_modeswitch-0.9.4.ebuild
+++ b/sys-apps/usb_modeswitch/usb_modeswitch-0.9.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/usb_modeswitch-0.9.4.ebuild,v 1.1 2008/08/25 22:28:23 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/usb_modeswitch-0.9.4.ebuild,v 1.2 2009/02/23 09:43:15 flameeyes Exp $
inherit toolchain-funcs
@@ -17,7 +17,7 @@ DEPEND="dev-libs/libusb"
RDEPEND="${DEPEND}"
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -l usb -o usb_modeswitch usb_modeswitch.c \
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o usb_modeswitch usb_modeswitch.c -lusb \
|| die 'failed to compile usb_modeswitch'
}