summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-22 05:34:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-22 05:34:03 +0000
commit16c7a82f150bbd08f1bae0ac600c7e3689037066 (patch)
treec4f19a871223e9bd6c2ae89a282e6ed366688d96 /sys-apps/texinfo
parentremove unused versions (diff)
downloadgentoo-2-16c7a82f150bbd08f1bae0ac600c7e3689037066.tar.gz
gentoo-2-16c7a82f150bbd08f1bae0ac600c7e3689037066.tar.bz2
gentoo-2-16c7a82f150bbd08f1bae0ac600c7e3689037066.zip
Bug #220695, version bump to avoid whitespace problems with install-info.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/ChangeLog7
-rw-r--r--sys-apps/texinfo/texinfo-4.13.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index 34dff5716e7b..9a94678ab702 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/texinfo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.99 2008/05/05 04:24:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.100 2008/10/22 05:34:03 robbat2 Exp $
+
+*texinfo-4.13 (22 Oct 2008)
+
+ 22 Oct 2008; Robin H. Johnson <robbat2@gentoo.org> +texinfo-4.13.ebuild:
+ Bug #220695, version bump to avoid whitespace problems with install-info.
*texinfo-4.12 (05 May 2008)
diff --git a/sys-apps/texinfo/texinfo-4.13.ebuild b/sys-apps/texinfo/texinfo-4.13.ebuild
new file mode 100644
index 000000000000..b1f193dde709
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.13.ebuild,v 1.1 2008/10/22 05:34:03 robbat2 Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static"
+
+RDEPEND="!=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf $(use_enable nls) || die
+ emake || die "emake"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
+ newdoc info/README README.info
+ newdoc makeinfo/README README.makeinfo
+
+ rm -f "${D}"/usr/lib/charset.alias #195148
+}