summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-03 23:05:19 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-03 23:05:19 +0000
commit788b3bdaac9b10df35917980a1b33d80f951c3d0 (patch)
tree37341f505fad81a9e68c6d68d2c68fdf85ba0ea5 /sys-apps/sharutils
parentremoved libtool 1.4 depend (diff)
downloadgentoo-2-788b3bdaac9b10df35917980a1b33d80f951c3d0.tar.gz
gentoo-2-788b3bdaac9b10df35917980a1b33d80f951c3d0.tar.bz2
gentoo-2-788b3bdaac9b10df35917980a1b33d80f951c3d0.zip
fixed info warnings.
Diffstat (limited to 'sys-apps/sharutils')
-rw-r--r--sys-apps/sharutils/files/sharutils-4.2.1-r4-gentoo.diff43
-rw-r--r--sys-apps/sharutils/sharutils-4.2.1-r4.ebuild54
2 files changed, 97 insertions, 0 deletions
diff --git a/sys-apps/sharutils/files/sharutils-4.2.1-r4-gentoo.diff b/sys-apps/sharutils/files/sharutils-4.2.1-r4-gentoo.diff
new file mode 100644
index 000000000000..8b504f587015
--- /dev/null
+++ b/sys-apps/sharutils/files/sharutils-4.2.1-r4-gentoo.diff
@@ -0,0 +1,43 @@
+diff -r -C2 sharutils-4.2.1.orig/doc/remsync.texi sharutils-4.2.1/doc/remsync.texi
+*** sharutils-4.2.1.orig/doc/remsync.texi Thu Nov 30 18:15:37 1995
+--- sharutils-4.2.1/doc/remsync.texi Fri Aug 3 18:57:02 2001
+***************
+*** 8,11 ****
+--- 8,15 ----
+
+ @ifinfo
++
++ @direntry
++ * remsync: (remsync). Synchronize remote files (sharutils).
++ @end direntry
+ This file documents the @code{remsync} command and friends, which have
+ the purpose of synchronizing remote directory trees using email.
+diff -r -C2 sharutils-4.2.1.orig/doc/sharutils.texi sharutils-4.2.1/doc/sharutils.texi
+*** sharutils-4.2.1.orig/doc/sharutils.texi Fri Nov 24 21:42:52 1995
+--- sharutils-4.2.1/doc/sharutils.texi Fri Aug 3 18:29:43 2001
+***************
+*** 16,31 ****
+
+ @ifinfo
+! @format
+! START-INFO-DIR-ENTRY
+ * Shar utilities: (sharutils). GNU shar utilities.
+! * mail-files: (sharutils)mail-files invocation. Send files to remote site.
+! * mailshar: (sharutils)mailshar invocation. Make and send a shell archive.
+! * remsync: (sharutils)remsync invocation. Synchronize remote files.
+! * shar: (sharutils)shar invocation. Make a shell archive.
+! * unshar: (sharutils)unshar invocation. Explode a shell archive.
+! * uudecode: (sharutils)uudecode invocation. Restore file from 7-bits.
+! * uuencode: (sharutils)uuencode invocation. Force binary file to 7-bits.
+! END-INFO-DIR-ENTRY
+! @end format
+ @end ifinfo
+
+--- 16,22 ----
+
+ @ifinfo
+! @direntry
+ * Shar utilities: (sharutils). GNU shar utilities.
+! @end direntry
+ @end ifinfo
+
diff --git a/sys-apps/sharutils/sharutils-4.2.1-r4.ebuild b/sys-apps/sharutils/sharutils-4.2.1-r4.ebuild
new file mode 100644
index 000000000000..6dcd491dc100
--- /dev/null
+++ b/sys-apps/sharutils/sharutils-4.2.1-r4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sharutils/sharutils-4.2.1-r4.ebuild,v 1.1 2001/08/03 23:05:19 chadh Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools to deal with shar archives"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/sharutils/${A}
+ ftp://prep.ai.mit.edu/gnu/sharutils/${A}"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gettext-0.10.35"
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}/po
+ mv nl.po nl.po.orig
+ sed -e 's/aangemaakt/aangemaakt\\n/' nl.po.orig > nl.po
+ mv pt.po pt.po.orig
+ sed -e 's/de %dk/de %dk\\n/' pt.po.orig > pt.po
+
+}
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr
+ try make ${MAKEOPTS} localedir=/usr/share/locale
+}
+
+src_install() {
+
+ try make prefix=${D}/usr localedir=${D}/usr/share/locale infodir=${D}/usr/share/info install
+
+ doman doc/*.[15]
+ #Remove some strange locals
+ cd ${D}/usr/share/locale
+ for i in *.
+ do
+ rm -rf ${i}
+ done
+ rm -rf ${D}/usr/lib
+
+ cd ${S}
+ dodoc AUTHORS BACKLOG COPYING ChangeLog ChangeLog.OLD \
+ NEWS README README.OLD THANKS TODO
+}
+
+