summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2006-06-05 12:04:37 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2006-06-05 12:04:37 +0000
commitc055736d7414752b14cd90940f2112c288625a18 (patch)
treecfd82123df412784276cf9fe3469336c08d673cc /sys-apps/qingy
parentAdded hibernate-script:vim (diff)
downloadgentoo-2-c055736d7414752b14cd90940f2112c288625a18.tar.gz
gentoo-2-c055736d7414752b14cd90940f2112c288625a18.tar.bz2
gentoo-2-c055736d7414752b14cd90940f2112c288625a18.zip
Version bump. Wiped out older version.
(Portage version: 2.1_rc3-r3)
Diffstat (limited to 'sys-apps/qingy')
-rw-r--r--sys-apps/qingy/ChangeLog9
-rw-r--r--sys-apps/qingy/files/digest-qingy-0.8.03
-rw-r--r--sys-apps/qingy/qingy-0.8.0.ebuild90
3 files changed, 101 insertions, 1 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index cfa123030c1f..6350e528ce90 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/qingy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.30 2006/05/11 06:35:38 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.31 2006/06/05 12:04:36 s4t4n Exp $
+
+*qingy-0.8.0 (05 Jun 2006)
+
+ 05 June 2006; Michele Noberasco <s4t4n@gentoo.org> qingy-0.8.0.ebuild:
+ Version bump.
+ qingy-0.6.0.ebuild:
+ Removed older version.
11 May 2006; Michele Noberasco <s4t4n@gentoo.org> qingy-0.7.4.ebuild:
Stable for x86.
diff --git a/sys-apps/qingy/files/digest-qingy-0.8.0 b/sys-apps/qingy/files/digest-qingy-0.8.0
new file mode 100644
index 000000000000..cdccfc03ccef
--- /dev/null
+++ b/sys-apps/qingy/files/digest-qingy-0.8.0
@@ -0,0 +1,3 @@
+MD5 9dd9ab3c4f72ad52f5823a3b0bfd2013 qingy-0.8.0.tar.bz2 597511
+RMD160 2dbb5d14b3cde57a40964cfce921ddbf9389473f qingy-0.8.0.tar.bz2 597511
+SHA256 7c74fb499aca3e38a14d0a028b5411e205a3a2e9eb3d376bb4acf4eefa8574e8 qingy-0.8.0.tar.bz2 597511
diff --git a/sys-apps/qingy/qingy-0.8.0.ebuild b/sys-apps/qingy/qingy-0.8.0.ebuild
new file mode 100644
index 000000000000..2ce3c57786d5
--- /dev/null
+++ b/sys-apps/qingy/qingy-0.8.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.8.0.ebuild,v 1.1 2006/06/05 12:04:37 s4t4n Exp $
+
+DESCRIPTION="a DirectFB getty replacement"
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="crypto_openssl crypto_libgcrypt emacs gpm pam static"
+
+RDEPEND=">=dev-libs/DirectFB-0.9.18
+ crypto_openssl? ( >=dev-libs/openssl-0.9.7e )
+ crypto_libgcrypt? ( >=dev-libs/libgcrypt-1.2.1 )
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
+ >=sys-libs/ncurses-5.4-r6
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver )
+ virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_unpack()
+{
+ if use crypto_openssl && use crypto_libgcrypt; then
+ echo
+ eerror "You can have openssl or libgcrypt as a crypto library, not both."
+ eerror "Please check your USE flags..."
+ echo
+ die "USE flags check failed"
+ fi
+
+ unpack ${A}
+}
+
+src_compile()
+{
+ local crypto_support="--disable-crypto"
+
+ use crypto_openssl && crypto_support="--enable-crypto=openssl"
+ use crypto_libgcrypt && crypto_support="--enable-crypto=libgcrypt"
+
+ econf \
+ --sbindir=/sbin \
+ --disable-optimizations \
+ `use_enable emacs` \
+ `use_enable pam` \
+ `use_enable static static-build` \
+ `use_enable gpm gpm-lock` \
+ ${crypto_support} \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install()
+{
+ # copy documentation manually as make install only installs info files
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+
+ # and finally install the program
+ make DESTDIR=${D} install || die "Installation failed"
+
+ # Set the settings file umask to 600, in case somebody
+ # wants to make use of the autologin feature
+ /bin/chmod 600 ${D}/etc/qingy/settings
+}
+
+pkg_postinst()
+{
+ einfo "In order to use qingy you must first edit your /etc/inittab"
+ einfo "Check the documentation at ${HOMEPAGE}"
+ einfo "for instructions on how to do that."
+ echo
+ ewarn "Also note that qingy doesn't seem to work realiably with"
+ ewarn "2.6.7 kernels due to problems with the DirectFB library."
+ ewarn "Your mileage may vary, but it could even lock up your machine!"
+ ewarn "See http://bugs.gentoo.org/show_bug.cgi?id=59340"
+ ewarn "and http://bugs.gentoo.org/show_bug.cgi?id=60402"
+ ewarn "Use either a 2.6.5 or a >=2.6.8 kernel!"
+
+ if use crypto_libgcrypt; then
+ echo
+ einfo "You will have to create a key pair using 'qingy-keygen'"
+ fi
+}