summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2006-12-21 10:45:00 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2006-12-21 10:45:00 +0000
commit1afa05601959c66493e7cbf98ae703b9d4cdfeea (patch)
tree291ccf30af8e3dd6b738c12124fe53e538d93476 /sys-apps/qingy
parentWinter cleaning, so to let arch teams know that they need to hurry up on clea... (diff)
downloadgentoo-2-1afa05601959c66493e7cbf98ae703b9d4cdfeea.tar.gz
gentoo-2-1afa05601959c66493e7cbf98ae703b9d4cdfeea.tar.bz2
gentoo-2-1afa05601959c66493e7cbf98ae703b9d4cdfeea.zip
Version bump. Wiped out previuos unstable releases.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-apps/qingy')
-rw-r--r--sys-apps/qingy/files/digest-qingy-0.9.46
-rw-r--r--sys-apps/qingy/qingy-0.9.4.ebuild132
2 files changed, 138 insertions, 0 deletions
diff --git a/sys-apps/qingy/files/digest-qingy-0.9.4 b/sys-apps/qingy/files/digest-qingy-0.9.4
new file mode 100644
index 000000000000..9991a3163801
--- /dev/null
+++ b/sys-apps/qingy/files/digest-qingy-0.9.4
@@ -0,0 +1,6 @@
+MD5 0576a0857a6d95f76b5ea8d50394bb08 qingy-0.9.4.tar.bz2 623962
+RMD160 5100c3017ed81e393d9f1ae4288fa576c5713cf8 qingy-0.9.4.tar.bz2 623962
+SHA256 b1e42fffa770562dfe65dbc9a5a30dde2083c6a012cb0fb756d94a50acf140a3 qingy-0.9.4.tar.bz2 623962
+MD5 af5f4dbf0da9a7b75365017835f6718e qingy-gentoo-theme-2.0.tar.bz2 150712
+RMD160 372add7e4cb5eba54cf3f5c2b1ae6181f0535202 qingy-gentoo-theme-2.0.tar.bz2 150712
+SHA256 e1c1ade006c58a0fb90ac2027179cb8bb7f4c74ae571542b530f90367517b64f qingy-gentoo-theme-2.0.tar.bz2 150712
diff --git a/sys-apps/qingy/qingy-0.9.4.ebuild b/sys-apps/qingy/qingy-0.9.4.ebuild
new file mode 100644
index 000000000000..9ae61e5f65f2
--- /dev/null
+++ b/sys-apps/qingy/qingy-0.9.4.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.4.ebuild,v 1.1 2006/12/21 10:45:00 s4t4n Exp $
+
+inherit eutils
+
+GENTOO_THEME_VERSION="2.0"
+
+DESCRIPTION="a DirectFB getty replacement"
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-gentoo-theme-${GENTOO_THEME_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="crypt directfb emacs gpm logrotate opensslcrypt pam static X"
+
+RDEPEND=">=sys-libs/ncurses-5.4-r6
+ opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
+ crypt? ( >=dev-libs/libgcrypt-1.2.1 )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
+ X? ( || ( (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-proto/scrnsaverproto )
+ virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ >=sys-apps/sed-4.1.4-r1"
+
+src_unpack()
+{
+ if use crypt && use opensslcrypt; then
+ echo
+ eerror "You can have openssl or libgcrypt as a crypto library, not both."
+ eerror "Please check your USE flags..."
+ echo
+ die "USE flags check failed"
+ fi
+
+ if use directfb; then
+
+ #Issues with this version have been work-arounded :-)
+ #if has_version "=dev-libs/DirectFB-0.9.25.1"; then
+ # echo
+ # ewarn "You are running DirectFB version 0.9.25.1:"
+ # ewarn "I advise against that as this version introduces"
+ # ewarn "instability, expecially when closing DirectFB mode!"
+ # ewarn "Please consider downgrading DirectFB to version 0.9.24..."
+ # echo
+ # epause
+ #fi
+
+ if ! built_with_use -a dev-libs/DirectFB fbcon jpeg png truetype; then
+ echo
+ eerror "qingy expects DirectFB to provide certain capabilities."
+ eerror "It depends on the theme you use, but at least the following USE flags"
+ eerror "should be enabled in DirectFB: fbcon jpeg png truetype."
+ eerror "You must rebuild DirectFB those USE flags enabled!"
+ echo
+ die "USE flags check failed"
+ fi
+
+ fi
+
+ unpack ${A}
+}
+
+src_compile()
+{
+ local crypto_support="--disable-crypto"
+
+ use opensslcrypt && crypto_support="--enable-crypto=openssl"
+ use crypt && crypto_support="--enable-crypto=libgcrypt"
+
+ econf \
+ --sbindir=/sbin \
+ --disable-optimizations \
+ `use_enable emacs` \
+ `use_enable pam` \
+ `use_enable static static-build` \
+ `use_enable gpm gpm-lock` \
+ `use_enable X x-support` \
+ `use_enable directfb DirectFB-support` \
+ ${crypto_support} \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install()
+{
+ # Copy documentation manually as make install only installs info files
+ # INSTALL is left because it contains also configuration informations
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+
+ # Install the program
+ make DESTDIR=${D} install || die "Installation failed"
+
+ # Set the settings file umask to 600, in case somebody
+ # wants to make use of the autologin feature
+ /bin/chmod 600 ${D}/etc/qingy/settings
+
+ # Install Gentoo theme
+ dodir /usr/share/${PN}/themes/gentoo
+ cp ${WORKDIR}/gentoo/* ${D}/usr/share/${PN}/themes/gentoo \
+ || die "Gentoo theme installation failed"
+
+ # Alter config file so that it uses our theme
+ sed -i 's/theme = "default"/theme = "gentoo"/' ${D}/etc/${PN}/settings
+
+ # Install log rotation policy if user wants it
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins ${FILESDIR}/${PN}-logrotate ${PN} || die "Log rotation policy installation failed"
+ fi
+}
+
+pkg_postinst()
+{
+ einfo "In order to use qingy you must first edit your /etc/inittab"
+ einfo "Check the documentation at ${HOMEPAGE}"
+ einfo "for instructions on how to do that."
+
+ if use crypt; then
+ echo
+ einfo "You will have to create a key pair using 'qingy-keygen'"
+ fi
+}