summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 02:52:22 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 02:52:22 +0000
commitff65c2dd8cb09a58fec42ca88f6cb743d355e562 (patch)
treefb7fe8282a22814e18b94f99265354e7d5eb9813 /sys-apps/psmisc
parentlintool fixes for #9258 (diff)
downloadgentoo-2-ff65c2dd8cb09a58fec42ca88f6cb743d355e562.tar.gz
gentoo-2-ff65c2dd8cb09a58fec42ca88f6cb743d355e562.tar.bz2
gentoo-2-ff65c2dd8cb09a58fec42ca88f6cb743d355e562.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/psmisc')
-rw-r--r--sys-apps/psmisc/psmisc-19-r2.ebuild33
1 files changed, 14 insertions, 19 deletions
diff --git a/sys-apps/psmisc/psmisc-19-r2.ebuild b/sys-apps/psmisc/psmisc-19-r2.ebuild
index e74dc4ba33a7..a196b2957a5d 100644
--- a/sys-apps/psmisc/psmisc-19-r2.ebuild
+++ b/sys-apps/psmisc/psmisc-19-r2.ebuild
@@ -1,40 +1,35 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/psmisc-19-r2.ebuild,v 1.6 2002/10/04 06:29:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/psmisc-19-r2.ebuild,v 1.7 2002/10/19 02:52:22 vapier Exp $
-#from Debian ;)
-
-A=${P}.tar.gz
S=${WORKDIR}/psmisc
DESCRIPTION="Handy process-related utilities from Debian"
-SRC_URI="ftp://lrcftp.epfl.ch/pub/linux/local/psmisc/"${A}
+SRC_URI="ftp://lrcftp.epfl.ch/pub/linux/local/psmisc/${P}.tar.gz"
DEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"
HOMEPAGE="http://psmisc.sourceforge.net/"
KEYWORDS="x86"
SLOT="0"
LICENSE="GPL-2"
+
src_unpack() {
- unpack ${A}
- cd ${S}
- cp Makefile Makefile.orig
- sed -e "s/-ltermcap/-lncurses/g" -e "s/-O/${CFLAGS}/" -e "s:-Wpointer-arith::" Makefile.orig > Makefile
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s/-ltermcap/-lncurses/g" -e "s/-O/${CFLAGS}/" -e "s:-Wpointer-arith::" Makefile.orig > Makefile
}
src_compile() {
- try pmake
+ pmake || die
}
src_install() {
+ dobin killall pstree
+ dosym killall /usr/bin/pidof
- dobin killall pstree
- dosym killall /usr/bin/pidof
-
- into /
- dobin fuser
+ into /
+ dobin fuser
- doman *.1
+ doman *.1
- dodoc CHANGES COPYING README VERSION psmisc-19.lsm
+ dodoc CHANGES COPYING README VERSION psmisc-19.lsm
}
-
-