summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-21 20:52:24 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-21 20:52:24 +0000
commite15b90094abe6cea3bf0db2c7b87ac03f0888b05 (patch)
tree1773cd6cbb62f945e621d11c7033cce1f6a08e45 /sys-apps/pciutils
parentStable on ppc64; bug #137344 (diff)
downloadgentoo-2-e15b90094abe6cea3bf0db2c7b87ac03f0888b05.tar.gz
gentoo-2-e15b90094abe6cea3bf0db2c7b87ac03f0888b05.tar.bz2
gentoo-2-e15b90094abe6cea3bf0db2c7b87ac03f0888b05.zip
ugh, just fix the patch, dont patch it
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/files/pcimodules-pciutils-2.1.11.diff3
-rw-r--r--sys-apps/pciutils/files/pcimodules-pciutils-2.2.0.patch3
-rw-r--r--sys-apps/pciutils/pciutils-2.1.11-r5.ebuild5
-rw-r--r--sys-apps/pciutils/pciutils-2.2.0-r1.ebuild3
-rw-r--r--sys-apps/pciutils/pciutils-2.2.3.ebuild3
5 files changed, 6 insertions, 11 deletions
diff --git a/sys-apps/pciutils/files/pcimodules-pciutils-2.1.11.diff b/sys-apps/pciutils/files/pcimodules-pciutils-2.1.11.diff
index a351a2c66bd1..e3023b8a97bf 100644
--- a/sys-apps/pciutils/files/pcimodules-pciutils-2.1.11.diff
+++ b/sys-apps/pciutils/files/pcimodules-pciutils-2.1.11.diff
@@ -59,7 +59,7 @@
/* For cardbus bridges, we need to fetch 64 bytes more to get the full standard header... */
--- ./pcimodules.c.orig 2003-02-20 23:22:36.000000000 -0800
+++ ./pcimodules.c 2003-02-20 23:22:36.000000000 -0800
-@@ -0,0 +1,183 @@
+@@ -0,0 +1,182 @@
+/*
+ * pcimodules: Load all kernel modules for PCI device currently
+ * plugged into any PCI slot.
@@ -78,7 +78,6 @@
+
+#include <stdlib.h>
+#include <stdio.h>
-+#include <malloc.h>
+#include <string.h>
+#include <unistd.h>
+#include <sys/utsname.h>
diff --git a/sys-apps/pciutils/files/pcimodules-pciutils-2.2.0.patch b/sys-apps/pciutils/files/pcimodules-pciutils-2.2.0.patch
index 584bfde6e14b..3b778cdeb51f 100644
--- a/sys-apps/pciutils/files/pcimodules-pciutils-2.2.0.patch
+++ b/sys-apps/pciutils/files/pcimodules-pciutils-2.2.0.patch
@@ -58,7 +58,7 @@
cp ~/tree/pciids/pci.ids pci.ids
--- pciutils-2.2.0/pcimodules.c
+++ pciutils-dsd/pcimodules.c
-@@ -0,0 +1,183 @@
+@@ -0,0 +1,182 @@
+/*
+ * pcimodules: Load all kernel modules for PCI device currently
+ * plugged into any PCI slot.
@@ -77,7 +77,6 @@
+
+#include <stdlib.h>
+#include <stdio.h>
-+#include <malloc.h>
+#include <string.h>
+#include <unistd.h>
+#include <sys/utsname.h>
diff --git a/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild b/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
index 5e2fb1840885..740456bfbc46 100644
--- a/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
+++ b/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild,v 1.11 2005/11/11 19:46:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild,v 1.12 2006/06/21 20:52:24 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -26,7 +26,6 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-gentoo-paths.patch
epatch "${FILESDIR}"/${PV}-scan.patch #from fedora
epatch "${FILESDIR}"/${P}-bsd.patch #103241
- epatch "${FILESDIR}"/${P}-malloc.patch
# Unconditionally use -fPIC for libs (#55238)
# Make sure we respect $AR / $RANLIB / $CFLAGS
diff --git a/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild b/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
index 0e2dd5526421..38e7277efc7b 100644
--- a/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
+++ b/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.14 2006/04/18 17:05:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.15 2006/06/21 20:52:24 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -23,7 +23,6 @@ src_unpack() {
epatch "${FILESDIR}"/pcimodules-${P}.patch
epatch "${FILESDIR}"/${P}-shared-lib.patch
- epatch "${FILESDIR}"/${PN}-2.1.11-malloc.patch
# Set Gentoo paths
# and do not strip (breaks cross-compile), portage handles stripping
diff --git a/sys-apps/pciutils/pciutils-2.2.3.ebuild b/sys-apps/pciutils/pciutils-2.2.3.ebuild
index 188c58d604be..365c420703df 100644
--- a/sys-apps/pciutils/pciutils-2.2.3.ebuild
+++ b/sys-apps/pciutils/pciutils-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.3.ebuild,v 1.1 2006/06/08 10:30:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.3.ebuild,v 1.2 2006/06/21 20:52:24 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -23,7 +23,6 @@ src_unpack() {
epatch "${FILESDIR}"/pcimodules-${PN}-2.2.0.patch
epatch "${FILESDIR}"/${PN}-2.2.0-shared-lib.patch
- epatch "${FILESDIR}"/${PN}-2.1.11-malloc.patch
# Set Gentoo paths
# and do not strip (breaks cross-compile), portage handles stripping