summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-19 15:22:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-19 15:22:29 +0000
commit8e0bbd0491d4a1e5587144e4bf52029b40dd3068 (patch)
treea77165eef4f7865eb63465ca3a769a3b2016e7f9 /sys-apps/pciutils
parentMigrate to python-r1. (diff)
downloadgentoo-2-8e0bbd0491d4a1e5587144e4bf52029b40dd3068.tar.gz
gentoo-2-8e0bbd0491d4a1e5587144e4bf52029b40dd3068.tar.bz2
gentoo-2-8e0bbd0491d4a1e5587144e4bf52029b40dd3068.zip
Version bump. Use libkmod instead of "modules.pcimap" which is no longer generated using the depmod from sys-apps/kmod like it was with sys-apps/module-init-tools wrt #462982 by Mike Frysinger.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog10
-rw-r--r--sys-apps/pciutils/metadata.xml1
-rw-r--r--sys-apps/pciutils/pciutils-3.2.0.ebuild84
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index cdcb8e04721c..1aca36fcc858 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.214 2013/02/22 17:31:31 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.215 2013/04/19 15:22:29 ssuominen Exp $
+
+*pciutils-3.2.0 (19 Apr 2013)
+
+ 19 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> +pciutils-3.2.0.ebuild,
+ metadata.xml:
+ Version bump. Use libkmod instead of "modules.pcimap" which is no longer
+ generated using the depmod from sys-apps/kmod like it was with
+ sys-apps/module-init-tools wrt #462982 by Mike Frysinger.
22 Feb 2013; Zac Medico <zmedico@gentoo.org> pciutils-3.1.10.ebuild:
Add ~arm-linux keyword.
diff --git a/sys-apps/pciutils/metadata.xml b/sys-apps/pciutils/metadata.xml
index ac8266dbf250..a1df75ba582a 100644
--- a/sys-apps/pciutils/metadata.xml
+++ b/sys-apps/pciutils/metadata.xml
@@ -4,6 +4,7 @@
<herd>base-system</herd>
<use>
<flag name='compress-db'>Compress pci.ids database by default</flag>
+ <flag name='kmod'>Enable <pkg>sys-apps/kmod</pkg> support for the -k switch in lspci command</flag>
<flag name='network-cron'>Monthly cronjob the update-pciids script</flag>
<flag name='zlib'>Support compressed pci.ids database</flag>
</use>
diff --git a/sys-apps/pciutils/pciutils-3.2.0.ebuild b/sys-apps/pciutils/pciutils-3.2.0.ebuild
new file mode 100644
index 000000000000..bbd7e8d3f1a5
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-3.2.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.2.0.ebuild,v 1.1 2013/04/19 15:22:29 ssuominen Exp $
+
+EAPI="5"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://mj.ucw.cz/sw/pciutils/ http://git.kernel.org/?p=utils/pciutils/pciutils.git"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+kmod static-libs zlib"
+
+# Have the sub-libs in RDEPEND with [static-libs] since, logically,
+# our libssl.a depends on libz.a/etc... at runtime.
+LIB_DEPEND="zlib? ( sys-libs/zlib[static-libs(+)] )"
+DEPEND="kmod? ( sys-apps/kmod )
+ static-libs? ( ${LIB_DEPEND} )
+ !static-libs? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+RDEPEND="${DEPEND}
+ sys-apps/hwids"
+DEPEND="${DEPEND}
+ kmod? ( virtual/pkgconfig )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.9-static-pc.patch
+
+ if use static-libs ; then
+ cp -pPR "${S}" "${S}.static" || die
+ fi
+}
+
+pemake() {
+ emake \
+ HOST="${CHOST}" \
+ CROSS_COMPILE="${CHOST}-" \
+ CC="$(tc-getCC)" \
+ DNS="yes" \
+ IDSDIR='$(SHAREDIR)/misc' \
+ MANDIR='$(SHAREDIR)/man' \
+ PREFIX="${EPREFIX}/usr" \
+ SHARED="yes" \
+ STRIP="" \
+ ZLIB=$(usex zlib) \
+ PCI_COMPRESSED_IDS=0 \
+ PCI_IDS=pci.ids \
+ LIBDIR="\${PREFIX}/$(get_libdir)" \
+ LIBKMOD="$(usex kmod)" \
+ "$@"
+}
+
+src_compile() {
+ pemake OPT="${CFLAGS}" all
+ if use static-libs ; then
+ pemake \
+ -C "${S}.static" \
+ OPT="${CFLAGS}" \
+ SHARED="no" \
+ lib/libpci.a
+ fi
+}
+
+src_install() {
+ pemake DESTDIR="${D}" install install-lib
+ use static-libs && dolib.a "${S}.static/lib/libpci.a"
+ dodoc ChangeLog README TODO
+
+ rm "${ED}"/usr/sbin/update-pciids "${ED}"/usr/share/misc/pci.ids \
+ "${ED}"/usr/share/man/man8/update-pciids.8*
+
+ newinitd "${FILESDIR}"/init.d-pciparm pciparm
+ newconfd "${FILESDIR}"/conf.d-pciparm pciparm
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 3.2.0 ]]; then
+ elog "The 'network-cron' USE flag is gone; if you want a more up-to-date"
+ elog "pci.ids file, you should use sys-apps/hwids-99999999 (live ebuild)."
+ fi
+}