summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2012-07-02 06:03:57 +0000
committerNathan Phillip Brink <binki@gentoo.org>2012-07-02 06:03:57 +0000
commita2dbeec2acf349e115f40f96748b9fdf01efdb8e (patch)
tree2b771bfafa5f7ea3e40e5496e430f764c56abf27 /sys-apps/pacman
parentRemove old version. (diff)
downloadgentoo-2-a2dbeec2acf349e115f40f96748b9fdf01efdb8e.tar.gz
gentoo-2-a2dbeec2acf349e115f40f96748b9fdf01efdb8e.tar.bz2
gentoo-2-a2dbeec2acf349e115f40f96748b9fdf01efdb8e.zip
Add pacman-4.0.3, fixing bug #421313.
(Portage version: 2.2.0_alpha114-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pacman')
-rw-r--r--sys-apps/pacman/ChangeLog8
-rw-r--r--sys-apps/pacman/pacman-4.0.3.ebuild83
2 files changed, 89 insertions, 2 deletions
diff --git a/sys-apps/pacman/ChangeLog b/sys-apps/pacman/ChangeLog
index 9d4c6bd2c57a..6637a0875947 100644
--- a/sys-apps/pacman/ChangeLog
+++ b/sys-apps/pacman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pacman
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/ChangeLog,v 1.11 2012/06/16 05:28:26 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/ChangeLog,v 1.12 2012/07/02 06:03:57 binki Exp $
+
+*pacman-4.0.3 (02 Jul 2012)
+
+ 02 Jul 2012; Nathan Phillip Brink <binki@gentoo.org> +pacman-4.0.3.ebuild:
+ Add pacman-4.0.3, fixing bug #421313.
16 Jun 2012; Nathan Phillip Brink <binki@gentoo.org> pacman-4.0.1.ebuild:
Fix inconsistency between m4/gettext.m4 and Makefile.in.in caused by
@@ -57,4 +62,3 @@
Initial commit of pacman package manager. Moved from sunrise overlay.
Thanks to Nathan Phillip Brink (ohnobinki) <ohnobinki@ohnopublishing.net>.
Fixes bug #299275
-
diff --git a/sys-apps/pacman/pacman-4.0.3.ebuild b/sys-apps/pacman/pacman-4.0.3.ebuild
new file mode 100644
index 000000000000..a402c4b33946
--- /dev/null
+++ b/sys-apps/pacman/pacman-4.0.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pacman/pacman-4.0.3.ebuild,v 1.1 2012/07/02 06:03:57 binki Exp $
+
+EAPI=4
+
+inherit autotools autotools-utils bash-completion-r1 eutils
+
+DESCRIPTION="Archlinux's binary package manager"
+HOMEPAGE="http://archlinux.org/pacman/"
+SRC_URI="ftp://ftp.archlinux.org/other/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl debug doc gpg test"
+
+COMMON_DEPEND="app-arch/libarchive
+ dev-libs/openssl
+ virtual/libiconv
+ virtual/libintl
+ sys-devel/gettext
+ curl? ( net-misc/curl )
+ gpg? ( app-crypt/gpgme )"
+RDEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils"
+# autoconf macros from gpgme requied unconditionally
+DEPEND="${COMMON_DEPEND}
+ app-crypt/gpgme
+ doc? ( app-doc/doxygen
+ app-text/asciidoc )
+ test? ( dev-lang/python )"
+
+RESTRICT="test"
+
+src_prepare() {
+ # Adds AM_GPGME_PATH call which requires app-crypt/gpgme to be
+ # DEPENDed on unconditionally:
+ epatch "${FILESDIR}"/${PN}-4.0.0-gpgme.patch
+
+ # Remove a line that adds -Werror in ./configure when --enable-debug
+ # is passed:
+ sed -i -e '/-Werror/d' configure.ac || die "-Werror"
+
+ # autopoint is unwilling to replace m4/gettext.m4 with the correct
+ # version even though it'll gladly replace */po/Makefile.in.in,
+ # creating an inconsistency between gettext m4 macros and
+ # Makefile.in.in. Also, AM_MKINSTALLDIRS apparently doesn't exist
+ # anymore, so we need newer gettext macros. #420469
+ rm m4/gettext.m4 || die
+ sed -i -e '/AM_GNU_GETTEXT_VERSION/s/0\.13\.1/0.18.1/' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --disable-git-version
+ --with-openssl
+ # Help protect user from shooting his/her Gentoo installation in
+ # its foot.
+ --with-root-dir="${EPREFIX}"/var/chroot/archlinux
+ $(use_enable debug)
+ $(use_enable doc)
+ $(use_enable doc doxygen)
+ $(use_with curl libcurl)
+ $(use_with gpg gpgme)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodir /etc/pacman.d
+ newbashcomp "${AUTOTOOLS_BUILD_DIR}"/contrib/bash_completion pacman
+}
+
+pkg_postinst() {
+ einfo "Please see http://ohnopub.net/~ohnobinki/gentoo/arch/ for information"
+ einfo "about setting up an archlinux chroot."
+}