summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-06 21:11:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-06 21:11:51 +0000
commit4bcdd27d63305bb579e7e58db60f7425d4d77a7b (patch)
treebf51c751d026efb702d36522d2a57931a32733ba /sys-apps/module-init-tools/files
parentSecurity fix from upstream, patch from https://bugzilla.redhat.com/bugzilla/a... (diff)
downloadgentoo-2-4bcdd27d63305bb579e7e58db60f7425d4d77a7b.tar.gz
gentoo-2-4bcdd27d63305bb579e7e58db60f7425d4d77a7b.tar.bz2
gentoo-2-4bcdd27d63305bb579e7e58db60f7425d4d77a7b.zip
Generate .depend files with CPPFLAGS rather than CFLAGS #154281.
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'sys-apps/module-init-tools/files')
-rw-r--r--sys-apps/module-init-tools/files/modutils-2.4.27-build.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/module-init-tools/files/modutils-2.4.27-build.patch b/sys-apps/module-init-tools/files/modutils-2.4.27-build.patch
new file mode 100644
index 000000000000..00cc103257f7
--- /dev/null
+++ b/sys-apps/module-init-tools/files/modutils-2.4.27-build.patch
@@ -0,0 +1,35 @@
+http://bugs.gentoo.org/154281
+
+--- util/Makefile.in
++++ util/Makefile.in
+@@ -42,7 +42,7 @@
+ install-bin: all
+
+ dep depend .depend: $(OBJS:.o=.c)
+- $(CC) -M $(CFLAGS) $(DEFS) $^ > .depend
++ $(CC) -M $(CPPFLAGS) $(DEFS) $^ > .depend
+
+ ifeq (.depend,$(wildcard .depend))
+ include .depend
+--- obj/Makefile.in
++++ obj/Makefile.in
+@@ -78,7 +78,7 @@
+ install-bin: all
+
+ dep depend .depend: $(LIBOBJ_SRCS)
+- $(CC) -M $(CFLAGS) $(DEFSNOARCH) $(DEFS) $^ > .depend
++ $(CC) -M $(CPPFLAGS) $(DEFSNOARCH) $(DEFS) $^ > .depend
+
+ ifeq (.depend,$(wildcard .depend))
+ include .depend
+--- insmod/Makefile.in.orig 2006-11-06 16:10:44.000000000 -0500
++++ insmod/Makefile.in 2006-11-06 16:10:53.000000000 -0500
+@@ -146,7 +146,7 @@
+ rm -f Makefile
+
+ dep depend .depend: $(addsuffix .c, $(PROGS))
+- $(CC) -M $(CFLAGS) $(DEFSNOARCH) $(DEFS) $^ > .depend
++ $(CC) -M $(CPPFLAGS) $(DEFSNOARCH) $(DEFS) $^ > .depend
+
+ ifeq (.depend,$(wildcard .depend))
+ include .depend