summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-05 05:30:30 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-05 05:30:30 +0000
commit22a5f21f35fed29fb5a9534f88f5bfd8d1342ead (patch)
tree7e47b23dc1451c0c9c766381c771ae17dda2f6ad /sys-apps/microcode-ctl
parentold (diff)
downloadgentoo-2-22a5f21f35fed29fb5a9534f88f5bfd8d1342ead.tar.gz
gentoo-2-22a5f21f35fed29fb5a9534f88f5bfd8d1342ead.tar.bz2
gentoo-2-22a5f21f35fed29fb5a9534f88f5bfd8d1342ead.zip
Version bump #176600 by Nuno Lopes.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog8
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.173
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.17.ebuild43
3 files changed, 53 insertions, 1 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index 6ddf71e83722..5e135fffef43 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-ctl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.23 2007/02/10 03:39:44 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.24 2007/05/05 05:30:30 vapier Exp $
+
+*microcode-ctl-1.17 (05 May 2007)
+
+ 05 May 2007; Mike Frysinger <vapier@gentoo.org>
+ +microcode-ctl-1.17.ebuild:
+ Version bump #176600 by Nuno Lopes.
10 Feb 2007; Steve Dibb <beandog@gentoo.org> microcode-ctl-1.15.ebuild:
amd64 stable, bug 165354
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.17 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.17
new file mode 100644
index 000000000000..baecaab95ce0
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.17
@@ -0,0 +1,3 @@
+MD5 98a7f06acef8459c8ef2a1b0fb86a99e microcode_ctl-1.17.tar.gz 326921
+RMD160 d5dba99ed89365fef51f9493a10fbb02bd1fb94a microcode_ctl-1.17.tar.gz 326921
+SHA256 41ef081c3a2649ca012714a3e2034d748612b1a8f007aa275f395f81cb230bb7 microcode_ctl-1.17.tar.gz 326921
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.17.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.17.ebuild
new file mode 100644
index 000000000000..4b0ca2c18d0f
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.17.ebuild,v 1.1 2007/05/05 05:30:30 vapier Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "compile problem"
+}
+
+src_install() {
+ dosbin microcode_ctl || die "dosbin"
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ insinto /etc
+ newins intel-ia32microcode-*.txt microcode.dat
+
+ newinitd "${FILESDIR}"/microcode_ctl.rc microcode_ctl
+ newconfd "${FILESDIR}"/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must include microcode update support."
+ echo
+ einfo "Microcode updates will be lost at every reboot."
+ einfo "You can use the init.d script to update at boot time."
+}