summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-27 16:15:47 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-27 16:15:47 +0000
commitb62cf17f647ed92256652652aed44fa045131bb2 (patch)
treede12e34edecee5827fbfaaa449d26ee2c898a7e3 /sys-apps/man
parentsecurity fix, bug 159145. (diff)
downloadgentoo-2-b62cf17f647ed92256652652aed44fa045131bb2.tar.gz
gentoo-2-b62cf17f647ed92256652652aed44fa045131bb2.tar.bz2
gentoo-2-b62cf17f647ed92256652652aed44fa045131bb2.zip
Move makewhatis to /etc/cron.daily.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog5
-rw-r--r--sys-apps/man/man-1.6e.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 895717e6cb97..1b4ef0bce0c7 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.104 2006/11/29 05:18:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.105 2006/12/27 16:15:47 vapier Exp $
+
+ 27 Dec 2006; Mike Frysinger <vapier@gentoo.org> man-1.6e.ebuild:
+ Move makewhatis to /etc/cron.daily.
*man-1.6e (29 Nov 2006)
diff --git a/sys-apps/man/man-1.6e.ebuild b/sys-apps/man/man-1.6e.ebuild
index 8b4cc348a182..3fc9af54a9bb 100644
--- a/sys-apps/man/man-1.6e.ebuild
+++ b/sys-apps/man/man-1.6e.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6e.ebuild,v 1.1 2006/11/29 05:18:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6e.ebuild,v 1.2 2006/12/27 16:15:47 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -80,12 +80,13 @@ src_compile() {
}
src_install() {
- make PREFIX="${D}" install || die "make install failed"
+ emake PREFIX="${D}" install || die "make install failed"
dosym man /usr/bin/manpath
dodoc LSM README* TODO
- exeinto /etc/cron.weekly
+ # makewhatis only adds man-pages from the last 24hrs
+ exeinto /etc/cron.daily
newexe "${FILESDIR}"/makewhatis.cron makewhatis
keepdir /var/cache/man
@@ -105,7 +106,13 @@ pkg_postinst() {
echo
- local files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ local f files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ for f in ${files} ; do
+ [[ ${f} == */etc/cron.daily/makewhatis ]] && continue
+ [[ $(md5sum "${f}") == "8b2016cc778ed4e2570b912c0f420266 "* ]] \
+ && rm -f "${f}"
+ done
+ files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
if [[ ${files/$'\n'} != ${files} ]] ; then
ewarn "You have multiple makewhatis cron files installed."
ewarn "You might want to delete all but one of these:"