summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-03 07:49:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-03 07:49:01 +0000
commit5d480c2b3f9e86c69644c1848ad8fcfd211d6ef7 (patch)
tree3f26ab5a7c64cc9b996da74fcc2bf7e536eba346 /sys-apps/man
parentbetter HOMEPAGE (Manifest recommit) (diff)
downloadgentoo-2-5d480c2b3f9e86c69644c1848ad8fcfd211d6ef7.tar.gz
gentoo-2-5d480c2b3f9e86c69644c1848ad8fcfd211d6ef7.tar.bz2
gentoo-2-5d480c2b3f9e86c69644c1848ad8fcfd211d6ef7.zip
clean up
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/files/digest-man-1.5l-r61
-rw-r--r--sys-apps/man/files/digest-man-1.5m1
-rw-r--r--sys-apps/man/man-1.5l-r6.ebuild114
-rw-r--r--sys-apps/man/man-1.5m-r1.ebuild4
-rw-r--r--sys-apps/man/man-1.5m.ebuild119
5 files changed, 2 insertions, 237 deletions
diff --git a/sys-apps/man/files/digest-man-1.5l-r6 b/sys-apps/man/files/digest-man-1.5l-r6
deleted file mode 100644
index 1d4a35da11da..000000000000
--- a/sys-apps/man/files/digest-man-1.5l-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 07fa5ab41c39afcd59cdef5139ef563b man-1.5l.tar.gz 218249
diff --git a/sys-apps/man/files/digest-man-1.5m b/sys-apps/man/files/digest-man-1.5m
deleted file mode 100644
index 40276c035044..000000000000
--- a/sys-apps/man/files/digest-man-1.5m
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d27867e59d3bbb971b00058f20ef8ea4 man-1.5m2.tar.gz 228145
diff --git a/sys-apps/man/man-1.5l-r6.ebuild b/sys-apps/man/man-1.5l-r6.ebuild
deleted file mode 100644
index 8256e40caae9..000000000000
--- a/sys-apps/man/man-1.5l-r6.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5l-r6.ebuild,v 1.14 2004/06/30 02:52:00 vapier Exp $
-
-inherit eutils
-
-NV="${PV}"
-S="${WORKDIR}/${PN}-${NV}"
-DESCRIPTION="Standard commands to read man pages"
-HOMEPAGE="http://freshmeat.net/projects/man/"
-SRC_URI="mirror://kernel/linux/utils/man/man-${NV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ppc64"
-IUSE="nls"
-
-DEPEND="virtual/libc
- >=sys-apps/sed-4
- nls? ( sys-devel/gettext )"
-RDEPEND="sys-apps/cronbase
- >=sys-apps/groff-1.18"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S} && \
- sed -i \
- -e 's:/usr/lib/locale:$(prefix)/usr/lib/locale:g' \
- -e 's!/usr/bin:/usr/ucb:!/usr/bin:!' \
- configure || die "configure sed failed"
-
- sed -i -e 's:cc -o:$(CC) -o:' gencat/Makefile \
- || die "gencat/Makefile sed failed"
-
- # security fix
- epatch ${FILESDIR}/${P}-security.patch
-
- # Fix search order in man.conf so that system installed manpages
- # will be found first ...
- epatch ${FILESDIR}/${P}-search-order.patch
-
- # For groff-1.18 or later we need to call nroff with '-c'
- epatch ${FILESDIR}/${P}-groff-1.18.patch
-
- # Fix wierd failing in rare cases
- epatch ${FILESDIR}/${P}-wrong-quotes-v2.patch
-
- # Fix a crash when calling man with: man -k "foo bar" (bug #9761).
- # <azarah@gentoo.org> (26 Dec 2002).
- epatch ${FILESDIR}/${P}-util_c-segfault.patch
-
- # Various fixes from Redhat
- epatch ${FILESDIR}/${P}-redhat-patches.patch
-
- # Do not print the 'man: No such file or directory' error if
- # 'man -d' was called and the NLS catalogue was not found, as
- # it confuses people, and be more informative ... (bug #6360)
- # <azarah@gentoo.org> (26 Dec 2002).
- epatch ${FILESDIR}/${P}-locale-debug-info.patch
-
- # Line length overidden by noff macros, thanks to
- # <grant.mcdorman@sympatico.ca> for the patch, (bug #21018).
- # -taviso@gentoo.org
- epatch ${FILESDIR}/${P}-LL-linelength.patch
-}
-
-src_compile() {
- local myconf=
-
- use nls && myconf="+lang all" || myconf="+lang none"
-
- ./configure -confdir=/etc \
- +sgid +fhs \
- ${myconf} || die "configure failed"
-
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- dodir /usr/{bin,sbin}
- cd ${S}
- make PREFIX=${D} install || die "make install failed"
-
- insinto /etc
- doins src/man.conf
-
- dodoc COPYING LSM README* TODO
-
- if use nls ; then
- cd ${S}/msgs
- ./inst.sh ?? ${D}/usr/share/locale/%L/%N
- fi
-
- chown root:man ${D}/usr/bin/man
- chmod 2555 ${D}/usr/bin/man
-
- # Needed for makewhatis
- keepdir /var/cache/man
-
- exeinto /etc/cron.daily
- doexe ${FILESDIR}/makewhatis.cron
-
- for x in $(awk '
- /^MANSECT/ {
- split($2, sects, ":")
- for (x in sects)
- print "cat" sects[x]
- }' ${D}/etc/man.conf)
- do
- keepdir /var/cache/man/${x}
- done
-}
-
diff --git a/sys-apps/man/man-1.5m-r1.ebuild b/sys-apps/man/man-1.5m-r1.ebuild
index ac29f14d0816..8fa094722dde 100644
--- a/sys-apps/man/man-1.5m-r1.ebuild
+++ b/sys-apps/man/man-1.5m-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r1.ebuild,v 1.16 2004/09/25 06:10:02 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r1.ebuild,v 1.17 2004/10/03 07:49:01 vapier Exp $
inherit eutils flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://kernel/linux/utils/man/man-${NV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc alpha ~arm hppa amd64 ~ia64 s390 mips"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE="nls"
DEPEND="virtual/libc
diff --git a/sys-apps/man/man-1.5m.ebuild b/sys-apps/man/man-1.5m.ebuild
deleted file mode 100644
index e2d4197712a0..000000000000
--- a/sys-apps/man/man-1.5m.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m.ebuild,v 1.15 2004/09/03 21:03:24 pvdabeel Exp $
-
-inherit eutils
-
-NV="1.5m2"
-DESCRIPTION="Standard commands to read man pages"
-HOMEPAGE="http://freshmeat.net/projects/man/"
-SRC_URI="mirror://kernel/linux/utils/man/man-${NV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ppc ~alpha arm hppa ~amd64 ia64 s390"
-IUSE="nls"
-
-DEPEND="virtual/libc
- >=sys-apps/sed-4"
-RDEPEND="sys-apps/cronbase
- >=sys-apps/groff-1.18"
-
-S=${WORKDIR}/${PN}-${NV}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S} && \
- sed -i \
- -e 's:/usr/lib/locale:$(prefix)/usr/lib/locale:g' \
- -e 's!/usr/bin:/usr/ucb:!/usr/bin:!' \
- configure || die "configure sed failed"
-
- sed -i -e 's:cc -o:$(CC) -o:' gencat/Makefile \
- || die "gencat/Makefile sed failed"
-
- # security fix
- epatch ${FILESDIR}/${P}-security.patch
-
- # Fix search order in man.conf so that system installed manpages
- # will be found first ...
- epatch ${FILESDIR}/${P}-search-order.patch
-
- # For groff-1.18 or later we need to call nroff with '-c'
- epatch ${FILESDIR}/${P}-groff-1.18.patch
-
- # Fix wierd failing in rare cases
- epatch ${FILESDIR}/${P}-wrong-quotes-v2.patch
-
- # Fix a crash when calling man with: man -k "foo bar" (bug #9761).
- # <azarah@gentoo.org> (26 Dec 2002).
- epatch ${FILESDIR}/${P}-util_c-segfault.patch
-
- # Various fixes from Redhat
- epatch ${FILESDIR}/${P}-redhat-patches.patch
-
- # Do not print the 'man: No such file or directory' error if
- # 'man -d' was called and the NLS catalogue was not found, as
- # it confuses people, and be more informative ... (bug #6360)
- # <azarah@gentoo.org> (26 Dec 2002).
- epatch ${FILESDIR}/${P}-locale-debug-info.patch
-
- # Line length overidden by nroff macros, thanks to
- # <grant.mcdorman@sympatico.ca> for the patch, (bug #21018).
- # -taviso@gentoo.org
- epatch ${FILESDIR}/${P}-LL-linelength.patch
-
- # makewhatis traverses manpages twice, as default manpath
- # contains two directories that are symlinked together
- # (bug 23848)
- # -taviso@gentoo.org
- epatch ${FILESDIR}/${P}-defmanpath-symlinks.patch
-}
-
-src_compile() {
- local myconf=
-
- use nls && myconf="+lang all"
-
- ./configure -confdir=/etc \
- +sgid +fhs \
- ${myconf} || die "configure failed"
-
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- dodir /usr/{bin,sbin}
- cd ${S}
- make PREFIX=${D} install || die "make install failed"
-
- insinto /etc
- doins src/man.conf
-
- dodoc COPYING LSM README* TODO
-
- if use nls ; then
- cd ${S}/msgs
- ./inst.sh ?? ${D}/usr/share/locale/%L/%N
- fi
-
- # Needed for makewhatis
- keepdir /var/cache/man
- exeinto /etc/cron.weekly
- doexe ${FILESDIR}/makewhatis.cron
-
- fowners root:man /usr/bin/man
- fperms 2555 /usr/bin/man
-
- diropts -m0775 -g man
- for x in $(awk '
- /^MANSECT/ {
- split($2, sects, ":")
- for (x in sects)
- print "cat" sects[x]
- }' ${D}/etc/man.conf)
- do
- keepdir /var/cache/man/${x}
- done
-}