summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-10 06:11:15 +0000
committerJustin Lecher <jlec@gentoo.org>2014-07-10 06:11:15 +0000
commit9a0200eb2806d19195238801cb9eb74ae5009969 (patch)
treee6259585aa5837a849ec3374d22b3dd8dd1b5301 /sys-apps/kexec-tools
parentsys-kernel/aufs-sources: Bump to latest aufs3, genpatches and linux release (diff)
downloadgentoo-2-9a0200eb2806d19195238801cb9eb74ae5009969.tar.gz
gentoo-2-9a0200eb2806d19195238801cb9eb74ae5009969.tar.bz2
gentoo-2-9a0200eb2806d19195238801cb9eb74ae5009969.zip
sys-apps/kexec-tools: Version Bump, #516778
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-apps/kexec-tools')
-rw-r--r--sys-apps/kexec-tools/ChangeLog9
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.7.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/sys-apps/kexec-tools/ChangeLog b/sys-apps/kexec-tools/ChangeLog
index d7af158dee56..975eab490ac5 100644
--- a/sys-apps/kexec-tools/ChangeLog
+++ b/sys-apps/kexec-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/kexec-tools
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.61 2013/12/28 20:27:31 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.62 2014/07/10 06:11:15 jlec Exp $
+
+*kexec-tools-2.0.7 (10 Jul 2014)
+
+ 10 Jul 2014; Justin Lecher <jlec@gentoo.org> +kexec-tools-2.0.7.ebuild:
+ Version Bump, #516778
28 Dec 2013; Justin Lecher <jlec@gentoo.org> kexec-tools-9999.ebuild,
files/kexec.init-9999:
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.7.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.7.ebuild
new file mode 100644
index 000000000000..e3a07e6f7842
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-2.0.7.ebuild,v 1.1 2014/07/10 06:11:15 jlec Exp $
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic linux-info systemd
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="http://kernel.org/pub/linux/utils/kernel/kexec/"
+SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="booke lzma xen zlib"
+
+REQUIRED_USE="lzma? ( zlib )"
+
+DEPEND="
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KEXEC"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
+ "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
+ )
+
+pkg_setup() {
+ # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
+ export ASFLAGS="${CCASFLAGS}"
+ # to disable the -fPIE -pie in the hardened compiler
+ if gcc-specs-pie ; then
+ filter-flags -fPIE
+ append-ldflags -nopie
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with booke)
+ $(use_with lzma)
+ $(use_with xen)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ newinitd "${FILESDIR}"/kexec.init-2.0.4-r2 kexec
+ newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
+
+ insinto /etc
+ doins "${FILESDIR}"/kexec.conf
+
+ insinto /etc/kernel/postinst.d
+ doins "${FILESDIR}"/90_kexec
+
+ systemd_dounit "${FILESDIR}"/kexec.service
+}
+
+pkg_postinst() {
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "For systemd support the new config file is"
+ elog " /etc/kexec.conf"
+ elog "Please adopt it to your needs as there is no autoconfig anymore"
+ fi
+}