summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 03:31:45 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 03:31:45 +0000
commit3a4ffa01f7ea32c20a87e6bb740646108692e96d (patch)
treed2081d04c0630fc17c74b024a881e1e3e2769b41 /sys-apps/isapnptools/isapnptools-1.27.ebuild
parentVersion bump. (diff)
downloadgentoo-2-3a4ffa01f7ea32c20a87e6bb740646108692e96d.tar.gz
gentoo-2-3a4ffa01f7ea32c20a87e6bb740646108692e96d.tar.bz2
gentoo-2-3a4ffa01f7ea32c20a87e6bb740646108692e96d.zip
Version bump. Fix missing include.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/isapnptools/isapnptools-1.27.ebuild')
-rw-r--r--sys-apps/isapnptools/isapnptools-1.27.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/isapnptools/isapnptools-1.27.ebuild b/sys-apps/isapnptools/isapnptools-1.27.ebuild
new file mode 100644
index 000000000000..8d377aaae649
--- /dev/null
+++ b/sys-apps/isapnptools/isapnptools-1.27.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/isapnptools/isapnptools-1.27.ebuild,v 1.1 2011/06/15 03:31:45 jer Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Tools for configuring ISA PnP devices"
+HOMEPAGE="http://www.roestock.demon.co.uk/isapnptools/"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/hardware/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /sbin
+ mv "${D}"/usr/sbin/isapnp "${D}"/sbin/ || die "couldnt relocate isapnp"
+
+ dodoc AUTHORS ChangeLog README NEWS
+ docinto txt
+ dodoc doc/README* doc/*.txt test/*.txt
+ dodoc etc/isapnp.*
+
+ newinitd "${FILESDIR}"/isapnp.rc isapnp
+}