summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 15:19:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 15:19:28 +0000
commit5672fda85b10a43bb4c7ef9b9f06bf75373bc4b7 (patch)
tree2e550e1f2bcbf645c6ee9db8afc243d4f16d74dc /sys-apps/iproute
parentBumped at infrastructure's request (Manifest recommit) (diff)
downloadgentoo-2-5672fda85b10a43bb4c7ef9b9f06bf75373bc4b7.tar.gz
gentoo-2-5672fda85b10a43bb4c7ef9b9f06bf75373bc4b7.tar.bz2
gentoo-2-5672fda85b10a43bb4c7ef9b9f06bf75373bc4b7.zip
update to fix bugs #33831 #34294 #37432 #40230 #40510 #45274 ... GOD I LOVE THIS JOB
Diffstat (limited to 'sys-apps/iproute')
-rw-r--r--sys-apps/iproute/ChangeLog13
-rw-r--r--sys-apps/iproute/files/20010824-hfsc.patch416
-rw-r--r--sys-apps/iproute/files/20010824-local-exploit-fix.patch22
-rw-r--r--sys-apps/iproute/files/20010824-rates-1024-fix.patch36
-rw-r--r--sys-apps/iproute/files/digest-iproute-20010824-r52
-rw-r--r--sys-apps/iproute/iproute-20010824-r5.ebuild83
6 files changed, 571 insertions, 1 deletions
diff --git a/sys-apps/iproute/ChangeLog b/sys-apps/iproute/ChangeLog
index 0e00b3ab2c9e..92751146c165 100644
--- a/sys-apps/iproute/ChangeLog
+++ b/sys-apps/iproute/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-apps/iproute
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.32 2004/03/25 10:41:15 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.33 2004/04/06 15:19:21 vapier Exp $
+
+*iproute-20010824-r5 (06 Apr 2004)
+
+ 06 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump to clean up bugs and all that fun stuff.
+ #33831 by Miguel Sousa Filipe - We use /usr/include instead of /usr/src/linux.
+ #34294 by Andrea Barisani - Fix local DoS exploit.
+ #37432 by Radek Podgorny - Update the debian patch that we pull.
+ #40230 by Sebastian Werner - Use system pkt_sched.h instead of bundled.
+ #40510 by valli - Use system glibc headers instead of bundled.
+ #45274 by David Pufer - Add HFSC support.
25 Mar 2004; Joshua Kinard <kumba@gentoo.org> iproute-20010824-r4.ebuild:
Marked stable on mips.
diff --git a/sys-apps/iproute/files/20010824-hfsc.patch b/sys-apps/iproute/files/20010824-hfsc.patch
new file mode 100644
index 000000000000..c36dd069c685
--- /dev/null
+++ b/sys-apps/iproute/files/20010824-hfsc.patch
@@ -0,0 +1,416 @@
+diff -urN a/tc/Makefile b/tc/Makefile
+--- a/tc/Makefile 2000-04-16 19:42:53.000000000 +0200
++++ b/tc/Makefile 2004-01-04 23:24:39.000000000 +0100
+@@ -26,7 +26,7 @@
+
+ #TCMODULES += q_csz.o
+ #TCMODULES += q_hpfq.o
+-#TCMODULES += q_hfsc.o
++TCMODULES += q_hfsc.o
+
+ TCOBJ += $(TCMODULES)
+
+diff -urN a/tc/q_hfsc.c b/tc/q_hfsc.c
+--- a/tc/q_hfsc.c 2000-04-16 19:42:54.000000000 +0200
++++ b/tc/q_hfsc.c 2004-01-25 14:42:43.000000000 +0100
+@@ -1,12 +1,12 @@
+ /*
+- * q_hfsc.c HFSC.
++ * q_hfsc.c HFSC.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version
+ * 2 of the License, or (at your option) any later version.
+ *
+- * Authors: Alexey Kuznetsov, <kuznet@ms2.inr.ac.ru>
++ * Authors: Patrick McHardy, <kaber@trash.ner>
+ *
+ */
+
+@@ -19,36 +19,247 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <string.h>
++#include <math.h>
+
+ #include "utils.h"
+ #include "tc_util.h"
+
+-static void explain()
++static int hfsc_get_sc(int *, char ***, struct tc_service_curve *);
++
++
++static void
++explain_qdisc(void)
++{
++ fprintf(stderr,
++ "Usage: ... hfsc [ default CLASSID ]\n"
++ "\n"
++ " default: default class for unclassified packets\n"
++ );
++}
++
++static void
++explain_class(void)
+ {
+- fprintf(stderr, "Usage: ... hfsc \n");
++ fprintf(stderr,
++ "Usage: ... hfsc [ rt SC ] [ ls SC ] [ ul SC ]\n"
++ "\n"
++ "SC := [ [ m1 BPS ] [ d SEC ] m2 BPS\n"
++ "\n"
++ " m1 : slope of first segment\n"
++ " d : x-coordinate of intersection\n"
++ " m2 : slope of second segment\n"
++ "\n"
++ "Alternative format:\n"
++ "\n"
++ "SC := [ [ umax BYTE ] dmax SEC ] rate BPS\n"
++ "\n"
++ " umax : maximum unit of work\n"
++ " dmax : maximum delay\n"
++ " rate : rate\n"
++ "\n"
++ );
+ }
+
+-static void explain1(char *arg)
++static void
++explain1(char *arg)
+ {
+- fprintf(stderr, "Illegal \"%s\"\n", arg);
++ fprintf(stderr, "HFSC: Illegal \"%s\"\n", arg);
+ }
+
++static int
++hfsc_parse_opt(struct qdisc_util *qu, int argc, char **argv, struct nlmsghdr *n)
++{
++ struct tc_hfsc_qopt qopt;
++
++ memset(&qopt, 0, sizeof(qopt));
++
++ while (argc > 0) {
++ if (matches(*argv, "default") == 0) {
++ NEXT_ARG();
++ if (qopt.defcls != 0) {
++ fprintf(stderr, "HFSC: Double \"default\"\n");
++ return -1;
++ }
++ if (get_u16(&qopt.defcls, *argv, 16) < 0) {
++ explain1("default");
++ return -1;
++ }
++ } else if (matches(*argv, "help") == 0) {
++ explain_qdisc();
++ return -1;
++ } else {
++ fprintf(stderr, "HFSC: What is \"%s\" ?\n", *argv);
++ explain_qdisc();
++ return -1;
++ }
++ argc--, argv++;
++ }
+
+-#define usage() return(-1)
++ addattr_l(n, 1024, TCA_OPTIONS, &qopt, sizeof(qopt));
++ return 0;
++}
+
+-static int hfsc_parse_opt(struct qdisc_util *qu, int argc, char **argv, struct nlmsghdr *n)
++static int
++hfsc_print_opt(struct qdisc_util *qu, FILE *f, struct rtattr *opt)
+ {
+- return -1;
++ struct tc_hfsc_qopt *qopt;
++
++ if (opt == NULL)
++ return 0;
++ if (RTA_PAYLOAD(opt) < sizeof(*qopt))
++ return -1;
++ qopt = RTA_DATA(opt);
++
++ if (qopt->defcls != 0)
++ fprintf(f, "default %x ", qopt->defcls);
++
++ return 0;
+ }
+
+-static int hfsc_print_opt(struct qdisc_util *qu, FILE *f, struct rtattr *opt)
++static int
++hfsc_print_xstats(struct qdisc_util *qu, FILE *f, struct rtattr *xstats)
+ {
+- return -1;
++ struct tc_hfsc_stats *st;
++
++ if (xstats == NULL)
++ return 0;
++ if (RTA_PAYLOAD(xstats) < sizeof(*st))
++ return -1;
++ st = RTA_DATA(xstats);
++
++ fprintf(f, " period %u ", st->period);
++ if (st->work != 0)
++ fprintf(f, "work %llu bytes ", st->work);
++ if (st->rtwork != 0)
++ fprintf(f, "rtwork %llu bytes ", st->rtwork);
++ fprintf(f, "level %u ", st->level);
++ fprintf(f, "\n");
++
++ return 0;
+ }
+
+-static int hfsc_print_xstats(struct qdisc_util *qu, FILE *f, struct rtattr *xstats)
++static int
++hfsc_parse_class_opt(struct qdisc_util *qu, int argc, char **argv,
++ struct nlmsghdr *n)
+ {
+- return -1;
++ struct tc_service_curve rsc, fsc, usc;
++ int rsc_ok, fsc_ok, usc_ok;
++ struct rtattr *tail;
++
++ memset(&rsc, 0, sizeof(rsc));
++ memset(&fsc, 0, sizeof(fsc));
++ memset(&usc, 0, sizeof(usc));
++ rsc_ok = fsc_ok = usc_ok = 0;
++
++ while (argc > 0) {
++ if (matches(*argv, "rt") == 0) {
++ NEXT_ARG();
++ if (hfsc_get_sc(&argc, &argv, &rsc) < 0) {
++ explain1("rt");
++ return -1;
++ }
++ rsc_ok = 1;
++ } else if (matches(*argv, "ls") == 0) {
++ NEXT_ARG();
++ if (hfsc_get_sc(&argc, &argv, &fsc) < 0) {
++ explain1("ls");
++ return -1;
++ }
++ fsc_ok = 1;
++ } else if (matches(*argv, "ul") == 0) {
++ NEXT_ARG();
++ if (hfsc_get_sc(&argc, &argv, &usc) < 0) {
++ explain1("ul");
++ return -1;
++ }
++ usc_ok = 1;
++ } else if (matches(*argv, "help") == 0) {
++ explain_class();
++ return -1;
++ } else {
++ fprintf(stderr, "HFSC: What is \"%s\" ?\n", *argv);
++ explain_class();
++ return -1;
++ }
++ argc--, argv++;
++ }
++
++ if (!(rsc_ok || fsc_ok || usc_ok)) {
++ fprintf(stderr, "HFSC: no parameters given\n");
++ explain_class();
++ return -1;
++ }
++ if (usc_ok && !fsc_ok) {
++ fprintf(stderr, "HFSC: Upper-limit Service Curve without "
++ "Link-Share Service Curve\n");
++ explain_class();
++ return -1;
++ }
++
++ tail = (struct rtattr*)(((void*)n) + NLMSG_ALIGN(n->nlmsg_len));
++
++ addattr_l(n, 1024, TCA_OPTIONS, NULL, 0);
++ if (rsc_ok)
++ addattr_l(n, 1024, TCA_HFSC_RSC, &rsc, sizeof(rsc));
++ if (fsc_ok)
++ addattr_l(n, 1024, TCA_HFSC_FSC, &fsc, sizeof(fsc));
++ if (usc_ok)
++ addattr_l(n, 1024, TCA_HFSC_USC, &usc, sizeof(usc));
++
++ tail->rta_len = (((void*)n) + NLMSG_ALIGN(n->nlmsg_len)) - (void*)tail;
++ return 0;
++}
++
++static void
++hfsc_print_sc(FILE *f, char *name, struct tc_service_curve *sc)
++{
++ SPRINT_BUF(b1);
++
++ fprintf(f, "%s ", name);
++ fprintf(f, "m1 %s ", sprint_rate(sc->m1, b1));
++ fprintf(f, "d %s ", sprint_usecs(sc->d, b1));
++ fprintf(f, "m2 %s ", sprint_rate(sc->m2, b1));
++}
++
++static int
++hfsc_print_class_opt(struct qdisc_util *qu, FILE *f, struct rtattr *opt)
++{
++ struct rtattr *tb[TCA_HFSC_MAX+1];
++ struct tc_service_curve *rsc = NULL, *fsc = NULL, *usc = NULL;
++
++ if (opt == NULL)
++ return 0;
++
++ memset(tb, 0, sizeof(tb));
++ parse_rtattr(tb, TCA_HFSC_MAX, RTA_DATA(opt), RTA_PAYLOAD(opt));
++
++ if (tb[TCA_HFSC_RSC]) {
++ if (RTA_PAYLOAD(tb[TCA_HFSC_RSC]) < sizeof(*rsc))
++ fprintf(stderr, "HFSC: truncated realtime option\n");
++ else
++ rsc = RTA_DATA(tb[TCA_HFSC_RSC]);
++ }
++ if (tb[TCA_HFSC_FSC]) {
++ if (RTA_PAYLOAD(tb[TCA_HFSC_FSC]) < sizeof(*fsc))
++ fprintf(stderr, "HFSC: truncated linkshare option\n");
++ else
++ fsc = RTA_DATA(tb[TCA_HFSC_FSC]);
++ }
++ if (tb[TCA_HFSC_USC]) {
++ if (RTA_PAYLOAD(tb[TCA_HFSC_USC]) < sizeof(*usc))
++ fprintf(stderr, "HFSC: truncated upperlimit option\n");
++ else
++ usc = RTA_DATA(tb[TCA_HFSC_USC]);
++ }
++
++ if (rsc != NULL)
++ hfsc_print_sc(f, "rt", rsc);
++ if (fsc != NULL)
++ hfsc_print_sc(f, "ls", fsc);
++ if (usc != NULL)
++ hfsc_print_sc(f, "ul", usc);
++
++ return 0;
+ }
+
+ struct qdisc_util hfsc_util = {
+@@ -57,5 +268,126 @@
+ hfsc_parse_opt,
+ hfsc_print_opt,
+ hfsc_print_xstats,
++ hfsc_parse_class_opt,
++ hfsc_print_class_opt,
+ };
+
++static int
++hfsc_get_sc1(int *argcp, char ***argvp, struct tc_service_curve *sc)
++{
++ char **argv = *argvp;
++ int argc = *argcp;
++ unsigned int m1 = 0, d = 0, m2 = 0;
++
++ if (matches(*argv, "m1") == 0) {
++ NEXT_ARG();
++ if (get_rate(&m1, *argv) < 0) {
++ explain1("m1");
++ return -1;
++ }
++ NEXT_ARG();
++ }
++
++ if (matches(*argv, "d") == 0) {
++ NEXT_ARG();
++ if (get_usecs(&d, *argv) < 0) {
++ explain1("d");
++ return -1;
++ }
++ NEXT_ARG();
++ }
++
++ if (matches(*argv, "m2") == 0) {
++ NEXT_ARG();
++ if (get_rate(&m2, *argv) < 0) {
++ explain1("m2");
++ return -1;
++ }
++ } else
++ return -1;
++
++ sc->m1 = m1;
++ sc->d = d;
++ sc->m2 = m2;
++
++ *argvp = argv;
++ *argcp = argc;
++ return 0;
++}
++
++static int
++hfsc_get_sc2(int *argcp, char ***argvp, struct tc_service_curve *sc)
++{
++ char **argv = *argvp;
++ int argc = *argcp;
++ unsigned int umax = 0, dmax = 0, rate = 0;
++
++ if (matches(*argv, "umax") == 0) {
++ NEXT_ARG();
++ if (get_size(&umax, *argv) < 0) {
++ explain1("umax");
++ return -1;
++ }
++ NEXT_ARG();
++ }
++
++ if (matches(*argv, "dmax") == 0) {
++ NEXT_ARG();
++ if (get_usecs(&dmax, *argv) < 0) {
++ explain1("dmax");
++ return -1;
++ }
++ NEXT_ARG();
++ }
++
++ if (matches(*argv, "rate") == 0) {
++ NEXT_ARG();
++ if (get_rate(&rate, *argv) < 0) {
++ explain1("rate");
++ return -1;
++ }
++ } else
++ return -1;
++
++ if (umax != 0 && dmax == 0) {
++ fprintf(stderr, "HFSC: umax given but dmax is zero.\n");
++ return -1;
++ }
++
++ if (dmax != 0 && ceil(umax * 1000000.0 / dmax) > rate) {
++ /*
++ * concave curve, slope of first segment is umax/dmax,
++ * intersection is at dmax
++ */
++ sc->m1 = ceil(umax * 1000000.0 / dmax); /* in bps */
++ sc->d = dmax;
++ sc->m2 = rate;
++ } else {
++ /*
++ * convex curve, slope of first segment is 0, intersection
++ * is at dmax - umax / rate
++ */
++ sc->m1 = 0;
++ sc->d = ceil(dmax - umax * 1000000.0 / rate); /* in usec */
++ sc->m2 = rate;
++ }
++
++ *argvp = argv;
++ *argcp = argc;
++ return 0;
++}
++
++static int
++hfsc_get_sc(int *argcp, char ***argvp, struct tc_service_curve *sc)
++{
++ if (hfsc_get_sc1(argcp, argvp, sc) < 0 &&
++ hfsc_get_sc2(argcp, argvp, sc) < 0)
++ return -1;
++
++ if (sc->m1 == 0 && sc->m2 == 0) {
++ fprintf(stderr, "HFSC: Service Curve has two zero slopes\n");
++ return -1;
++ }
++
++ return 0;
++}
diff --git a/sys-apps/iproute/files/20010824-local-exploit-fix.patch b/sys-apps/iproute/files/20010824-local-exploit-fix.patch
new file mode 100644
index 000000000000..c66b9cbdc99c
--- /dev/null
+++ b/sys-apps/iproute/files/20010824-local-exploit-fix.patch
@@ -0,0 +1,22 @@
+--- iproute2/lib/libnetlink.c.orig 2003-08-10 15:02:10.000000000 +1000
++++ iproute2/lib/libnetlink.c 2003-10-13 19:36:41.000000000 +1000
+@@ -169,7 +169,8 @@
+ while (NLMSG_OK(h, status)) {
+ int err;
+
+- if (h->nlmsg_pid != rth->local.nl_pid ||
++ if (nladdr.nl_pid != 0 ||
++ h->nlmsg_pid != rth->local.nl_pid ||
+ h->nlmsg_seq != rth->dump) {
+ if (junk) {
+ err = junk(&nladdr, h, arg2);
+@@ -277,7 +278,8 @@
+ exit(1);
+ }
+
+- if (h->nlmsg_pid != rtnl->local.nl_pid ||
++ if (nladdr.nl_pid != peer ||
++ h->nlmsg_pid != rtnl->local.nl_pid ||
+ h->nlmsg_seq != seq) {
+ if (junk) {
+ err = junk(&nladdr, h, jarg);
diff --git a/sys-apps/iproute/files/20010824-rates-1024-fix.patch b/sys-apps/iproute/files/20010824-rates-1024-fix.patch
new file mode 100644
index 000000000000..06d6539ccbff
--- /dev/null
+++ b/sys-apps/iproute/files/20010824-rates-1024-fix.patch
@@ -0,0 +1,36 @@
+diff -urN a/tc/tc_util.c b/tc/tc_util.c
+--- a/tc/tc_util.c 2000-04-16 19:42:55.000000000 +0200
++++ b/tc/tc_util.c 2003-12-14 06:56:55.000000000 +0100
+@@ -108,13 +108,13 @@
+
+ if (*p) {
+ if (strcasecmp(p, "kbps") == 0)
+- bps *= 1024;
++ bps *= 1000;
+ else if (strcasecmp(p, "mbps") == 0)
+- bps *= 1024*1024;
++ bps *= 1000*1000;
+ else if (strcasecmp(p, "mbit") == 0)
+- bps *= 1024*1024/8;
++ bps *= 1000*1000/8;
+ else if (strcasecmp(p, "kbit") == 0)
+- bps *= 1024/8;
++ bps *= 1000/8;
+ else if (strcasecmp(p, "bps") != 0)
+ return -1;
+ } else
+@@ -158,10 +158,10 @@
+ {
+ double tmp = (double)rate*8;
+
+- if (tmp >= 1024*1023 && fabs(1024*1024*rint(tmp/(1024*1024)) - tmp) < 1024)
+- snprintf(buf, len, "%gMbit", rint(tmp/(1024*1024)));
+- else if (tmp >= 1024-16 && fabs(1024*rint(tmp/1024) - tmp) < 16)
+- snprintf(buf, len, "%gKbit", rint(tmp/1024));
++ if (tmp >= 1000*999 && fabs(1000*1000*rint(tmp/(1000*1000)) - tmp) < 1000)
++ snprintf(buf, len, "%gMbit", rint(tmp/(1000*1000)));
++ else if (tmp >= 1000-10 && fabs(1000*rint(tmp/1000) - tmp) < 10)
++ snprintf(buf, len, "%gKbit", rint(tmp/1000));
+ else
+ snprintf(buf, len, "%ubps", rate);
+ return 0;
diff --git a/sys-apps/iproute/files/digest-iproute-20010824-r5 b/sys-apps/iproute/files/digest-iproute-20010824-r5
new file mode 100644
index 000000000000..0019edbd44cc
--- /dev/null
+++ b/sys-apps/iproute/files/digest-iproute-20010824-r5
@@ -0,0 +1,2 @@
+MD5 b05a4e375d9468be3a1dd3f0e83daee8 iproute2-2.4.7-now-ss010824.tar.gz 140139
+MD5 60585e8f7d11173ca80591cc9f5fb833 iproute_20010824-13.diff.gz 91751
diff --git a/sys-apps/iproute/iproute-20010824-r5.ebuild b/sys-apps/iproute/iproute-20010824-r5.ebuild
new file mode 100644
index 000000000000..50f5608e58d2
--- /dev/null
+++ b/sys-apps/iproute/iproute-20010824-r5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824-r5.ebuild,v 1.1 2004/04/06 15:19:21 vapier Exp $
+
+inherit eutils
+
+DEBIANPATCH="${P/-/_}-13.diff.gz"
+SRCFILE="iproute2-2.4.7-now-ss${PV/20}.tar.gz"
+
+DESCRIPTION="kernel routing and traffic control utilities"
+HOMEPAGE="http://www.worldbank.ro/ip-routing/"
+SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${SRCFILE}
+ mirror://debian/pool/main/i/iproute/${DEBIANPATCH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64"
+IUSE="doc"
+
+DEPEND="virtual/os-headers
+ >=sys-apps/sed-4
+ doc? ( virtual/tetex )"
+RDEPEND="virtual/glibc"
+
+S=${WORKDIR}/iproute2
+
+src_unpack() {
+ unpack ${SRCFILE}
+ cd ${S}
+
+ # Our patch does two things for us; First, it syncs up with Debian's
+ # iproute 20010824-9 package; Secondly, it adds htb3 support. The Debian
+ # patch tweaks the iproute compile so that we use an included pkt_sched.h
+ # header rather than looking at the one in /usr/src/linux/include/linux.
+ # This allows us to always enable HTB3 without compile problems;
+ epatch ${DISTDIR}/${DEBIANPATCH}
+
+ # Enable HFSC scheduler #45274
+ epatch ${FILESDIR}/${PV}-hfsc.patch
+ epatch ${FILESDIR}/${PV}-rates-1024-fix.patch
+ rm include/linux/pkt_sched.h
+
+ # Fix local DoS exploit #34294
+ epatch ${FILESDIR}/${PV}-local-exploit-fix.patch
+
+ sed -i \
+ -e "s:-O2:${CFLAGS}:g" \
+ -e "s:-Werror::g" \
+ -e "s:-I../include-glibc::g" \
+ Makefile || die "sed Makefile failed"
+
+ # this next thing is required to enable diffserv
+ # (ATM support doesn't compile right now)
+ sed -i \
+ -e 's:DIFFSERV=n:DIFFSERV=y:g' \
+ -e 's:ATM=y:ATM=n:g' \
+ Config || die "sed Config failed"
+}
+
+src_compile() {
+ emake KERNEL_INCLUDE=/usr/include || die
+}
+
+src_install() {
+ dodoc README* RELNOTES
+
+ into /
+ cd ${S}/ip
+ dosbin ifcfg ip routef routel rtacct rtmon rtpr || die "dosbin * failed"
+ cd ${S}/tc
+ dosbin tc || die "dosbin tc failed"
+
+ #install Debian man pages
+ doman ${S}/debian/manpages/*.[1-9]
+
+ docinto examples/diffserv ; dodoc examples/diffserv/*
+ docinto examples ; dodoc examples/*
+ dodir /etc/iproute2
+ insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
+ if use doc && [ -n "`ls doc/*.ps`" ] ; then
+ docinto ps ; dodoc doc/*.ps
+ fi
+}