summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Nussbaumer <killerfox@gentoo.org>2007-01-14 17:34:57 +0000
committerRené Nussbaumer <killerfox@gentoo.org>2007-01-14 17:34:57 +0000
commit60265f127928cb1a74fe0a9484ee953cfc12dbae (patch)
tree37d3af52b24b91e399e407410a4645b23e4d2089 /sys-apps/inputd/inputd-0.0.8.ebuild
parentCleanup. (diff)
downloadgentoo-2-60265f127928cb1a74fe0a9484ee953cfc12dbae.tar.gz
gentoo-2-60265f127928cb1a74fe0a9484ee953cfc12dbae.tar.bz2
gentoo-2-60265f127928cb1a74fe0a9484ee953cfc12dbae.zip
Version bump from upstream
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-apps/inputd/inputd-0.0.8.ebuild')
-rw-r--r--sys-apps/inputd/inputd-0.0.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/inputd/inputd-0.0.8.ebuild b/sys-apps/inputd/inputd-0.0.8.ebuild
new file mode 100644
index 000000000000..b3dc5074e29d
--- /dev/null
+++ b/sys-apps/inputd/inputd-0.0.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/inputd/inputd-0.0.8.ebuild,v 1.1 2007/01/14 17:34:57 killerfox Exp $
+
+inherit eutils
+
+DESCRIPTION="inputd is a user-space daemon to emulate key presses trough other
+key combinations"
+HOMEPAGE="http://hansmi.ch/software/inputd"
+SRC_URI="http://hansmi.ch/download/inputd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~ppc64"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.8
+ >=sys-kernel/linux-headers-2.6.16"
+RDEPEND="sys-fs/udev"
+
+src_install() {
+ emake DESTDIR=${D} install || die 'installation failed.'
+
+ newinitd ${FILESDIR}/inputd.init inputd
+ dodoc README doc/FAQ NEWS
+
+ insinto /etc
+ doins doc/inputd.conf
+}
+