summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-27 07:28:25 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-27 07:28:25 +0000
commitb27bd35a6df733cbbd94fa5262fdceba6952fd63 (patch)
tree0cc0ffd0a3c8baf5049b82fd300dd2cb2460351e /sys-apps/hbaapi
parentBump, drop vulnerable version. 0.1.15 includes fixes for CVE-2011-4349 (same ... (diff)
downloadgentoo-2-b27bd35a6df733cbbd94fa5262fdceba6952fd63.tar.gz
gentoo-2-b27bd35a6df733cbbd94fa5262fdceba6952fd63.tar.bz2
gentoo-2-b27bd35a6df733cbbd94fa5262fdceba6952fd63.zip
Update to EAPI 4, respect CFLAGS (bug #241988), restrict test phase (bug #320357), respect LDFLAGS (bug #336558), and fix various qa warnings.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hbaapi')
-rw-r--r--sys-apps/hbaapi/ChangeLog9
-rw-r--r--sys-apps/hbaapi/files/hbaapi-2.2-qa.patch37
-rw-r--r--sys-apps/hbaapi/hbaapi-2.2.ebuild26
3 files changed, 61 insertions, 11 deletions
diff --git a/sys-apps/hbaapi/ChangeLog b/sys-apps/hbaapi/ChangeLog
index 7228b2d46d9d..19d89d2cd893 100644
--- a/sys-apps/hbaapi/ChangeLog
+++ b/sys-apps/hbaapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hbaapi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hbaapi/ChangeLog,v 1.3 2009/02/09 00:35:36 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hbaapi/ChangeLog,v 1.4 2011/11/27 07:28:24 radhermit Exp $
+
+ 27 Nov 2011; Tim Harder <radhermit@gentoo.org> hbaapi-2.2.ebuild,
+ +files/hbaapi-2.2-qa.patch:
+ Update to EAPI 4, respect CFLAGS (bug #241988), restrict test phase (bug
+ #320357), respect LDFLAGS (bug #336558), and fix various qa warnings.
09 Feb 2009; Mike Frysinger <vapier@gentoo.org> hbaapi-2.2.ebuild:
Cleanup ebuild a bit.
diff --git a/sys-apps/hbaapi/files/hbaapi-2.2-qa.patch b/sys-apps/hbaapi/files/hbaapi-2.2-qa.patch
new file mode 100644
index 000000000000..240cc1d2d473
--- /dev/null
+++ b/sys-apps/hbaapi/files/hbaapi-2.2-qa.patch
@@ -0,0 +1,37 @@
+--- hbaapi_src_2.2.orig/HBAAPILIB.c
++++ hbaapi_src_2.2/HBAAPILIB.c
+@@ -30,7 +30,6 @@
+
+ #ifdef WIN32
+ #include <windows.h>
+-#include <string.h>
+ /*
+ * Next define forces entry points in the dll to be exported
+ * See hbaapi.h to see what it does.
+@@ -40,6 +39,7 @@
+ #include <dlfcn.h>
+ #include <strings.h>
+ #endif
++#include <string.h>
+ #include <stdio.h>
+ #include <time.h>
+ #include "hbaapi.h"
+@@ -395,7 +395,7 @@
+ GRAB_MUTEX(&_hbaapi_APSE_mutex);
+ GRAB_MUTEX(&_hbaapi_TE_mutex);
+ GRAB_MUTEX(&_hbaapi_LE_mutex);
+- for(listp = cb_lists_array, found = 0; found == 0, *listp != NULL; listp++) {
++ for(listp = cb_lists_array, found = 0; found == 0 && *listp != NULL; listp++) {
+ lastp = *listp;
+ for(cbp=**listp; cbp != NULL; cbp = cbp->next) {
+ if(cbhandle != (HBA_CALLBACKHANDLE)cbp) {
+--- hbaapi_src_2.2.orig/hbaapitest.c
++++ hbaapi_src_2.2/hbaapitest.c
+@@ -28,6 +28,7 @@
+
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifndef WIN32
+ #include <dlfcn.h> /* Dynamic library support for Solaris */
+ #include <time.h>
diff --git a/sys-apps/hbaapi/hbaapi-2.2.ebuild b/sys-apps/hbaapi/hbaapi-2.2.ebuild
index 255da0f7e306..b84df7ad8e42 100644
--- a/sys-apps/hbaapi/hbaapi-2.2.ebuild
+++ b/sys-apps/hbaapi/hbaapi-2.2.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hbaapi/hbaapi-2.2.ebuild,v 1.3 2009/02/09 00:35:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hbaapi/hbaapi-2.2.ebuild,v 1.4 2011/11/27 07:28:24 radhermit Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
MY_PN="${PN}_src"
MY_P="${MY_PN}_${PV}"
@@ -14,25 +18,29 @@ SLOT="0"
KEYWORDS="~ppc ~x86 ~amd64"
IUSE=""
-DEPEND=""
-RDEPEND=""
+RESTRICT="test"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
+src_prepare() {
mv "${WORKDIR}"/${P}.Makefile "${S}"/Makefile
+
+ sed -i -e "s/-g -c/${CFLAGS} -c/" \
+ -e "s/-shared/\0 ${LDFLAGS}/" \
+ Makefile || die
+
+ epatch "${FILESDIR}"/${P}-qa.patch
}
src_compile() {
# not parallel safe!
- emake -j1 all || die
+ emake -j1 CC="$(tc-getCC)" all
}
src_install() {
into /usr
- dolib.so libHBAAPI.so || die
- dosbin hbaapitest || die
+ dolib.so libHBAAPI.so
+ dosbin hbaapitest
insinto /etc
doins "${FILESDIR}"/hba.conf
dodoc readme.txt