summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-07 09:01:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-07 09:01:39 +0000
commitcdc44978e5eab7ef2e9146a51b1abc628a7a8a91 (patch)
tree6a450dba2caf01908a0cd4bfc208497a80c51df3 /sys-apps/grep
parentOld JasPer license no longer needed, see bug #240318 (diff)
downloadgentoo-2-cdc44978e5eab7ef2e9146a51b1abc628a7a8a91.tar.gz
gentoo-2-cdc44978e5eab7ef2e9146a51b1abc628a7a8a91.tar.bz2
gentoo-2-cdc44978e5eab7ef2e9146a51b1abc628a7a8a91.zip
Fix bug #238235. This is a very important upgrade for anybody using the 2.5.3-r0, which breaks grep -i in UTF-8 environments.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog8
-rw-r--r--sys-apps/grep/grep-2.5.3-r1.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 718eca0e842f..dd5bd8d4e53d 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.75 2008/09/19 21:28:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.76 2008/10/07 09:01:39 robbat2 Exp $
+
+*grep-2.5.3-r1 (07 Oct 2008)
+
+ 07 Oct 2008; Robin H. Johnson <robbat2@gentoo.org> +grep-2.5.3-r1.ebuild:
+ Fix bug #238235. This is a very important upgrade for anybody using the
+ 2.5.3-r0, which breaks grep -i in UTF-8 environments.
19 Sep 2008; Mike Frysinger <vapier@gentoo.org> grep-2.5.3.ebuild:
Apply Debian patchset to fix "-o -i" failures.
diff --git a/sys-apps/grep/grep-2.5.3-r1.ebuild b/sys-apps/grep/grep-2.5.3-r1.ebuild
new file mode 100644
index 000000000000..61e68a9087ec
--- /dev/null
+++ b/sys-apps/grep/grep-2.5.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.3-r1.ebuild,v 1.1 2008/10/07 09:01:39 robbat2 Exp $
+
+inherit flag-o-matic eutils
+
+DEB_VER="${PV}~dfsg-6"
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://debian/pool/main/g/grep/grep_${DEB_VER}.diff.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls pcre static"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ pcre? ( dev-libs/libpcre )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}"/grep_${DEB_VER}.diff
+ EPATCH_FORCE="yes" \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_MULTI_MSG="Applying Debian patchset (${DEB_VER}) ..." \
+ epatch ${P}~dfsg/debian/patches/
+
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp) \
+ --without-included-regex \
+ || die "econf failed"
+
+ use static || sed -i 's:-lpcre:-Wl,-Bstatic -lpcre -Wl,-Bdynamic:g' src/Makefile
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}