summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-24 21:59:36 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-24 21:59:36 +0000
commit79224575b5507886991d3c9c440ee3d4f631d5e2 (patch)
tree503ee483a90743e2df13d01110903ac827b8e4cb /sys-apps/gawk
parentMark stable for x86. (diff)
downloadgentoo-2-79224575b5507886991d3c9c440ee3d4f631d5e2.tar.gz
gentoo-2-79224575b5507886991d3c9c440ee3d4f631d5e2.tar.bz2
gentoo-2-79224575b5507886991d3c9c440ee3d4f631d5e2.zip
bump
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog7
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.1.21
-rw-r--r--sys-apps/gawk/gawk-3.1.2.ebuild68
3 files changed, 75 insertions, 1 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index a65eacea0d1a..44d74040e4ca 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/gawk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.13 2003/02/21 02:34:19 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.14 2003/03/24 21:59:36 lostlogic Exp $
+
+*gawk-3.1.2 (24 Mar 2003)
+
+ 24 Mar 2003; Brandon Low <lostlogic@gentoo.org> gawk-3.1.2.ebuild:
+ Bump
20 Feb 2003; Zach Welch <zwelch@gentoo.org> gawk-3.1.1-r1.ebuild :
Added arm to keywords.
diff --git a/sys-apps/gawk/files/digest-gawk-3.1.2 b/sys-apps/gawk/files/digest-gawk-3.1.2
new file mode 100644
index 000000000000..d002b5ee0638
--- /dev/null
+++ b/sys-apps/gawk/files/digest-gawk-3.1.2
@@ -0,0 +1 @@
+MD5 6d14f3c95669ace8c6aee2a96ba4eed7 gawk-3.1.2.tar.gz 2003860
diff --git a/sys-apps/gawk/gawk-3.1.2.ebuild b/sys-apps/gawk/gawk-3.1.2.ebuild
new file mode 100644
index 000000000000..df1d53bc0232
--- /dev/null
+++ b/sys-apps/gawk/gawk-3.1.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.2.ebuild,v 1.1 2003/03/24 21:59:36 lostlogic Exp $
+
+IUSE="nls build"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU awk pattern-matching language"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gawk/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/awk \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ bindir=${D}/bin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ libexecdir=${D}/usr/lib/awk \
+ install || die
+
+ cd ${D}/bin
+ rm -f gawk
+ ln -s gawk-${PV} gawk
+ #compat symlink
+ dodir /usr/bin
+ cd ${D}/usr/bin
+ ln -s /bin/gawk-${PV} awk
+ ln -s /bin/gawk-${PV} gawk
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
+ dodoc ChangeLog ACKNOWLEDGMENT COPYING FUTURES
+ dodoc LIMITATIONS NEWS PROBLEMS README
+ docinto README_d
+ dodoc README_d/*
+ docinto atari
+ dodoc atari/ChangeLog atari/README.1st
+ docinto awklib
+ dodoc awklib/ChangeLog
+ docinto pc
+ dodoc pc/ChangeLog
+ docinto posix
+ dodoc posix/ChangeLog
+ else
+ rm -rf ${D}/usr/share
+ fi
+}