summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-15 08:03:43 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-15 08:03:43 +0000
commit774887acde07b77be1a75f7991a744207fe8f2e4 (patch)
treed234e2a1500c5b87beee264e372c71ff491e1cd9 /sys-apps/file
parentAllow to build net-libs/libgadu without ssl, bug #363627 thank Bartosz Bracha... (diff)
downloadgentoo-2-774887acde07b77be1a75f7991a744207fe8f2e4.tar.gz
gentoo-2-774887acde07b77be1a75f7991a744207fe8f2e4.tar.bz2
gentoo-2-774887acde07b77be1a75f7991a744207fe8f2e4.zip
old
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-5.04.ebuild60
-rw-r--r--sys-apps/file/files/file-4.15-libtool.patch19
2 files changed, 0 insertions, 79 deletions
diff --git a/sys-apps/file/file-5.04.ebuild b/sys-apps/file/file-5.04.ebuild
deleted file mode 100644
index c5b1adc47735..000000000000
--- a/sys-apps/file/file-5.04.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.04.ebuild,v 1.10 2011/04/07 20:41:09 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit eutils distutils libtool flag-o-matic
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
- ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="python"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
-
- elibtoolize
- epunt_cxx
-
- # make sure python links against the current libmagic #54401
- sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
- # dont let python README kill main README #60043
- mv python/README{,.python}
-}
-
-src_configure() {
- # file uses things like strndup() and wcwidth()
- append-flags -D_GNU_SOURCE
-
- econf
-}
-
-src_compile() {
- emake || die
-
- use python && cd python && distutils_src_compile
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog MAINT README
-
- use python && cd python && distutils_src_install
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sys-apps/file/files/file-4.15-libtool.patch b/sys-apps/file/files/file-4.15-libtool.patch
deleted file mode 100644
index c41c8fec297d..000000000000
--- a/sys-apps/file/files/file-4.15-libtool.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Fix build time issues with tools who like to export LD_LIBRARY_PATH
-to retarded values.
-
-http://bugs.gentoo.org/99593
-
---- ltmain.sh
-+++ ltmain.sh
-@@ -5085,6 +5085,11 @@
- $echo >> $output "\
- if test \"\$libtool_execute_magic\" != \"$magic\"; then
- # Run the actual program with our arguments.
-+
-+ # Make sure env LD_LIBRARY_PATH does not mess us up
-+ if test -n \"\${LD_LIBRARY_PATH+set}\"; then
-+ export LD_LIBRARY_PATH=\$progdir:\$LD_LIBRARY_PATH
-+ fi
- "
- case $host in
- # Backslashes separate directories on plain windows