summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-10 05:06:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-10 05:06:07 +0000
commit92f0c6181f43278b040a9aa0e5299c910b672e2d (patch)
treeb85e92a72b6dda3d8f14e74c8a46759f27105773 /sys-apps/dnotify
parentx86 stable wrt security bug #336321 (diff)
downloadgentoo-2-92f0c6181f43278b040a9aa0e5299c910b672e2d.tar.gz
gentoo-2-92f0c6181f43278b040a9aa0e5299c910b672e2d.tar.bz2
gentoo-2-92f0c6181f43278b040a9aa0e5299c910b672e2d.zip
Fix building with recent glibc wrt #336649 by Jochen Schlick.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dnotify')
-rw-r--r--sys-apps/dnotify/ChangeLog8
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0.ebuild23
-rw-r--r--sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch12
3 files changed, 30 insertions, 13 deletions
diff --git a/sys-apps/dnotify/ChangeLog b/sys-apps/dnotify/ChangeLog
index 41fba72c34cc..e60f82df268c 100644
--- a/sys-apps/dnotify/ChangeLog
+++ b/sys-apps/dnotify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/dnotify
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/ChangeLog,v 1.23 2008/01/10 10:40:22 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/ChangeLog,v 1.24 2010/09/10 05:06:06 ssuominen Exp $
+
+ 10 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> dnotify-0.18.0.ebuild,
+ +files/dnotify-0.18.0-glibc-212.patch:
+ Fix building with recent glibc wrt #336649 by Jochen Schlick.
10 Jan 2008; Mike Frysinger <vapier@gentoo.org> dnotify-0.18.0.ebuild:
Update HOMEPAGE #205167 and touchup ebuild.
diff --git a/sys-apps/dnotify/dnotify-0.18.0.ebuild b/sys-apps/dnotify/dnotify-0.18.0.ebuild
index ac82def8d29a..4d4578ea9bfa 100644
--- a/sys-apps/dnotify/dnotify-0.18.0.ebuild
+++ b/sys-apps/dnotify/dnotify-0.18.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/dnotify-0.18.0.ebuild,v 1.9 2008/01/10 10:40:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/dnotify-0.18.0.ebuild,v 1.10 2010/09/10 05:06:06 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Execute a command when the contents of a directory change"
@@ -10,23 +11,23 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 mips ppc -sparc x86"
+KEYWORDS="amd64 ~mips ppc -sparc x86"
IUSE="nls"
+RDEPEND=""
DEPEND="nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-nls.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nls.patch \
+ "${FILESDIR}"/${P}-glibc-212.patch
}
-src_compile() {
- econf $(use_enable nls) || die "failed to configure"
- emake || die "failed to make"
+src_configure() {
+ econf \
+ $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS TODO NEWS README
}
diff --git a/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch b/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch
new file mode 100644
index 000000000000..6cc6e6f40092
--- /dev/null
+++ b/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/336649
+
+--- src/main.c
++++ src/main.c
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <stdarg.h>
+ #include <errno.h>