summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-11-29 20:07:40 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-11-29 20:07:40 +0000
commit02aa7316399c8bde118597e76a0b63c5f0a39f28 (patch)
tree508617bebf653913bf310aea8545ba5b6a56bbd0 /sys-apps/dmidecode
parentAdding ebuild from bug 72658 thanks to Bernd Westermann <Bernd.Westermann@it-... (diff)
downloadgentoo-2-02aa7316399c8bde118597e76a0b63c5f0a39f28.tar.gz
gentoo-2-02aa7316399c8bde118597e76a0b63c5f0a39f28.tar.bz2
gentoo-2-02aa7316399c8bde118597e76a0b63c5f0a39f28.zip
Version bump, closes bug #72810. 2.4 stable on x86.
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/ChangeLog8
-rw-r--r--sys-apps/dmidecode/Manifest6
-rw-r--r--sys-apps/dmidecode/dmidecode-2.4.ebuild4
-rw-r--r--sys-apps/dmidecode/dmidecode-2.5.ebuild38
-rw-r--r--sys-apps/dmidecode/files/digest-dmidecode-2.51
5 files changed, 52 insertions, 5 deletions
diff --git a/sys-apps/dmidecode/ChangeLog b/sys-apps/dmidecode/ChangeLog
index fb0b51ae739a..efb0051113dc 100644
--- a/sys-apps/dmidecode/ChangeLog
+++ b/sys-apps/dmidecode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dmidecode
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.2 2004/09/03 00:34:49 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.3 2004/11/29 20:07:40 chainsaw Exp $
+
+*dmidecode-2.5 (29 Nov 2004)
+
+ 29 Nov 2004; Tony Vroon <chainsaw@gentoo.org> dmidecode-2.4.ebuild,
+ +dmidecode-2.5.ebuild:
+ Version bump, closes bug #72810. 2.4 stable on x86.
03 Sep 2004; David Holm <dholm@gentoo.org> dmidecode-2.4.ebuild:
Added to ~ppc.
diff --git a/sys-apps/dmidecode/Manifest b/sys-apps/dmidecode/Manifest
index 2e5e33102ec9..747f9b4c6980 100644
--- a/sys-apps/dmidecode/Manifest
+++ b/sys-apps/dmidecode/Manifest
@@ -1,4 +1,6 @@
-MD5 6d7e048f14d21bfdd39f8f2636949f8f ChangeLog 439
-MD5 fc9d31db0b151398f5ac48477e2a9b3f dmidecode-2.4.ebuild 921
+MD5 878639bc98c62db54a85ad6491a97862 dmidecode-2.5.ebuild 837
+MD5 6b0168a701ba8f06421b510ca582936b dmidecode-2.4.ebuild 920
+MD5 0d14a820e86f275d8ff173c0da68ef53 ChangeLog 619
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 6a74ce88ec57714cc3170b034b461293 files/digest-dmidecode-2.4 65
+MD5 726d1af1a9d1b6f95db131bcb57db2aa files/digest-dmidecode-2.5 65
diff --git a/sys-apps/dmidecode/dmidecode-2.4.ebuild b/sys-apps/dmidecode/dmidecode-2.4.ebuild
index 406b071f5c11..0a88e64b15d9 100644
--- a/sys-apps/dmidecode/dmidecode-2.4.ebuild
+++ b/sys-apps/dmidecode/dmidecode-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.4.ebuild,v 1.2 2004/09/03 00:34:49 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.4.ebuild,v 1.3 2004/11/29 20:07:40 chainsaw Exp $
inherit flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://savannah.nongnu.org/download/dmidecode/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ia64 ~ppc"
+KEYWORDS="x86 ~amd64 ~ia64 ~ppc"
IUSE=""
DEPEND=">=sys-apps/sed-4"
diff --git a/sys-apps/dmidecode/dmidecode-2.5.ebuild b/sys-apps/dmidecode/dmidecode-2.5.ebuild
new file mode 100644
index 000000000000..7a7ff6b4f671
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.5.ebuild,v 1.1 2004/11/29 20:07:40 chainsaw Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/dmidecode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use ia64 && append-flags -D__IA64__
+ sed -i \
+ -e "s:-O2:${CFLAGS}${ARCHFLAGS}:" \
+ -e "s:man/man8:share/man/man8:g" \
+ -e "s:/usr/local:${D}/usr:" \
+ Makefile || die "manpage sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/sbin /usr/share/man/man8
+ make install || die "make install failed"
+ dodoc README AUTHORS CHANGELOG
+}
diff --git a/sys-apps/dmidecode/files/digest-dmidecode-2.5 b/sys-apps/dmidecode/files/digest-dmidecode-2.5
new file mode 100644
index 000000000000..0fb20c0b20fb
--- /dev/null
+++ b/sys-apps/dmidecode/files/digest-dmidecode-2.5
@@ -0,0 +1 @@
+MD5 df1900d748cc227fcac31552ce558574 dmidecode-2.5.tar.bz2 38171