summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-31 10:40:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-31 10:40:07 +0000
commit34264f79a88fd6fb6779e416bcb3a25d11f2d993 (patch)
tree27e64235b0bdb9b156b7e34c3f06b22c0383e9f3 /sys-apps/dmapi
parentfix the locale fix so that it works for apps other than adobe acrobat (Manife... (diff)
downloadgentoo-2-34264f79a88fd6fb6779e416bcb3a25d11f2d993.tar.gz
gentoo-2-34264f79a88fd6fb6779e416bcb3a25d11f2d993.tar.bz2
gentoo-2-34264f79a88fd6fb6779e416bcb3a25d11f2d993.zip
Cleanup of XFS-related apps: dmapi, acl, xfsdump, attr.
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/ChangeLog5
-rw-r--r--sys-apps/dmapi/Manifest2
-rw-r--r--sys-apps/dmapi/dmapi-2.2.0.ebuild59
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-2.2.01
4 files changed, 66 insertions, 1 deletions
diff --git a/sys-apps/dmapi/ChangeLog b/sys-apps/dmapi/ChangeLog
index 86f55df0b8e5..921a1b5a3a3a 100644
--- a/sys-apps/dmapi/ChangeLog
+++ b/sys-apps/dmapi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/dmapi
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.20 2004/06/30 15:19:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.21 2004/08/31 10:40:07 robbat2 Exp $
+
+ 31 Aug 2004; Robin H. Johnson <robbat2@gentoo.org> :
+ Cleanup of XFS-related apps: dmapi, acl, xfsdump, attr.
30 Jun 2004; Aron Griffis <agriffis@gentoo.org> dmapi-2.0.5-r1.ebuild:
sync IUSE (missing)
diff --git a/sys-apps/dmapi/Manifest b/sys-apps/dmapi/Manifest
index 7634050cb016..bade9c55fb07 100644
--- a/sys-apps/dmapi/Manifest
+++ b/sys-apps/dmapi/Manifest
@@ -1,4 +1,6 @@
+MD5 90e3b26482c8c7cb01e5518d7493fd89 dmapi-2.2.0.ebuild 1275
MD5 421213c3cac85027806d02e69b9e9dca dmapi-2.0.5-r1.ebuild 1138
MD5 ee37c8f5df41f6a0e38704056ff282f3 ChangeLog 2650
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 b6bfbe8bb8ef997f32aa53f211ab8651 files/digest-dmapi-2.2.0 66
MD5 2418eac09140fabcd9c755c25629a0dd files/digest-dmapi-2.0.5-r1 66
diff --git a/sys-apps/dmapi/dmapi-2.2.0.ebuild b/sys-apps/dmapi/dmapi-2.2.0.ebuild
new file mode 100644
index 000000000000..754a2228378c
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.0.ebuild,v 1.1 2004/08/31 10:40:07 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~ia64 ~amd64 ~alpha"
+IUSE="debug static"
+
+DEPEND="sys-fs/xfsprogs"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e 's:^PKG_\(.*\)_DIR[[:space:]]*= \(.*\)$:PKG_\1_DIR = $(DESTDIR)\2:' \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.in || die
+}
+
+src_compile() {
+ if use debug; then
+ DEBUG=-DDEBUG
+ OPTIMIZER="-g"
+ CFLAGS=
+ CXXFLAGS=
+ export CFLAGS CXXFLAGS
+ else
+ DEBUG=-DNDEBUG
+ OPTIMIZER="${CFLAGS}"
+ fi
+ export DEBUG OPTIMIZER
+
+ # Some archs need the PLATFORM var unset
+ if hasq ${ARCH} mips ppc sparc ppc64 s390; then
+ unset PLATFORM
+ fi
+
+ autoconf || die
+
+ local myconf
+ LIBDIR="`get_libdir`"
+ myconf="${myconf} --libdir=/${LIBDIR} --libexecdir=/usr/${LIBDIR}"
+ myconf="${myconf} `use_enable !static shared`"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-2.2.0 b/sys-apps/dmapi/files/digest-dmapi-2.2.0
new file mode 100644
index 000000000000..613ce8a9ffd3
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-2.2.0
@@ -0,0 +1 @@
+MD5 f928d849584d97e6a65dced71f8c10a5 dmapi-2.2.0.src.tar.gz 77289