summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-02-23 11:00:28 +0000
committerRoy Marples <uberlord@gentoo.org>2007-02-23 11:00:28 +0000
commitefb71753c5064e3a5811eca83d965c57c8273577 (patch)
treef31d54061f9b68bd5b1065b7ca79940e30ed0a37 /sys-apps/dbus
parentBump for a non bash init script. (diff)
downloadgentoo-2-efb71753c5064e3a5811eca83d965c57c8273577.tar.gz
gentoo-2-efb71753c5064e3a5811eca83d965c57c8273577.tar.bz2
gentoo-2-efb71753c5064e3a5811eca83d965c57c8273577.zip
Bump for a non bash init script.
(Portage version: 2.1.2-r10)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog8
-rw-r--r--sys-apps/dbus/dbus-1.0.2-r1.ebuild114
-rw-r--r--sys-apps/dbus/files/dbus.init-1.06
-rw-r--r--sys-apps/dbus/files/digest-dbus-1.0.2-r13
4 files changed, 127 insertions, 4 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 4287c6d27ef4..56dbd8e9bacd 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.184 2007/02/09 22:27:05 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.185 2007/02/23 11:00:28 uberlord Exp $
+
+*dbus-1.0.2-r1 (23 Feb 2007)
+
+ 23 Feb 2007; Roy Marples <uberlord@gentoo.org> files/dbus.init-1.0,
+ +dbus-1.0.2-r1.ebuild:
+ Bump for a non bash init script.
09 Feb 2007; Alexander H. Færøy <eroyf@gentoo.org> dbus-1.0.2.ebuild:
Stable on MIPS; bug #154522
diff --git a/sys-apps/dbus/dbus-1.0.2-r1.ebuild b/sys-apps/dbus/dbus-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..a37326774e54
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.0.2-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.2-r1.ebuild,v 1.1 2007/02/23 11:00:28 uberlord Exp $
+
+inherit eutils multilib autotools
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="debug doc selinux X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+ selinux? ( sys-libs/libselinux )
+ >=dev-libs/expat-1.95.8
+ !<sys-apps/dbus-0.91"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix dnotify issue with not detecting created files
+ epatch "${FILESDIR}"/${PN}-1.0.1-fixfilecreation.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ hasq test ${FEATURES} && myconf="${myconf} --enable-tests=yes"
+
+ econf \
+ $(use_with X x) \
+ $(use_enable kernel_linux dnotify) \
+ $(use_enable kernel_FreeBSD kqueue) \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug asserts) \
+ --with-xml=expat \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-1.0 dbus
+
+ # dbus X session script (#77504)
+ # turns out to only work for GDM. has been merged into other desktop
+ # (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+ # needs to exist for machine id
+ keepdir /var/lib/dbus
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog
+ elog "If dbus is already installed and running,"
+ elog "run etc-update and then run the following:"
+ elog "\`/etc/init.d/dbus reload\`"
+ elog "This will cause it to reload it's configs but"
+ elog "*not* run the newest version you just installed."
+ elog "You must tell it to restart for that to happen,"
+ elog "however not all apps can handle a D-Bus restart."
+ elog
+ ewarn
+ ewarn "You MUST run 'revdep-rebuild' after emerging this package"
+ ewarn
+}
diff --git a/sys-apps/dbus/files/dbus.init-1.0 b/sys-apps/dbus/files/dbus.init-1.0
index ba0f4e71c23c..086aa2132b60 100644
--- a/sys-apps/dbus/files/dbus.init-1.0
+++ b/sys-apps/dbus/files/dbus.init-1.0
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.init-1.0,v 1.2 2007/01/08 13:10:21 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.init-1.0,v 1.3 2007/02/23 11:00:28 uberlord Exp $
opts="reload"
@@ -16,7 +16,7 @@ start() {
/usr/bin/dbus-uuidgen --ensure
# We need to test if /var/run/dbus exists, since script will fail if it does not
- [[ ! -e /var/run/dbus ]] && mkdir /var/run/dbus
+ [ ! -e /var/run/dbus ] && mkdir /var/run/dbus
start-stop-daemon --start --pidfile /var/run/dbus.pid --exec /usr/bin/dbus-daemon -- --system
eend $?
@@ -32,7 +32,7 @@ stop() {
eend ${retval}
- [[ -S /var/run/dbus/system_bus_socket ]] && rm -f /var/run/dbus/system_bus_socket
+ [ -S /var/run/dbus/system_bus_socket ] && rm -f /var/run/dbus/system_bus_socket
return ${retval}
}
diff --git a/sys-apps/dbus/files/digest-dbus-1.0.2-r1 b/sys-apps/dbus/files/digest-dbus-1.0.2-r1
new file mode 100644
index 000000000000..55bc8dd8333d
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-1.0.2-r1
@@ -0,0 +1,3 @@
+MD5 0552a9b54beb4a044951b7cdbc8fc855 dbus-1.0.2.tar.gz 1400278
+RMD160 d5eddfb058c4c026d4a9f091ad90abcc6e54861a dbus-1.0.2.tar.gz 1400278
+SHA256 8a004125f58512a69575f21f105aead0d1217fce9cb54cbafeac06b4be28c6ca dbus-1.0.2.tar.gz 1400278