summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2008-01-16 02:18:59 +0000
committerStephen Klimaszewski <steev@gentoo.org>2008-01-16 02:18:59 +0000
commit5541e4f3b4580bbabb0e9747f3a31a5aace06e14 (patch)
tree395265e41f1bf4ebb487b79ce16b811278bf2007 /sys-apps/dbus
parentBackport fix for network route troubles #205894 and revert an accidental inpu... (diff)
downloadgentoo-2-5541e4f3b4580bbabb0e9747f3a31a5aace06e14.tar.gz
gentoo-2-5541e4f3b4580bbabb0e9747f3a31a5aace06e14.tar.bz2
gentoo-2-5541e4f3b4580bbabb0e9747f3a31a5aace06e14.zip
New upstream release. This is 1.2RC0. Give it some testing.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog10
-rw-r--r--sys-apps/dbus/dbus-1.1.3.ebuild109
-rw-r--r--sys-apps/dbus/files/digest-dbus-1.1.33
3 files changed, 120 insertions, 2 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 44dbaae9de91..7ae67a096d7e 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.201 2007/12/13 20:04:31 cardoe Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.202 2008/01/16 02:18:59 steev Exp $
+
+*dbus-1.1.3 (16 Jan 2008)
+
+ 16 Jan 2008; Steev Klimaszewski <steev@gentoo.org> +dbus-1.1.3.ebuild:
+ New upstream release, this is 1.2RC0, very stable release, give it some
+ testing!
13 Dec 2007; Doug Klima <cardoe@gentoo.org> -dbus-1.0.2-r1.ebuild:
remove old version
diff --git a/sys-apps/dbus/dbus-1.1.3.ebuild b/sys-apps/dbus/dbus-1.1.3.ebuild
new file mode 100644
index 000000000000..3f3f274e3987
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.1.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.1.3.ebuild,v 1.1 2008/01/16 02:18:59 steev Exp $
+
+inherit eutils multilib autotools flag-o-matic
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc selinux X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+ selinux? ( sys-libs/libselinux
+ sec-policy/selinux-dbus )
+ >=dev-libs/expat-1.95.8
+ !<sys-apps/dbus-0.91"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
+
+src_compile() {
+ # so we can get backtraces from apps
+ append-flags -rdynamic
+
+ local myconf=""
+
+ hasq test ${FEATURES} && myconf="${myconf} --enable-tests=yes"
+
+ econf \
+ $(use_with X x) \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable kernel_FreeBSD kqueue) \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug asserts) \
+ --with-xml=expat \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-1.0 dbus
+
+ # dbus X session script (#77504)
+ # turns out to only work for GDM. has been merged into other desktop
+ # (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+ # needs to exist for machine id
+ keepdir /var/lib/dbus
+ # needs to exist for dbus sessions to launch
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+ keepdir /etc/dbus-1/system.d/
+ keepdir /etc/dbus-1/session.d/
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog
+ elog "Somme applications require a session bus in addition to the system"
+ elog "bus. Please see \`man dbus-launch\` for more information."
+ elog
+ ewarn
+ ewarn "You MUST run 'revdep-rebuild' after emerging this package"
+ elog "If you notice any issues, please rebuild sys-apps/hal"
+ ewarn
+}
diff --git a/sys-apps/dbus/files/digest-dbus-1.1.3 b/sys-apps/dbus/files/digest-dbus-1.1.3
new file mode 100644
index 000000000000..751e788b4c1e
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-1.1.3
@@ -0,0 +1,3 @@
+MD5 2e0185e1f8b4c61c9248049c680d2ab6 dbus-1.1.3.tar.gz 1400207
+RMD160 e8d3bd4015cda0e13482940105ff364a82021535 dbus-1.1.3.tar.gz 1400207
+SHA256 964d8d15c1ed01d74efd8d4c74ed70bb137cc9ed152ab118de972a4968e51b5f dbus-1.1.3.tar.gz 1400207