summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-03-10 06:03:39 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-03-10 06:03:39 +0000
commitaa9700b1a9458fbc63d03f002c3090c0fd1ab463 (patch)
treec39c0e67fda83795256df0d131b8ff93b53ff259 /sys-apps/cpuid
parentVersion bump (bug #406725). Add myself to metatdata.xml. (diff)
downloadgentoo-2-aa9700b1a9458fbc63d03f002c3090c0fd1ab463.tar.gz
gentoo-2-aa9700b1a9458fbc63d03f002c3090c0fd1ab463.tar.bz2
gentoo-2-aa9700b1a9458fbc63d03f002c3090c0fd1ab463.zip
Version bump.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/ChangeLog7
-rw-r--r--sys-apps/cpuid/cpuid-20120225.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/sys-apps/cpuid/ChangeLog b/sys-apps/cpuid/ChangeLog
index 6a45645f144e..d6b3eef6c7cd 100644
--- a/sys-apps/cpuid/ChangeLog
+++ b/sys-apps/cpuid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/cpuid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/ChangeLog,v 1.3 2012/03/06 04:39:41 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/ChangeLog,v 1.4 2012/03/10 06:03:39 dirtyepic Exp $
+
+*cpuid-20120225 (10 Mar 2012)
+
+ 10 Mar 2012; Ryan Hill <dirtyepic@gentoo.org> +cpuid-20120225.ebuild:
+ Version bump.
06 Mar 2012; Ryan Hill <dirtyepic@gentoo.org> metadata.xml:
Add myself to metadata.xml.
diff --git a/sys-apps/cpuid/cpuid-20120225.ebuild b/sys-apps/cpuid/cpuid-20120225.ebuild
new file mode 100644
index 000000000000..a9f32178d0ea
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20120225.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/cpuid-20120225.ebuild,v 1.1 2012/03/10 06:03:39 dirtyepic Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20110305-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-20110305-fPIC.patch #376245
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}