summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-20 00:34:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-20 00:34:37 +0000
commit4b0290dbe113d0a133783ad00d7abe81e1198701 (patch)
treefdd007a6bdc47fe41d470bb80e6d98c787e8d213 /sys-apps/cpudyn/cpudyn-0.5.0.ebuild
parentdigest fix (diff)
downloadgentoo-2-4b0290dbe113d0a133783ad00d7abe81e1198701.tar.gz
gentoo-2-4b0290dbe113d0a133783ad00d7abe81e1198701.tar.bz2
gentoo-2-4b0290dbe113d0a133783ad00d7abe81e1198701.zip
fixed bugs #38482, #37619, #32523.
Diffstat (limited to 'sys-apps/cpudyn/cpudyn-0.5.0.ebuild')
-rw-r--r--sys-apps/cpudyn/cpudyn-0.5.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/cpudyn/cpudyn-0.5.0.ebuild b/sys-apps/cpudyn/cpudyn-0.5.0.ebuild
new file mode 100644
index 000000000000..d8eaf24d9d79
--- /dev/null
+++ b/sys-apps/cpudyn/cpudyn-0.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpudyn/cpudyn-0.5.0.ebuild,v 1.1 2004/01/20 00:34:36 robbat2 Exp $
+
+DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
+HOMEPAGE="http://mnm.uib.es/~gallir/${PN}/"
+SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir gentoo
+ cp debian/cpudyn.conf gentoo
+ cp ${FILESDIR}/cpudyn.init gentoo
+ epatch ${FILESDIR}/${P}-init_conf_updates.patch
+}
+
+src_compile() {
+ emake cpudynd || die "Compilation failed."
+}
+
+src_install() {
+ into /
+ exeinto /etc/init.d
+ newexe gentoo/cpudyn.init cpudyn
+ insinto /etc/conf.d
+ newins gentoo/cpudyn.conf cpudyn
+
+ into /usr
+ doman cpudynd.8
+ dosbin cpudynd
+ dodoc INSTALL README VERSION changelog COPYING
+ dohtml *.html
+}
+
+pkg_postinst() {
+ einfo "Configuration file is /etc/conf.d/cpudyn."
+}