summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ostrow <dostrow@gentoo.org>2005-04-12 03:53:24 +0000
committerDaniel Ostrow <dostrow@gentoo.org>2005-04-12 03:53:24 +0000
commitabecc89bb969dc73e38a17f06f7a6e6108609842 (patch)
tree8a8180e2e06f2238897f70d7ee6f7bddbcb49b45 /sys-apps/coreutils
parentgcc4 version bump (diff)
downloadgentoo-2-abecc89bb969dc73e38a17f06f7a6e6108609842.tar.gz
gentoo-2-abecc89bb969dc73e38a17f06f7a6e6108609842.tar.bz2
gentoo-2-abecc89bb969dc73e38a17f06f7a6e6108609842.zip
Changes for ppc64 hardened
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog6
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r5.ebuild11
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r6.ebuild11
3 files changed, 23 insertions, 5 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 8b04fc5530f7..f2bc412a1c74 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.126 2005/04/09 12:55:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.127 2005/04/12 03:53:24 dostrow Exp $
+
+ 12 Apr 2005; Daniel Ostrow <dostrow@gentoo.org> coreutils-5.2.1-r5.ebuild,
+ coreutils-5.2.1-r6.ebuild:
+ Changes for ppc64 hardened
09 Apr 2005; Markus Rothe <corsair@gentoo.org> coreutils-5.2.1-r5.ebuild:
Stable on ppc64
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r5.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r5.ebuild
index f9a8bb46742d..59a421056037 100644
--- a/sys-apps/coreutils/coreutils-5.2.1-r5.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r5.ebuild,v 1.4 2005/04/09 12:55:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r5.ebuild,v 1.5 2005/04/12 03:53:24 dostrow Exp $
inherit eutils flag-o-matic
@@ -21,7 +21,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ia64 m68k ~mips ~ppc ppc64 s390 sh sparc x86"
-IUSE="nls build acl selinux static uclibc"
+IUSE="nls build acl selinux static uclibc hardened"
RDEPEND="selinux? ( sys-libs/libselinux )
acl? ( sys-apps/acl sys-apps/attr )
@@ -71,6 +71,13 @@ src_unpack() {
# When cross-compiling, we can't do that since 'bin' isn't
# a native binary, so let's just install outdated man-pages.
[[ ${CTARGET:-${CHOST}} != ${CHOST} ]] && touch man/*.1
+
+ # Rebuild of manpage seq.1 fails with ppc64 hardened so
+ # We'll install the outdated copy.
+ if use ppc64 && use hardened; then
+ touch man/seq.1
+ fi
+
}
src_compile() {
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
index c974bde09cdb..cedd84deecdb 100644
--- a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild,v 1.2 2005/04/02 04:49:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild,v 1.3 2005/04/12 03:53:24 dostrow Exp $
inherit eutils flag-o-matic
@@ -18,7 +18,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls build acl selinux static uclibc"
+IUSE="nls build acl selinux static uclibc hardened"
RDEPEND="selinux? ( sys-libs/libselinux )
acl? ( sys-apps/acl sys-apps/attr )
@@ -67,6 +67,13 @@ src_unpack() {
# When cross-compiling, we can't do that since 'bin' isn't
# a native binary, so let's just install outdated man-pages.
[[ ${CTARGET:-${CHOST}} != ${CHOST} ]] && touch man/*.1
+
+ # Rebuild of manpage seq.1 fails with ppc64 hardened so
+ # We'll install the outdated copy.
+ if use ppc64 && use hardened; then
+ touch man/seq.1
+ fi
+
}
src_compile() {