summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-17 19:17:45 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-17 19:17:45 +0000
commit9cb533b4bc8eedf43d7c56b4cb134b6731b73cef (patch)
tree7285e4c26162625d3ea31948d9cea84756e846a5 /sys-apps/collectl/collectl-3.4.1.ebuild
parentUpdated live ebuild, Bug #327823. (diff)
downloadgentoo-2-9cb533b4bc8eedf43d7c56b4cb134b6731b73cef.tar.gz
gentoo-2-9cb533b4bc8eedf43d7c56b4cb134b6731b73cef.tar.bz2
gentoo-2-9cb533b4bc8eedf43d7c56b4cb134b6731b73cef.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/collectl/collectl-3.4.1.ebuild')
-rw-r--r--sys-apps/collectl/collectl-3.4.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/collectl/collectl-3.4.1.ebuild b/sys-apps/collectl/collectl-3.4.1.ebuild
new file mode 100644
index 000000000000..e1a1049a640e
--- /dev/null
+++ b/sys-apps/collectl/collectl-3.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/collectl/collectl-3.4.1.ebuild,v 1.1 2010/07/17 19:17:45 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="light-weight performance monitoring tool capable of reporting interactively as well as logging to disk"
+HOMEPAGE="http://collectl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/collectl/${P}.src.tar.gz"
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8.8
+ virtual/perl-Time-HiRes
+ >=dev-perl/Archive-Zip-1.20
+ sys-apps/ethtool
+ sys-apps/pciutils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4.1-install.patch
+ sed -i \
+ -e "/^DOCDIR/s:doc/collectl:doc/${PF}:" \
+ INSTALL || die
+}
+
+src_install() {
+ DESTDIR=${D} bash -ex ./INSTALL || die
+
+ rm "${D}"/etc/init.d/* || die
+ newinitd "${FILESDIR}"/collectl.initd collectl
+
+ cd "${D}"/usr/share/doc/${PF}
+ dohtml * || die
+ rm -f ARTISTIC GPL COPYING *.html *.jpg *.css || die
+ prepalldocs
+}