summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-04 17:45:11 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-04 17:45:11 +0000
commit80adb9f4afa4613b8d426c9c7579d8261680aafb (patch)
treec9fc126c5f384efce52af0ee4160141f73acb87c /sys-apps/busybox
parentMark 4.4.0-r4 stable on ia64 (diff)
downloadgentoo-2-80adb9f4afa4613b8d426c9c7579d8261680aafb.tar.gz
gentoo-2-80adb9f4afa4613b8d426c9c7579d8261680aafb.tar.bz2
gentoo-2-80adb9f4afa4613b8d426c9c7579d8261680aafb.zip
fix the `bb` alias
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.1.0.ebuild12
-rw-r--r--sys-apps/busybox/files/1.1.0/bb.patch6
2 files changed, 8 insertions, 10 deletions
diff --git a/sys-apps/busybox/busybox-1.1.0.ebuild b/sys-apps/busybox/busybox-1.1.0.ebuild
index a245c24b5be0..3b6552c53522 100644
--- a/sys-apps/busybox/busybox-1.1.0.ebuild
+++ b/sys-apps/busybox/busybox-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.0.ebuild,v 1.1 2006/02/01 02:34:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.0.ebuild,v 1.2 2006/02/04 17:45:11 vapier Exp $
inherit eutils
@@ -56,15 +56,7 @@ src_unpack() {
cd "${S}"
# patches go here!
-# epatch "${FILESDIR}"/1.00/busybox-read-timeout.patch
-# epatch "${FILESDIR}"/1.00/readlink-follow.patch
-# epatch "${FILESDIR}"/1.00/more-insmod-arches.patch
-# epatch "${FILESDIR}"/1.00/bash-tests.patch
-# epatch "${FILESDIR}"/1.00/standalone.patch
-# epatch "${FILESDIR}"/1.00/nice.patch
-# epatch "${FILESDIR}"/1.00/printenv.patch
-# epatch "${FILESDIR}"/1.00/sum.patch
- epatch "${FILESDIR}"/1.00/bb.patch
+ epatch "${FILESDIR}"/1.1.0/bb.patch
# check for a busybox config before making one of our own.
# if one exist lets return and use it.
diff --git a/sys-apps/busybox/files/1.1.0/bb.patch b/sys-apps/busybox/files/1.1.0/bb.patch
new file mode 100644
index 000000000000..fc90b00c8793
--- /dev/null
+++ b/sys-apps/busybox/files/1.1.0/bb.patch
@@ -0,0 +1,6 @@
+--- include/applets.h
++++ include/applets.h
+@@ -78,2 +78,3 @@
+ #endif
++ APPLET_NOUSAGE("bb", ash_main, _BB_DIR_BIN, _BB_SUID_NEVER)
+ #ifdef CONFIG_BBCONFIG